aboutsummaryrefslogtreecommitdiff
path: root/Mac
diff options
context:
space:
mode:
authorNed Deily <nad@python.org>2020-05-18 11:31:21 -0400
committerGitHub <noreply@github.com>2020-05-18 11:31:21 -0400
commit951ab58024de9b5a21f0b979cdbea51e1049d781 (patch)
tree1ea404d9518f6db5d8c1f16435366a8c1716b365 /Mac
parentbpo-38112: Document that compileall.compile_[dir,file] also accept multiple o... (diff)
downloadcpython-951ab58024de9b5a21f0b979cdbea51e1049d781.tar.gz
cpython-951ab58024de9b5a21f0b979cdbea51e1049d781.tar.bz2
cpython-951ab58024de9b5a21f0b979cdbea51e1049d781.zip
Revert "bpo-26317: Support OBJC and OBJCXX configure command line variables (GH-20176)" (GH-20182)
This reverts commit 0da546665075aefbb476e192ed64122d340164f4. The commit is causing make failures on a FreeBSD buildbot. Due to the imminent 3.9.0b1 cutoff, revert this commit for now pending further investigation.
Diffstat (limited to 'Mac')
-rw-r--r--Mac/Makefile.in1
-rw-r--r--Mac/PythonLauncher/Makefile.in16
2 files changed, 7 insertions, 10 deletions
diff --git a/Mac/Makefile.in b/Mac/Makefile.in
index db59fc5d7f5..0b32673323a 100644
--- a/Mac/Makefile.in
+++ b/Mac/Makefile.in
@@ -21,7 +21,6 @@ PYTHONFRAMEWORK=@PYTHONFRAMEWORK@
PYTHONFRAMEWORKIDENTIFIER=@PYTHONFRAMEWORKIDENTIFIER@
LIPO_32BIT_FLAGS=@LIPO_32BIT_FLAGS@
CC=@CC@
-OBJC=@OBJC@
MACOSX_DEPLOYMENT_TARGET=@CONFIGURE_MACOSX_DEPLOYMENT_TARGET@
export MACOSX_DEPLOYMENT_TARGET
diff --git a/Mac/PythonLauncher/Makefile.in b/Mac/PythonLauncher/Makefile.in
index 1553b759051..4c05f26e835 100644
--- a/Mac/PythonLauncher/Makefile.in
+++ b/Mac/PythonLauncher/Makefile.in
@@ -1,7 +1,5 @@
CC=@CC@
LD=@CC@
-OBJC=@OBJC@
-OBJCFLAFS=@OBJCFLAGS@
BASECFLAGS=@BASECFLAGS@
OPT=@OPT@
CFLAGS=@CFLAGS@ $(BASECFLAGS) $(OPT)
@@ -54,25 +52,25 @@ Python\ Launcher.app: Info.plist \
cp -R $(srcdir)/English.lproj "Python Launcher.app/Contents/Resources"
FileSettings.o: $(srcdir)/FileSettings.m
- $(OBJC) $(CFLAGS) -o $@ -c $(srcdir)/FileSettings.m
+ $(CC) $(CFLAGS) -o $@ -c $(srcdir)/FileSettings.m
MyAppDelegate.o: $(srcdir)/MyAppDelegate.m
- $(OBJC) $(CFLAGS) -o $@ -c $(srcdir)/MyAppDelegate.m
+ $(CC) $(CFLAGS) -o $@ -c $(srcdir)/MyAppDelegate.m
MyDocument.o: $(srcdir)/MyDocument.m
- $(OBJC) $(CFLAGS) -o $@ -c $(srcdir)/MyDocument.m
+ $(CC) $(CFLAGS) -o $@ -c $(srcdir)/MyDocument.m
PreferencesWindowController.o: $(srcdir)/PreferencesWindowController.m
- $(OBJC) $(CFLAGS) -o $@ -c $(srcdir)/PreferencesWindowController.m
+ $(CC) $(CFLAGS) -o $@ -c $(srcdir)/PreferencesWindowController.m
doscript.o: $(srcdir)/doscript.m
- $(OBJC) $(CFLAGS) -o $@ -c $(srcdir)/doscript.m
+ $(CC) $(CFLAGS) -o $@ -c $(srcdir)/doscript.m
main.o: $(srcdir)/main.m
- $(OBJC) $(CFLAGS) -o $@ -c $(srcdir)/main.m
+ $(CC) $(CFLAGS) -o $@ -c $(srcdir)/main.m
Python\ Launcher: $(OBJECTS)
- $(OBJC) $(LDFLAGS) -o "Python Launcher" $(OBJECTS) -framework AppKit -framework Carbon
+ $(CC) $(LDFLAGS) -o "Python Launcher" $(OBJECTS) -framework AppKit -framework Carbon
Info.plist: $(srcdir)/Info.plist.in
sed 's/%VERSION%/'"`$(RUNSHARED) $(BUILDPYTHON) -c 'import platform; print(platform.python_version())'`"'/g' < $(srcdir)/Info.plist.in > Info.plist