aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Snow <ericsnowcurrently@gmail.com>2019-03-15 16:35:46 -0600
committerGitHub <noreply@github.com>2019-03-15 16:35:46 -0600
commitc11183cdcff6af13c4339fdcce84ab63f7930ddc (patch)
tree947655550e220dc5ddfd5079fa2a92ebdac9dbef /setup.py
parentbpo-33608: Deal with pending calls relative to runtime shutdown. (gh-12246) (diff)
downloadcpython-c11183cdcff6af13c4339fdcce84ab63f7930ddc.tar.gz
cpython-c11183cdcff6af13c4339fdcce84ab63f7930ddc.tar.bz2
cpython-c11183cdcff6af13c4339fdcce84ab63f7930ddc.zip
bpo-36097: Use only public C-API in the_xxsubinterpreters module (adding as necessary). (gh-12359)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 1 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index b96961073b9..c278f08b8e6 100644
--- a/setup.py
+++ b/setup.py
@@ -784,9 +784,7 @@ class PyBuildExt(build_ext):
self.add(Extension('syslog', ['syslogmodule.c']))
# Python interface to subinterpreter C-API.
- self.add(Extension('_xxsubinterpreters',
- ['_xxsubinterpretersmodule.c'],
- define_macros=[('Py_BUILD_CORE', '')]))
+ self.add(Extension('_xxsubinterpreters', ['_xxsubinterpretersmodule.c']))
#
# Here ends the simple stuff. From here on, modules need certain