aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTulio Magno Quites Machado Filho <tuliom@linux.vnet.ibm.com>2018-02-15 15:44:47 -0200
committerPaul E. Murphy <murphyp@linux.vnet.ibm.com>2020-03-06 09:17:32 -0600
commitd2b2acefa60a0559b0104394be1279eae72c9bb3 (patch)
treece674cdef02aedde4da20cbc588b7fe0f6835d0a
parentldbl-128ibm-compat: Add tests for IBM long double functions (diff)
downloadglibc-d2b2acefa60a0559b0104394be1279eae72c9bb3.tar.gz
glibc-d2b2acefa60a0559b0104394be1279eae72c9bb3.tar.bz2
glibc-d2b2acefa60a0559b0104394be1279eae72c9bb3.zip
ldbl-128ibm: Let long double files have specific compiler flags
Soon, powerpc64le will need to provide extra compiler flags to the long double files in order to continue to build using the IBM 128-bit extended floating point type as long double.
-rw-r--r--sysdeps/ieee754/ldbl-128ibm/Makefile22
1 files changed, 19 insertions, 3 deletions
diff --git a/sysdeps/ieee754/ldbl-128ibm/Makefile b/sysdeps/ieee754/ldbl-128ibm/Makefile
index bdba6cc6b5..c38d4f6ac2 100644
--- a/sysdeps/ieee754/ldbl-128ibm/Makefile
+++ b/sysdeps/ieee754/ldbl-128ibm/Makefile
@@ -9,8 +9,24 @@ tests += tst-strtold-ldbl-128ibm
$(objpfx)tst-strtold-ldbl-128ibm: $(libm)
endif
+ldbl-tests = test-fmodl-ldbl-128ibm test-remainderl-ldbl-128ibm \
+ test-remquol-ldbl-128ibm test-canonical-ldbl-128ibm \
+ test-totalorderl-ldbl-128ibm
+
ifeq ($(subdir),math)
-tests += test-fmodl-ldbl-128ibm test-remainderl-ldbl-128ibm \
- test-remquol-ldbl-128ibm test-canonical-ldbl-128ibm \
- test-totalorderl-ldbl-128ibm
+tests += $(ldbl-tests)
endif
+
+# Long double files may need extra CFLAGS.
+ldbl-128ibm-routines = s_nexttoward s_nexttowardf \
+ $(type-ldouble-routines) \
+ $(subst F,$(type-ldouble-suffix),$(libm-compat-calls)) \
+ $(subst F,$(type-ldouble-suffix),$(libm-calls)) \
+ $(subst F,$(type-ldouble-suffix),$(calls)) \
+ $(foreach f,$(libm-narrow-fns), \
+ $(subst F,$(f), \
+ $(libm-narrow-types-ldouble-yes)))
+$(foreach suf,$(all-object-suffixes), \
+ $(foreach r,$(ldbl-128ibm-routines) $(ldbl-tests), \
+ $(objpfx)$(r)$(suf))): \
+ CFLAGS += $(type-ldouble-CFLAGS)