aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Picus <matti.picus@gmail.com>2021-03-01 14:29:10 +0200
committerMatti Picus <matti.picus@gmail.com>2021-03-01 14:29:10 +0200
commit1e5561056eca8e53fb9f9834b3fe3c44752eee11 (patch)
treef864690aa3b730685b7524c76d76930c3fa81cd6
parentmerge string-algorithmic-optimizations (diff)
downloadpypy-1e5561056eca8e53fb9f9834b3fe3c44752eee11.tar.gz
pypy-1e5561056eca8e53fb9f9834b3fe3c44752eee11.tar.bz2
pypy-1e5561056eca8e53fb9f9834b3fe3c44752eee11.zip
sprinkle more links to heptapod in the docs, update some older pages
-rw-r--r--pypy/doc/Makefile2
-rw-r--r--pypy/doc/contributing.rst4
-rw-r--r--pypy/doc/dev_method.rst10
-rw-r--r--pypy/doc/faq.rst29
-rw-r--r--pypy/doc/index.rst9
5 files changed, 38 insertions, 16 deletions
diff --git a/pypy/doc/Makefile b/pypy/doc/Makefile
index 3bc64047ba..eacfa7b73e 100644
--- a/pypy/doc/Makefile
+++ b/pypy/doc/Makefile
@@ -2,7 +2,7 @@
#
# You can set these variables from the command line.
-SPHINXOPTS =
+SPHINXOPTS ?=
SPHINXBUILD = sphinx-build
PAPER =
BUILDDIR = _build
diff --git a/pypy/doc/contributing.rst b/pypy/doc/contributing.rst
index 959cecb065..43671869bf 100644
--- a/pypy/doc/contributing.rst
+++ b/pypy/doc/contributing.rst
@@ -45,11 +45,15 @@ and clicking the "Request Access" link on the `PyPy group page`. We also run
coding sprints which are separately announced and are usually announced on `the
blog`_.
+Like any Open Source project, issues should be filed on the `issue tracker`_,
+and `merge requests`_ to fix issues are welcome.
+
Further Reading: :ref:`Contact <contact>`
.. _the blog: https://morepypy.blogspot.com
.. _pypy-dev mailing list: https://mail.python.org/mailman/listinfo/pypy-dev
.. _`PyPy group page`: https://foss.heptapod.net/pypy
+.. _`merge requests`: https://foss.heptapod.net/heptapod/foss.heptapod.net/-/merge_requests
Your first contribution
diff --git a/pypy/doc/dev_method.rst b/pypy/doc/dev_method.rst
index f93da796a9..ffe4e42831 100644
--- a/pypy/doc/dev_method.rst
+++ b/pypy/doc/dev_method.rst
@@ -1,6 +1,16 @@
Distributed and agile development in PyPy
=========================================
+.. note::
+ This page describes the mode of development that preceeds the current models
+ of Open Source development. While people are welcome to join our (now yearly)
+ sprints, we encourage engagement via the gitlab repo at
+ https://foss.heptapod.net/pypy/pypy. Issues can be filed and discussed in the
+ `issue tracker`_ and we welcome `merge requests`_.
+
+.. _`issue tracker`: https://foss.heptapod.net/heptapod/foss.heptapod.net/-/issues
+.. _`merge requests`: https://foss.heptapod.net/heptapod/foss.heptapod.net/-/merge_requests
+
PyPy isn't just about producing code - it's also about how we produce code.
The challenges of coordinating work within a community and making sure it is
fused together with the parts of the project that is EU funded are tricky
diff --git a/pypy/doc/faq.rst b/pypy/doc/faq.rst
index 64d098b09d..bbdfdb442b 100644
--- a/pypy/doc/faq.rst
+++ b/pypy/doc/faq.rst
@@ -92,20 +92,20 @@ modules, recursively).
.. _`See below.`:
-Do CPython Extension modules work with PyPy?
---------------------------------------------
+Do C-extension modules work with PyPy?
+--------------------------------------
**First note that some Linux distributions (e.g. Ubuntu, Debian) split
PyPy into several packages. If you installed a package called "pypy",
then you may also need to install "pypy-dev" for the following to work.**
-We have experimental support for CPython extension modules, so
-they run with minor changes. This has been a part of PyPy since
-the 1.4 release, but support is still in beta phase. CPython
+We have support for c-extension modules (modules written using the C-API), so
+they run without modifications. This has been a part of PyPy since
+the 1.4 release, and support is almost complete. CPython
extension modules in PyPy are often much slower than in CPython due to
the need to emulate refcounting. It is often faster to take out your
-CPython extension and replace it with a pure python version that the
-JIT can see. If trying to install module xyz, and the module has both
+c-extension and replace it with a pure python or CFFI version that the
+JIT can optimize. If trying to install module xyz, and the module has both
a C and a Python version of the same code, try first to disable the C
version; this is usually easily done by changing some line in ``setup.py``.
@@ -143,9 +143,6 @@ Linux so fixes may depend on 3rd-party contributions.
To bootstrap from sources, PyPy can use either CPython 2.7 or
another (e.g. older) PyPy. Cross-translation is not really supported:
e.g. to build a 32-bit PyPy, you need to have a 32-bit environment.
-Cross-translation is only explicitly supported between a 32-bit Intel
-Linux and ARM Linux (see :ref:`here <rpython:arm>`).
-
Which Python version (2.x?) does PyPy implement?
------------------------------------------------
@@ -155,7 +152,7 @@ PyPy comes in two versions:
* one is fully compatible with Python 2.7;
* the other is fully compatible with one 3.x version. At the time of
- this writing, this is 3.6.
+ this writing, this is 3.7.
.. _threading:
@@ -181,14 +178,13 @@ PyPy, this sub-problem is simpler: we need to make our GC
multithread-aware. This is easier to do efficiently in PyPy than in
CPython. It doesn't solve the issue (2), though.
-Note that since 2012 there is work going on on a still very experimental
+Note that there was work to support a
:doc:`Software Transactional Memory <stm>` (STM) version of PyPy. This
should give an alternative PyPy which works without a GIL, while at the
same time continuing to give the Python programmer the complete illusion
of having one. This work is currently a bit stalled because of its own
technical difficulties.
-
What about numpy, numpypy, micronumpy?
--------------------------------------
@@ -402,6 +398,13 @@ the most immediate way to get feedback (at least during some parts of the day;
most PyPy developers are in Europe) and the `mailing list`_ is better for long
discussions.
+We also encourage engagement via the gitlab repo at
+https://foss.heptapod.net/pypy/pypy. Issues can be filed and discussed in the
+`issue tracker`_ and we welcome `merge requests`.
+
+.. _`issue tracker`: https://foss.heptapod.net/heptapod/foss.heptapod.net/-/issues
+.. _`merge requests`: https://foss.heptapod.net/heptapod/foss.heptapod.net/-/merge_requests
+
.. _mailing list: https://mail.python.org/mailman/listinfo/pypy-dev
diff --git a/pypy/doc/index.rst b/pypy/doc/index.rst
index e63dbc3daa..5a570dbbf1 100644
--- a/pypy/doc/index.rst
+++ b/pypy/doc/index.rst
@@ -9,7 +9,7 @@ implementation of the Python_ language.
* If you're interested in trying PyPy out, check out the :doc:`installation instructions <install>`.
-* If you want to help develop PyPy, please have a look at :doc:`contributing <contributing>`
+* If you want to help develop PyPy, please have a look at :doc:`contributing <contributing>` and at the repo on https://foss.heptapod.net/pypy/pypy
and get in touch (:ref:`contact`)!
All of the documentation and source code is available under the MIT license,
@@ -102,12 +102,17 @@ Meeting PyPy developers
anyone interested in the project. Watch out for sprint announcements on
the `development mailing list`_.
+Twitter handle `#pypyproject`_
+
+Watch us on twitch_
+
.. _#pypy on irc.freenode.net: irc://irc.freenode.net/pypy
.. _here: https://quodlibet.duckdns.org/irc/pypy/latest.log.html#irc-end
.. _Development mailing list: https://mail.python.org/mailman/listinfo/pypy-dev
.. _Commit mailing list: https://mail.python.org/mailman/listinfo/pypy-commit
.. _Development bug/feature tracker: https://foss.heptapod.net/pypy/pypy/issues
-
+.. _`#pypyproject`: https://twitter.com/pypyproject
+.. _twitch: https://www.twitch.tv/pypyproject
Indices and tables
==================