aboutsummaryrefslogtreecommitdiff
path: root/units
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-10-16 15:30:53 +0200
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2018-10-17 19:31:50 +0200
commitd85515edcf9700dc068201ab9f7103f04f3b25b2 (patch)
treea5d7ac7a8727efdd8c73ce413033a0a44101aba4 /units
parentunits: use SuccessAction=exit-force in systemd-exit.service (diff)
downloadsystemd-d85515edcf9700dc068201ab9f7103f04f3b25b2.tar.gz
systemd-d85515edcf9700dc068201ab9f7103f04f3b25b2.tar.bz2
systemd-d85515edcf9700dc068201ab9f7103f04f3b25b2.zip
units: use SuccessAction=reboot-force in systemd-reboot.service
Diffstat (limited to 'units')
-rw-r--r--units/meson.build2
-rw-r--r--units/systemd-reboot.service (renamed from units/systemd-reboot.service.in)5
2 files changed, 2 insertions, 5 deletions
diff --git a/units/meson.build b/units/meson.build
index e4ac6ced6..3785e15de 100644
--- a/units/meson.build
+++ b/units/meson.build
@@ -97,6 +97,7 @@ units = [
'sockets.target.wants/'],
['systemd-networkd.socket', 'ENABLE_NETWORKD',
join_paths(pkgsysconfdir, 'system/sockets.target.wants/')],
+ ['systemd-reboot.service', ''],
['systemd-rfkill.socket', 'ENABLE_RFKILL'],
['systemd-tmpfiles-clean.timer', '',
'timers.target.wants/'],
@@ -182,7 +183,6 @@ in_units = [
['systemd-quotacheck.service', 'ENABLE_QUOTACHECK'],
['systemd-random-seed.service', 'ENABLE_RANDOMSEED',
'sysinit.target.wants/'],
- ['systemd-reboot.service', ''],
['systemd-remount-fs.service', '',
'local-fs.target.wants/'],
['systemd-resolved.service', 'ENABLE_RESOLVE',
diff --git a/units/systemd-reboot.service.in b/units/systemd-reboot.service
index 4763ccfdc..505f60aab 100644
--- a/units/systemd-reboot.service.in
+++ b/units/systemd-reboot.service
@@ -13,7 +13,4 @@ Documentation=man:systemd-halt.service(8)
DefaultDependencies=no
Requires=shutdown.target umount.target final.target
After=shutdown.target umount.target final.target
-
-[Service]
-Type=oneshot
-ExecStart=@SYSTEMCTL@ --force reboot
+SuccessAction=reboot-force