summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwiktor w brodlo <wiktor@brodlo.net>2011-07-25 19:12:41 +0000
committerwiktor w brodlo <wiktor@brodlo.net>2011-07-25 19:12:41 +0000
commita5ed416f9a7b826d2afbb1c45a5170b3143bf7e3 (patch)
tree4d22ddb59b2f70f46ab4f76bed5ade47912fa6d9 /app-admin/system-config-date
parent sys-block/open-iscsi: update manifest (diff)
downloadanaconda-overlay-a5ed416f9a7b826d2afbb1c45a5170b3143bf7e3.tar.gz
anaconda-overlay-a5ed416f9a7b826d2afbb1c45a5170b3143bf7e3.tar.bz2
anaconda-overlay-a5ed416f9a7b826d2afbb1c45a5170b3143bf7e3.zip
New versions of Fedora ebuilds
Diffstat (limited to 'app-admin/system-config-date')
-rw-r--r--app-admin/system-config-date/system-config-date-1.9.61.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-admin/system-config-date/system-config-date-1.9.61.ebuild b/app-admin/system-config-date/system-config-date-1.9.61.ebuild
new file mode 100644
index 0000000..45a85ce
--- /dev/null
+++ b/app-admin/system-config-date/system-config-date-1.9.61.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2004-2010 Sabayon
+# Distributed under the terms of the GNU General Public License v2
+# $
+
+EAPI="2"
+inherit python base
+
+DESCRIPTION="The system-config-date tool lets you set the date and time of your machine."
+HOMEPAGE="http://fedoraproject.org/wiki/SystemConfig/date"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-1"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE="gtk"
+
+# FIXME: would also require a dependency against anaconda
+DEPEND="app-text/docbook-xml-dtd
+ app-text/docbook-sgml-dtd
+ app-text/gnome-doc-utils
+ app-text/rarian
+ dev-libs/newt
+ dev-util/desktop-file-utils
+ dev-util/intltool
+ sys-devel/gettext"
+
+# also net-misc/ntp would be a soft-dependency
+# but code is redhat-centric, so we won't really
+# let user use this crap
+# net-misc/ntp
+RDEPEND="dev-libs/newt
+ dev-python/python-slip
+ dev-python/rhpl
+ gtk? ( dev-python/pygtk:2
+ dev-python/libgnomecanvas-python
+ x11-themes/hicolor-icon-theme )"
+
+src_install() {
+ base_src_install
+
+ # removing .desktop file, not advertising this, it is
+ # only needed by app-admin/anaconda
+ rm -rf "${D}/usr/share/"{man,applications}
+ rm -rf "${D}/etc/"{pam.d,security}
+ rm -rf "${D}/usr/bin"
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}