summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2006-06-05 17:52:41 +0000
committerBenedikt Boehm <hollow@gentoo.org>2006-06-05 17:52:41 +0000
commit1bc496f1551687e0d24b73506c30627f3656f7eb (patch)
tree964824da67cdd29d43fdae54e1d43bc42cb8f064 /1.3/patches
parentfix old apr api calls (#133191) (diff)
downloadapache-1bc496f1551687e0d24b73506c30627f3656f7eb.tar.gz
apache-1bc496f1551687e0d24b73506c30627f3656f7eb.tar.bz2
apache-1bc496f1551687e0d24b73506c30627f3656f7eb.zip
fix apachectl #106563
Diffstat (limited to '1.3/patches')
-rw-r--r--1.3/patches/02_all_gentoo_apachectl.patch9
1 files changed, 7 insertions, 2 deletions
diff --git a/1.3/patches/02_all_gentoo_apachectl.patch b/1.3/patches/02_all_gentoo_apachectl.patch
index 03091bb..cef6fcb 100644
--- a/1.3/patches/02_all_gentoo_apachectl.patch
+++ b/1.3/patches/02_all_gentoo_apachectl.patch
@@ -12,12 +12,17 @@ diff -Nup -Nrup apache_1.3.33.orig/Makefile.tmpl apache_1.3.33.patched/Makefile.
diff -Nup -Nrup apache_1.3.33.orig/src/support/apachectl apache_1.3.33.patched/src/support/apachectl
--- apache_1.3.33.orig/src/support/apachectl 2004-02-20 22:02:24.000000000 +0000
+++ apache_1.3.33.patched/src/support/apachectl 2005-02-18 03:00:53.000000000 +0000
-@@ -40,12 +40,16 @@
+@@ -40,12 +40,21 @@
PIDFILE=/usr/local/apache/logs/httpd.pid
#
# the path to your httpd binary, including options if necessary
-HTTPD='/usr/local/apache/src/httpd'
+. /etc/conf.d/apache
++CONFIGFILE="${CONFIGFILE:-/etc/apache/httpd.conf}"
++SERVERROOT="${SERVERROOT:-/usr/lib/apache}"
++[ ${CONFIGFILE:0:1} != "/" ] && CONFIGFILE="${SERVERROOT}/${CONFIGFILE}"
++[ -n "${CONFIGFILE}" ] && APACHE_OPTS="${APACHE_OPTS} -f ${CONFIGFILE}"
++[ -n "${SERVERROOT}" ] && APACHE_OPTS="${APACHE_OPTS} -d ${SERVERROOT}"
+HTTPD="/usr/sbin/apache ${APACHE_OPTS}"
#
# a command that outputs a formatted text version of the HTML at the
@@ -30,7 +35,7 @@ diff -Nup -Nrup apache_1.3.33.orig/src/support/apachectl apache_1.3.33.patched/s
#
# the URL to your server's mod_status status page. If you do not
# have one, then status and fullstatus will not work.
-@@ -60,6 +64,14 @@ if [ "x$ARGV" = "x" ] ; then
+@@ -60,6 +69,14 @@ if [ "x$ARGV" = "x" ] ; then
ARGS="help"
fi