aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek.chauhan@gmail.com>2009-02-17 22:36:25 +0530
committerNirbheek Chauhan <nirbheek.chauhan@gmail.com>2009-02-17 22:44:37 +0530
commit003d4780cfe5c84107d4ee7d94c3b3fba24c57c1 (patch)
tree184a1a6fcc57b5aaf86863317d0b4e0147562525 /master/icons/Makefile
parentUpdate autotua-slave with ~amd64 KEYWORD (diff)
downloadautotua-003d4780cfe5c84107d4ee7d94c3b3fba24c57c1.tar.gz
autotua-003d4780cfe5c84107d4ee7d94c3b3fba24c57c1.tar.bz2
autotua-003d4780cfe5c84107d4ee7d94c3b3fba24c57c1.zip
Use `make` for autotua-master
* The main reason for this build-system is the absence of librsvg on most servers where autotua-master will be built. Hence, `make dist` will generate .pngs for the tarball * You need to specify the versions only in Makefile/setup.py now * Tarball creation support => we can have an ebuild for autotua-master based on the webapp eclass * New build systems -> 96x96 images are now suffixed with "-large" - Fix master/master/templates/frontpage.html for new images * `make dist` ftw! - Update scripts/do-release.sh for changes - Also fix a few bugs - And remove "scp" support (manual > automatic)
Diffstat (limited to 'master/icons/Makefile')
-rw-r--r--master/icons/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/master/icons/Makefile b/master/icons/Makefile
index 736d2f5..04df378 100644
--- a/master/icons/Makefile
+++ b/master/icons/Makefile
@@ -3,19 +3,24 @@
# License: AGPL-3
#
-INSTALL=install
-CONVERT=rsvg-convert --height=96
-CONVERT_MEDIUM=rsvg-convert --height=48
-IMGS=jobs.png master.png slaves.png users.png
-IMGS_MEDIUM=autotua.png home.png login.png logout.png password.png
-IMGMODE=644
+INSTALL := install
+CONVERT := rsvg-convert
+SIMGS := autotua.svg home.svg login.svg logout.svg password.svg
+SIMGS_L := jobs.svg master.svg slaves.svg users.svg
+IMGS := $(SIMGS:.svg=.png)
+IMGS_L := $(SIMGS_L:.svg=-large.png)
+IMGMODE := 644
-all:
- for img in ${IMGS}; do ${CONVERT} -o $$img $${img%.png}.svg; done
- for img in ${IMGS_MEDIUM}; do ${CONVERT_MEDIUM} -o $$img $${img%.png}.svg; done
+%.png: %.svg
+ $(CONVERT) --height=48 -o $@ $<
+
+%-large.png: %.svg
+ $(CONVERT) --height=96 -o $@ $<
+
+all: $(IMGS) $(IMGS_L)
clean:
- rm -f ${IMGS} ${IMGS_MEDIUM}
+ rm -f *.png
install: all
test -n "${DESTDIR}" || ( echo "Please define DESTDIR" ; exit 1 )