summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs/git-cola/git-cola-9999.ebuild')
-rw-r--r--dev-vcs/git-cola/git-cola-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-vcs/git-cola/git-cola-9999.ebuild b/dev-vcs/git-cola/git-cola-9999.ebuild
index dab8fb4..bbd4f21 100644
--- a/dev-vcs/git-cola/git-cola-9999.ebuild
+++ b/dev-vcs/git-cola/git-cola-9999.ebuild
@@ -20,6 +20,7 @@ KEYWORDS=""
IUSE="doc test"
RDEPEND="
+ dev-python/jsonpickle
dev-python/pyinotify
dev-python/PyQt4
dev-vcs/git"
@@ -49,9 +50,11 @@ src_prepare() {
-e "s|'doc', 'git-cola'|'doc', '${PF}', 'html'|" \
cola/resources.py || die "sed failed"
- epatch "${FILESDIR}/9999-disable-tests.patch"
+ epatch \
+ "${FILESDIR}"/9999-disable-tests.patch \
+ "${FILESDIR}"/9999-system-ssh-askpass.patch
- python_convert_shebangs 2 bin/git-cola bin/git-dag share/git-cola/bin/ssh-askpass
+ python_convert_shebangs 2 bin/git-cola bin/git-dag
}
src_compile() {
@@ -84,6 +87,10 @@ src_test() {
pkg_postinst() {
python_mod_optimize /usr/share/git-cola/lib/cola
+
+ elog "Please make sure you have either a SSH key management installed and activated or"
+ elog "installed a SSH askpass app like net-misc/x11-ssh-askpass."
+ elog "Otherwise git-cola may hang when pushing/pulling from remote git repositories via SSH. "
}
pkg_postrm() {