aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2013-01-24 20:26:38 -0800
committerBrian Dolbec <dolsen@gentoo.org>2014-04-02 13:04:15 -0700
commit773ae7f9ee04cedba218a9abdc9f9b7e8360f055 (patch)
treeaeec81b35511e4ab5a11565bae0ac2cd38ffb303 /testpath
parentcatalyst/support.py: Update for snakeoil API change. (diff)
downloadcatalyst-773ae7f9ee04cedba218a9abdc9f9b7e8360f055.tar.gz
catalyst-773ae7f9ee04cedba218a9abdc9f9b7e8360f055.tar.bz2
catalyst-773ae7f9ee04cedba218a9abdc9f9b7e8360f055.zip
Commit a testpath file to source with instructions on it's use.
Make testpath automagic via dwfeed's tweak Update HOWTO on how to run the git checkout code directly without being installed.
Diffstat (limited to 'testpath')
-rw-r--r--testpath18
1 files changed, 18 insertions, 0 deletions
diff --git a/testpath b/testpath
new file mode 100644
index 00000000..37af9c9f
--- /dev/null
+++ b/testpath
@@ -0,0 +1,18 @@
+
+# edit the following 2 paths to point to your catalyst git checkout if nessecary
+# then in a terminal window you wish to run the git code in...
+# cd ~/catalyst
+# source ./testpath
+# edit a config catalyst.conf file. Make similar path changes for it to
+# find and use/run the git checkout code.
+# The catalyst code can then be run on a system without being installed or
+# replacing an existing catalyst install which may be used for production.
+#
+# then run catalyst from there
+# eg:
+#
+# catalyst -c catalyst.conf -p -f stage1.spec
+
+export PATH="$(dirname ${BASH_SOURCE[0]})/bin:${PATH}"
+
+export PYTHONPATH="$(dirname ${BASH_SOURCE[0]})${PYTHONPATH:+:}${PYTHONPATH}"