summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrent Baude <ranger@gentoo.org>2007-04-12 14:09:55 +0000
committerBrent Baude <ranger@gentoo.org>2007-04-12 14:09:55 +0000
commitb00c232f59de8b013eaccbc95bdc5cbebd96966b (patch)
treecd392902107b337cc568b1946706a9a41027930a
parentcategories... (diff)
downloadcell-b00c232f59de8b013eaccbc95bdc5cbebd96966b.tar.gz
cell-b00c232f59de8b013eaccbc95bdc5cbebd96966b.tar.bz2
cell-b00c232f59de8b013eaccbc95bdc5cbebd96966b.zip
Adding a petitboot binary build
svn path=/; revision=6
-rw-r--r--sys-boot/petitboot-bin/Manifest8
-rw-r--r--sys-boot/petitboot-bin/files/digest-petitboot-bin-0.13
-rw-r--r--sys-boot/petitboot-bin/petitboot-bin-0.1.ebuild38
3 files changed, 49 insertions, 0 deletions
diff --git a/sys-boot/petitboot-bin/Manifest b/sys-boot/petitboot-bin/Manifest
new file mode 100644
index 0000000..24482d6
--- /dev/null
+++ b/sys-boot/petitboot-bin/Manifest
@@ -0,0 +1,8 @@
+DIST otheros.bld 3683892 RMD160 9735fcf087804ab8e0cfdf835775c082047629a6 SHA1 1b51d6bcce65461ea4fcdba5547bc8b9f908e27b SHA256 4d0f9eb163d144c05a7410c264b4c7b243104ddfdbb292efdf736a72d13464be
+EBUILD petitboot-bin-0.1.ebuild 881 RMD160 c93275005efdb83acf571443513c877f508a4c3f SHA1 b77f2a67479cbf38b9a181e0a92aa1ed7065f341 SHA256 fa5432aa119ab9dbd4169f7f328da975c7e16e50d13a1c382dc649a1a393a9be
+MD5 c5410b5b689737c0ca4a7f065834d1ae petitboot-bin-0.1.ebuild 881
+RMD160 c93275005efdb83acf571443513c877f508a4c3f petitboot-bin-0.1.ebuild 881
+SHA256 fa5432aa119ab9dbd4169f7f328da975c7e16e50d13a1c382dc649a1a393a9be petitboot-bin-0.1.ebuild 881
+MD5 f636532e2bf95231b4dfe59391ff38ae files/digest-petitboot-bin-0.1 217
+RMD160 54d4cf0c5321990eb438809d9b9b105d6fadcd17 files/digest-petitboot-bin-0.1 217
+SHA256 74f002685dc4351f6e58a5dc2de3f5110ed4f8da31726e6f95005af86cff9cbe files/digest-petitboot-bin-0.1 217
diff --git a/sys-boot/petitboot-bin/files/digest-petitboot-bin-0.1 b/sys-boot/petitboot-bin/files/digest-petitboot-bin-0.1
new file mode 100644
index 0000000..a9f4618
--- /dev/null
+++ b/sys-boot/petitboot-bin/files/digest-petitboot-bin-0.1
@@ -0,0 +1,3 @@
+MD5 1327194422e4efeb3357aeff4093caf9 otheros.bld 3683892
+RMD160 9735fcf087804ab8e0cfdf835775c082047629a6 otheros.bld 3683892
+SHA256 4d0f9eb163d144c05a7410c264b4c7b243104ddfdbb292efdf736a72d13464be otheros.bld 3683892
diff --git a/sys-boot/petitboot-bin/petitboot-bin-0.1.ebuild b/sys-boot/petitboot-bin/petitboot-bin-0.1.ebuild
new file mode 100644
index 0000000..452aaba
--- /dev/null
+++ b/sys-boot/petitboot-bin/petitboot-bin-0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+
+DESCRIPTION="PS3 alternative bootloader"
+HOMEPAGE="http://ozlabs.org/~jk/projects/petitboot/"
+SRC_URI="http://ozlabs.org/~jk/projects/petitboot/downloads/bin-0.0.1/otheros.bld"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE=""
+
+DEPEND="app-misc/ps3pf_utils"
+RDEPEND=""
+
+src_unpack () {
+ true
+}
+
+src_install () {
+ insinto /boot
+ doins $DISTDIR/otheros.bld
+}
+
+pkg_postinst() {
+ einfo "The binary otheros.bld from the petitboot project"
+ einfo "was installed to the /boot directory. This version"
+ einfo "of petitboot cannot read device names from the "
+ einfo "kboot.conf file. Remove the device name from"
+ einfo "kernel label in the conf file before using this flash"
+ einfo "image."
+ ebeep 5
+ einfo " ** USE AT YOUR OWN RISK **"
+ ebeep 5
+}