summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/ps3pf_utils/ps3pf_utils-2.1.1.ebuild')
-rw-r--r--app-misc/ps3pf_utils/ps3pf_utils-2.1.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/ps3pf_utils/ps3pf_utils-2.1.1.ebuild b/app-misc/ps3pf_utils/ps3pf_utils-2.1.1.ebuild
new file mode 100644
index 0000000..d785c00
--- /dev/null
+++ b/app-misc/ps3pf_utils/ps3pf_utils-2.1.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit flag-o-matic
+
+DESCRIPTION="Utilities to set the ps3 specific features"
+HOMEPAGE="http://www.playstation.com/ps3-openplatform/index.html"
+#SRC_URI="http://www.powerdeveloper.org/files/Cell/SourceCD/${P}.tar.bz2
+SRC_URI="http://dev.gentoo.org/~ranger/downloads/ps3/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc ppc64"
+IUSE=""
+
+# fixme: depend on a version of sys-kernel/linux-headers that supports ps3
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ #append-flags -I/usr/src/linux/include/
+ econf
+ emake || die "compile failed, do you have up to date kernel sources?"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "install failed"
+}