aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Thibodeau <kyron@neuralbs.com>2008-08-22 00:24:17 -0400
committerEric Thibodeau <kyron@neuralbs.com>2008-08-22 00:24:17 -0400
commite1c0538b5412e13384f15159c01b6d6eed38b213 (patch)
tree59857425e25d1aba632470f5676ce1298070aaee
parentAddition of this stripped down spec for nfsroot, based on the gentoo minimal ... (diff)
downloadclustering-livecd-e1c0538b5412e13384f15159c01b6d6eed38b213.tar.gz
clustering-livecd-e1c0538b5412e13384f15159c01b6d6eed38b213.tar.bz2
clustering-livecd-e1c0538b5412e13384f15159c01b6d6eed38b213.zip
replaced by r2
-rw-r--r--overlay/app-admin/diradm/diradm-2.9.3-r1.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/overlay/app-admin/diradm/diradm-2.9.3-r1.ebuild b/overlay/app-admin/diradm/diradm-2.9.3-r1.ebuild
deleted file mode 100644
index 954e0c9..0000000
--- a/overlay/app-admin/diradm/diradm-2.9.3-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/diradm-2.9.3.ebuild,v 1.6 2008/02/20 23:03:36 robbat2 Exp $
-
-inherit eutils
-
-DESCRIPTION="diradm is a nearly complete nss/shadow suite for managing POSIX users/groups/data in LDAP."
-#HOMEPAGE="http://research.iat.sfu.ca/custom-software/diradm/"
-#SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
-HOMEPAGE="http://orbis-terrarum.net/~robbat2/"
-SRC_URI="http://orbis-terrarum.net/~robbat2/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="samba irixpasswd automount test"
-DEPEND="net-nds/openldap
- sys-apps/gawk
- sys-apps/coreutils
- sys-apps/grep
- dev-lang/perl
- app-shells/bash
- sys-apps/sed
- virtual/perl-MIME-Base64
- samba? (
- dev-perl/Crypt-SmbHash
- >=net-fs/samba-3.0.6
- )
- test? ( dev-perl/Crypt-SmbHash >=net-fs/samba-3.0.6 dev-util/dejagnu )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}/src"
- epatch "${FILESDIR}"/diradm-2.9.3-emptyUID.patch
-}
-pkg_setup() {
- if use test; then
- if built_with_use net-nds/openldap minimal ; then
- die "You MUST have a non-minimal build of OpenLDAP to use the testcases!"
- fi
- elog "Warning, for test usage, diradm is built with all optional features!"
- fi
-}
-
-src_compile() {
- local myconf
- if use test; then
- myconf="--enable-samba --enable-automount --enable-irixpasswd"
- else
- myconf="`use_enable samba` `use_enable automount` `use_enable irixpasswd`"
- fi
- econf ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc CHANGES* README AUTHORS ChangeLog NEWS README.prefork THANKS TODO KNOWN-BUGS
- if use irixpasswd; then
- insinto /etc/openldap/schema
- doins irixpassword.schema
- fi
-}
-
-pkg_postinst() {
- elog "The new diradm pulls many settings from your LDAP configuration."
- elog "But don't forget to customize /etc/diradm.conf for other settings."
- elog "Please see the README to instructions if you problems."
-}
-
-src_test() {
- use test || die "You must build diradm with USE=test to run the testcases!"
- emake -j1 check
-}