summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2013-07-04 23:09:33 +0200
committerUlrich Müller <ulm@gentoo.org>2013-07-04 23:09:33 +0200
commitb8c61a868cf0b7cb0c4c82f80be4a0db098db2a7 (patch)
treeea181ef170715d44b3d322aa6773e06648a6d86b
parentFix typo in ChangeLog. (diff)
downloadebuild-mode-b8c61a868cf0b7cb0c4c82f80be4a0db098db2a7.tar.gz
ebuild-mode-b8c61a868cf0b7cb0c4c82f80be4a0db098db2a7.tar.bz2
ebuild-mode-b8c61a868cf0b7cb0c4c82f80be4a0db098db2a7.zip
Remove eselect-mode; it will be maintained in the eselect repository.
* gentoo-syntax.el: Remove eselect-mode; it will be maintained in the eselect repository. (eselect-mode-font-lock-keywords, eselect-mode): Variable and function removed. * eselect-mode-keywords.el: File removed. * gentoo-syntax.texi: Don't mention eselect-mode. * Makefile (DISTFILES): Update.
-rw-r--r--ChangeLog10
-rw-r--r--Makefile2
-rw-r--r--eselect-mode-keywords.el75
-rw-r--r--gentoo-syntax.el30
-rw-r--r--gentoo-syntax.texi41
5 files changed, 28 insertions, 130 deletions
diff --git a/ChangeLog b/ChangeLog
index e58b6e4..cdd13ff 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,13 @@
+2013-07-04 Ulrich Müller <ulm@gentoo.org>
+
+ * gentoo-syntax.el: Remove eselect-mode; it will be maintained
+ in the eselect repository.
+ (eselect-mode-font-lock-keywords, eselect-mode): Variable and
+ function removed.
+ * eselect-mode-keywords.el: File removed.
+ * gentoo-syntax.texi: Don't mention eselect-mode.
+ * Makefile (DISTFILES): Update.
+
2013-03-08 Ulrich Müller <ulm@gentoo.org>
* Version 1.21 released.
diff --git a/Makefile b/Makefile
index 59ead55..5cb66f5 100644
--- a/Makefile
+++ b/Makefile
@@ -6,7 +6,7 @@ PV = $(shell sed '/^;.*[Vv]ersion/!d;s/[^0-9.]*\([^ \t]*\).*/\1/;q' \
gentoo-syntax.el)
P = $(PN)-$(PV)
-DISTFILES = gentoo-syntax.el ebuild-mode-keywords.el eselect-mode-keywords.el \
+DISTFILES = gentoo-syntax.el ebuild-mode-keywords.el \
gentoo-syntax.texi keyword-generation.sh ChangeLog
diff --git a/eselect-mode-keywords.el b/eselect-mode-keywords.el
deleted file mode 100644
index 5b37ccb..0000000
--- a/eselect-mode-keywords.el
+++ /dev/null
@@ -1,75 +0,0 @@
-;;; eselect-mode-keywords.el
-
-;; Copyright 2006-2013 Gentoo Foundation
-
-;; Author: Matthew Kennedy <mkennedy@gentoo.org>
-;; Diego Pettenò <flameeyes@gentoo.org>
-;; Christian Faulhammer <fauli@gentoo.org>
-;; Ulrich Müller <ulm@gentoo.org>
-;; Maintainer: <emacs@gentoo.org>
-;; Keywords: languages
-
-;; This file is free software: you can redistribute it and/or modify
-;; it under the terms of the GNU General Public License as published by
-;; the Free Software Foundation, either version 2 of the License, or
-;; (at your option) any later version.
-
-;; This file is distributed in the hope that it will be useful,
-;; but WITHOUT ANY WARRANTY; without even the implied warranty of
-;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;; GNU General Public License for more details.
-
-;; You should have received a copy of the GNU General Public License
-;; along with GNU Emacs. If not, see <http://www.gnu.org/licenses/>.
-
-;;; Commentary:
-
-;;; Code:
-
-(defvar eselect-mode-keywords-warn
- '(("eval")
- font-lock-warning-face))
-
-(defvar eselect-mode-keywords-core
- '(("die" "check_do" "do_action" "inherit" "sed")
- font-lock-type-face))
-
-(defvar eselect-mode-keywords-output
- '(("write_error_msg" "write_warning_msg" "write_list_start"
- "write_numbered_list_entry" "write_kv_list_entry" "write_numbered_list"
- "highlight" "highlight_warning" "highlight_marker" "is_output_mode"
- "space")
- font-lock-type-face))
-
-(defvar eselect-mode-keywords-tests
- '(("has" "is_function" "is_number")
- font-lock-type-face))
-
-(defvar eselect-mode-keywords-path-manipulation
- '(("basename" "dirname" "canonicalise" "relative_name")
- font-lock-type-face))
-
-(defvar eselect-mode-keywords-manip
- '(("svn_date_to_version")
- font-lock-type-face))
-
-(defvar eselect-mode-keywords-config
- '(("store_config" "load_config" "append_config")
- font-lock-type-face))
-
-(defvar eselect-mode-keywords-multilib
- '(("list_libdirs")
- font-lock-type-face))
-
-(defvar eselect-mode-keywords-package-manager
- '(("arch" "envvar" "best_version" "has_version" "get_repositories"
- "get_repo_news_dir")
- font-lock-type-face))
-
-;; Local Variables:
-;; coding: utf-8
-;; fill-column: 78
-;; no-byte-compile: t
-;; End:
-
-;;; eselect-mode-keywords.el ends here
diff --git a/gentoo-syntax.el b/gentoo-syntax.el
index bff1e4d..04b2452 100644
--- a/gentoo-syntax.el
+++ b/gentoo-syntax.el
@@ -187,8 +187,7 @@ Optional argument LIMIT restarts collection after that number of elements."
)
(eval-when-compile
- (load "ebuild-mode-keywords" nil t)
- (load "eselect-mode-keywords" nil t))
+ (load "ebuild-mode-keywords" nil t))
(defvar ebuild-mode-font-lock-keywords
(eval-when-compile
@@ -199,15 +198,6 @@ Optional argument LIMIT restarts collection after that number of elements."
(all-completions "ebuild-mode-keywords-" obarray 'boundp))
1000))))
-(defvar eselect-mode-font-lock-keywords
- (eval-when-compile
- (mapcar
- (lambda (x) (apply 'ebuild-mode-make-keywords-list x))
- (ebuild-mode-collect-equal-cdrs
- (mapcar
- (lambda (x) (symbol-value (intern x)))
- (all-completions "eselect-mode-keywords-" obarray 'boundp))))))
-
(defvar gentoo-newsitem-font-lock-keywords
(eval-when-compile
(list (ebuild-mode-make-keywords-list
@@ -263,20 +253,6 @@ Optional argument LIMIT restarts collection after that number of elements."
nil ebuild-mode-font-lock-keywords)))
;;;###autoload
-(define-derived-mode eselect-mode shell-script-mode "Eselect"
- "Major mode for .eselect files."
- (if (featurep 'xemacs)
- (make-local-hook 'write-contents-hooks))
- (add-hook 'write-contents-hooks 'ebuild-mode-before-save t t)
- (sh-set-shell "bash")
- (setq tab-width 4)
- (setq indent-tabs-mode t))
-
-(add-hook 'eselect-mode-hook
- (lambda () (font-lock-add-keywords
- nil eselect-mode-font-lock-keywords)))
-
-;;;###autoload
(define-derived-mode gentoo-newsitem-mode text-mode "Newsitem"
"Major mode for Gentoo GLEP 42 news items."
(make-local-variable 'font-lock-defaults)
@@ -557,14 +533,12 @@ and `all-completions' for details."
;; make TAB key work
(defadvice sh-must-be-shell-mode
(around ebuild-mode-sh-must-be-shell-mode activate)
- (or (memq major-mode '(ebuild-mode eselect-mode))
+ (or (eq major-mode 'ebuild-mode)
ad-do-it)))
;;;###autoload
(add-to-list 'auto-mode-alist
'("\\.\\(ebuild\\|eclass\\|eblit\\)\\'" . ebuild-mode))
-;;;###autoload
-(add-to-list 'auto-mode-alist '("\\.eselect\\'" . eselect-mode))
;;;###autoload
(add-to-list 'auto-mode-alist
diff --git a/gentoo-syntax.texi b/gentoo-syntax.texi
index 657178b..054b699 100644
--- a/gentoo-syntax.texi
+++ b/gentoo-syntax.texi
@@ -1,12 +1,12 @@
\input texinfo.tex @c -*-texinfo-*-
@c %**start of header
@setfilename gentoo-syntax.info
-@settitle Major mode for ebuilds, eclasses and eselect modules in Gentoo
+@settitle Major mode for ebuilds and eclasses in Gentoo
@c %**end of header
@copying
-This manual is for gentoo-syntax, which is a major mode for ebuild,
-eclass and eselect module files.
+This manual is for gentoo-syntax, which is a major mode for ebuild
+and eclass files.
Copyright @copyright{} 2009-2013 Gentoo Foundation
@@ -20,13 +20,13 @@ later version published by the Free Software Foundation.
@dircategory Gentoo
@dircategory Emacs
@direntry
-* gentoo-syntax: (gentoo-syntax). Major mode for ebuilds, eclasses and eselect modules.
+* gentoo-syntax: (gentoo-syntax). Major mode for ebuild and eclass files.
@end direntry
@titlepage
@title gentoo-syntax 1.21
-@subtitle Major mode for Gentoo files
+@subtitle Major mode for ebuilds and eclasses in Gentoo
@author Christian Faulhammer
@page
@insertcopying
@@ -38,7 +38,7 @@ later version published by the Free Software Foundation.
@top gentoo-syntax: An introduction
This collection of modes will help the user to efficiently write and
-edit ebuilds, eclasses and eselect modules which are special to Gentoo,
+edit ebuilds and eclasses which are special to Gentoo,
a meta-distribution with various targets (Linux distribution, prefixed
environments in other operating systems, and integration of other
kernels and userlands like the BSDs).
@@ -50,21 +50,15 @@ scripts and there easy to create. Eclasses are comparable to a library
which provides generic functions that a set of ebuilds can use by
sourcing it on request.
-Eselect is a framework to set one out of many alternatives as the
-default value or to activate many out of many choices. An example is to
-choose the version of GNU Emacs called by the @code{/usr/bin/emacs}
-program. Those modules are also near to Bash.
-
-gentoo-syntax provides two modes to edit the above three file types:
-ebuild (eclass) mode and eselect mode. Other features are the execution
-of often needed commands (like KEYWORDS manipulation) or fast-track
-creation of new ebuilds by skeleton support.
+gentoo-syntax provides ebuild (eclass) mode to edit the above two
+file types. Other features are the execution of often needed commands
+(like KEYWORDS manipulation) or fast-track creation of new ebuilds
+by skeleton support.
@menu
* Commands:: What gentoo-syntax provides.
* ebuild-mode:: Editing ebuilds.
* eclass-mode:: Editing eclasses.
-* eselect-mode:: Editing eselect modules.
* gentoo-newsitem-mode:: Editing GLEP 42 news items.
@end menu
@@ -75,10 +69,9 @@ Two packages are available for installation:
(there is support for GNU Emacs and XEmacs from the same source). When
installed through the normal package management in Gentoo and proper
configuration of Emacs, gentoo-syntax loads the appropriate mode on
-opening files with the extensions @code{.ebuild}, @code{.eclass} and
-@code{.eselect}. As the ebuild format is based on the Bash syntax,
-sh-mode is called as a base, where ebuild specific things are
-added/changed on top.
+opening files with the extensions @code{.ebuild} and @code{.eclass}.
+As the ebuild format is based on the Bash syntax, sh-mode is called as
+a base, where ebuild specific things are added/changed on top.
If font-locking is enabled, keywords are highlighted, both the standard
set available from vanilla Portage and special functions from all common
@@ -183,16 +176,12 @@ Run Portage's ebuild command, you are prompted for the phase you want.
Create a ChangeLog entry.
@end table
-@node eclass-mode, eselect-mode, ebuild-mode, Top
+@node eclass-mode, gentoo-newsitem-mode, ebuild-mode, Top
@chapter eclass-mode
There is no special eclass-mode but ebuild-mode is used without the
commands that make no sense in eclasses.
-@node eselect-mode, gentoo-newsitem-mode ,eclass-mode, Top
-@chapter eselect-mode
-This mode only supports highlighting of special eselect keywords.
-
-@node gentoo-newsitem-mode, ,eselect-mode, Top
+@node gentoo-newsitem-mode, , eclass-mode, Top
@chapter gentoo-newsitem-mode for GLEP 42 news items
This mode supports the highlighting of relevant keywords for GLEP 42
news items. These news items get displayed if special criteria for