aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-06 05:39:13 +0000
committerSam James <sam@gentoo.org>2023-01-10 05:21:39 +0000
commit4fb8a9cb2a5410aa565d028bd8deb53d8682da62 (patch)
tree5ab9901cc1e6d66d950f5420a15ac72c4811a33a
parentscripts/paxmark.sh: source the profiles for PAX_MARKINGS (diff)
downloadelfix-4fb8a9cb2a5410aa565d028bd8deb53d8682da62.tar.gz
elfix-4fb8a9cb2a5410aa565d028bd8deb53d8682da62.tar.bz2
elfix-4fb8a9cb2a5410aa565d028bd8deb53d8682da62.zip
fix-gnustack: respect CFLAGS, LDFLAGS for tests
Needed to correctly run tests with Clang, as Clang doesn't create executable stacks by default. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--misc/fix-gnustack/tests/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/misc/fix-gnustack/tests/Makefile.am b/misc/fix-gnustack/tests/Makefile.am
index 9db0fd7..ad573a3 100644
--- a/misc/fix-gnustack/tests/Makefile.am
+++ b/misc/fix-gnustack/tests/Makefile.am
@@ -5,11 +5,11 @@ noinst_PROGRAMS = bad-gnustack
EXTRA_DIST = gnustacktest.sh
bad-gnustack.s: bad-gnustack.c
- $(CC) -S $<
+ $(CC) $(CPPFLAGS) $(CFLAGS) -S $<
$(SED) -i -e 's/GNU-stack,"",/GNU-stack,"x",/' $@
bad-gnustack$(EXEEXT): bad-gnustack.s
- $(CC) -o $@ $<
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $<
check_SCRIPTS = gnustacktest
TEST = $(check_SCRIPTS)