aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <basile@opensource.dyc.edu>2011-04-13 22:27:40 -0400
committerAnthony G. Basile <basile@opensource.dyc.edu>2011-04-13 22:27:40 -0400
commitceb19bb70a081eb281dca22c87d62a8915f3eed3 (patch)
treeb7d9d4c2837427449e0cb377aa67552288ebf05f /configure.ac
parentfix-gnustack.c: removed unnecessary and harmful elf_update() (diff)
downloadelfix-ceb19bb70a081eb281dca22c87d62a8915f3eed3.tar.gz
elfix-ceb19bb70a081eb281dca22c87d62a8915f3eed3.tar.bz2
elfix-ceb19bb70a081eb281dca22c87d62a8915f3eed3.zip
tests/Makefile.am: improved build of bad elf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6afc2e0..aac51c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,15 +2,18 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ([2.65])
-AC_INIT([parse-elf], [0.1], [blueness@gentoo.org])
-AC_CONFIG_SRCDIR([parse-elf.c])
+AC_INIT([elf-misc], [0.1], [blueness@gentoo.org])
+AC_CONFIG_SRCDIR([fix-gnustack.c])
#AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([1.11 foreign])
# Checks for programs.
AC_PROG_CC
+AC_CHECK_PROG([has_yasm],[yasm],["yes"],["no"])
+AS_IF([test "x$has_yasm" = "xno"],AC_MSG_ERROR(["Missing yasm assembler"]))
# Checks for libraries.
+AC_CHECK_LIB([elf], [elf_begin])
# Checks for header files.
AC_CHECK_HEADERS([fcntl.h stdlib.h unistd.h])