aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2010-02-05 06:44:10 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2010-02-05 06:44:10 +0000
commitdf2b070a6f7c6eee5f96bd873ecb325de47a83be (patch)
tree4fc0429aedca3f1c1fa115bb69991495ce562229
parentThe portage version of pixman compiles just fine, so remove it from the overlay. (diff)
downloadembedded-cross-df2b070a6f7c6eee5f96bd873ecb325de47a83be.tar.gz
embedded-cross-df2b070a6f7c6eee5f96bd873ecb325de47a83be.tar.bz2
embedded-cross-df2b070a6f7c6eee5f96bd873ecb325de47a83be.zip
Bump version of gnutls to latest portage stable.
-rw-r--r--net-libs/gnutls/Manifest2
-rw-r--r--net-libs/gnutls/gnutls-2.8.5.ebuild110
2 files changed, 112 insertions, 0 deletions
diff --git a/net-libs/gnutls/Manifest b/net-libs/gnutls/Manifest
index 683ad4c..e9f20ce 100644
--- a/net-libs/gnutls/Manifest
+++ b/net-libs/gnutls/Manifest
@@ -2,6 +2,8 @@ AUX gnutls-2.8.0-cross-configure.patch 780 RMD160 f229962e0a877695632b6f880c96b0
DIST gnutls-2.8.0.tar.bz2 6177498 RMD160 ad9d356ab55567ffc65c7fa4f48d8594a1cd5981 SHA1 7c102253bb4e817f393b9979a62c647010312eac SHA256 18a85a54aa2a26969e7bc91af06166a831182496c0cc215a032e7376f7b5129b
DIST gnutls-2.8.3.tar.bz2 6198273 RMD160 01763fad93e4b76e18dcfb1881c5f09011804dca SHA1 c25fb354258777f9ee34b79b08eb87c024cada75 SHA256 f08f49d6f0df2618bb4f995e73d2e1fe0ae5a999939b38954b067111da7d7998
DIST gnutls-2.8.4.tar.bz2 6193111 RMD160 f9236b3adf8ea3e747e1fb84d0ed19ae3294a522 SHA1 27bea240164b9287807543387682c7052f7318c2 SHA256 44a1f47b5df7a1ffc37b33801c7e529e380692d8c371a0f039b21698aab1b89c
+DIST gnutls-2.8.5.tar.bz2 6196862 RMD160 f160b8b413ae7e0b9243135fd8ffd0dd350d1504 SHA1 5121c52efd4718ad3d8b641d28343b0c6abaa571 SHA256 9249c29df71551e302e0186f4e1876dd6cc4c6cf2974b432c22525dde815cae8
EBUILD gnutls-2.8.0.ebuild 2518 RMD160 f407c1b9a3f849327f8b0f2fe8ed04b68df31ad5 SHA1 0544e2133d1c8e6bb1d406eac10fde397a1b1f90 SHA256 58b8da6a20fb545a4dc4c46fde949a01b04b6ec21f1f07b2806fdc9929a514c3
EBUILD gnutls-2.8.3.ebuild 2877 RMD160 3cde3377629a0fa78b9b8833be6f1bbbda17146e SHA1 3b1a04295a9ce36134286be180adb7f122124c42 SHA256 1ff351dfd22830d7db737733380f5dea88058b38093c3fdd0a53f57f0efed116
EBUILD gnutls-2.8.4.ebuild 2877 RMD160 3cde3377629a0fa78b9b8833be6f1bbbda17146e SHA1 3b1a04295a9ce36134286be180adb7f122124c42 SHA256 1ff351dfd22830d7db737733380f5dea88058b38093c3fdd0a53f57f0efed116
+EBUILD gnutls-2.8.5.ebuild 2900 RMD160 e1a940bcd36012b0c5958a785a145b9c65530f50 SHA1 044b0ce40b0c5d34f757a7c9bcec104833cc3946 SHA256 55fb166136bc8c5051e8d274427dc39ab368bfd6d41dd17be3145e5a9d144214
diff --git a/net-libs/gnutls/gnutls-2.8.5.ebuild b/net-libs/gnutls/gnutls-2.8.5.ebuild
new file mode 100644
index 0000000..dd74b26
--- /dev/null
+++ b/net-libs/gnutls/gnutls-2.8.5.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.8.5.ebuild,v 1.8 2010/01/30 17:34:22 armin76 Exp $
+
+EAPI="2"
+
+inherit autotools libtool
+
+DESCRIPTION="A TLS 1.0 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+
+if [[ "${PV}" == *pre* ]]; then
+ SRC_URI="http://daily.josefsson.org/${P%.*}/${P%.*}-${PV#*pre}.tar.gz"
+else
+ MINOR_VERSION="${PV#*.}"
+ MINOR_VERSION="${MINOR_VERSION%.*}"
+ if [[ $((MINOR_VERSION % 2)) == 0 ]]; then
+ #SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+ else
+ SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2"
+ fi
+ unset MINOR_VERSION
+fi
+
+# GPL-3 for the gnutls-extras library and LGPL for the gnutls library.
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="bindist +cxx doc examples guile lzo nls zlib"
+
+RDEPEND="dev-libs/libgpg-error
+ >=dev-libs/libgcrypt-1.4.0
+ >=dev-libs/libtasn1-0.3.4
+ nls? ( virtual/libintl )
+ guile? ( dev-scheme/guile[networking] )
+ zlib? ( >=sys-libs/zlib-1.1 )
+ !bindist? ( lzo? ( >=dev-libs/lzo-2 ) )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ doc? ( dev-util/gtk-doc )
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${P%_pre*}"
+
+pkg_setup() {
+ if use lzo && use bindist; then
+ ewarn "lzo support was disabled for binary distribution of gnutls"
+ ewarn "due to licensing issues. See Bug 202381 for details."
+ epause 5
+ fi
+}
+
+src_prepare() {
+ sed -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' -i doc/Makefile.am
+
+ # Make gnutls cross-compile by removing the libdir from the search path
+ epatch "${FILESDIR}/${PN}-2.8.0-cross-configure.patch"
+
+ local dir
+ for dir in m4 lib/m4 libextra/m4; do
+ rm -f "${dir}/lt"* "${dir}/libtool.m4"
+ done
+ find . -name ltmain.sh -exec rm {} \;
+ for dir in . lib libextra; do
+ pushd "${dir}" > /dev/null
+ eautoreconf
+ popd > /dev/null
+ done
+
+ elibtoolize # for sane .so versioning on FreeBSD
+}
+
+src_configure() {
+ local myconf
+
+ use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
+
+ # For cross-compilation we need to research the library parts.
+ if tc-is-cross-compiler ; then
+ myconf="${myconf} \
+ --without-libgcrypt-prefix \
+ --without-libtasn1-prefix \
+ --without-libreadline-prefix"
+ fi
+
+ econf --htmldir=/usr/share/doc/${P}/html \
+ $(use_enable cxx) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable guile) \
+ $(use_enable nls) \
+ $(use_with zlib) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS doc/TODO
+
+ if use doc; then
+ dodoc doc/gnutls.{pdf,ps}
+ dohtml doc/gnutls.html
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}