aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-05-08 06:19:54 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-05-08 06:19:54 +0000
commit6172c93fbc109e3593335339d0914ac22dc2983e (patch)
tree44e66fa8e3c1e04d3059b0b839d92f12ba533f77 /sys-libs
parentFix cross-compilation with +python. (diff)
downloadembedded-cross-6172c93fbc109e3593335339d0914ac22dc2983e.tar.gz
embedded-cross-6172c93fbc109e3593335339d0914ac22dc2983e.tar.bz2
embedded-cross-6172c93fbc109e3593335339d0914ac22dc2983e.zip
Add elibtoolize to make cracklib cross-compile (has old libtool version).
This fixes ticket http://gentoo.mindzoo.de/index.cgi/ticket/92.
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/cracklib/Manifest3
-rw-r--r--sys-libs/cracklib/cracklib-2.8.13.ebuild68
-rw-r--r--sys-libs/cracklib/files/cracklib-2.8.13-python-linkage.patch13
3 files changed, 84 insertions, 0 deletions
diff --git a/sys-libs/cracklib/Manifest b/sys-libs/cracklib/Manifest
new file mode 100644
index 0000000..213c878
--- /dev/null
+++ b/sys-libs/cracklib/Manifest
@@ -0,0 +1,3 @@
+AUX cracklib-2.8.13-python-linkage.patch 508 RMD160 fc6123093212c60c0d6de98a0b7390b52274ed28 SHA1 3514a018563e0848cdd9aa2625b7e003e875af8e SHA256 0958a6ce7ff7b89bb374281b0bd416af275d9f052d83d4fac493bee22aaa51f0
+DIST cracklib-2.8.13.tar.gz 593050 RMD160 948b02e6a74dfc94192f6f6ce9e3fc733d7a92f4 SHA1 e107d0a14c09aea9c63c18840db8b94b972b5315 SHA256 0a06caff3626c397d023f0c19efedfea295180c2c5ba2def57016a17e158041a
+EBUILD cracklib-2.8.13.ebuild 1758 RMD160 b5761c4c6619ec5b8a2072bcadc394df95fb0856 SHA1 7fde58c519f627542cd5203ee69e9af6624596ae SHA256 d01e37b341c36c5d0278734291e2ebd5126a10ce2e6bc258e942ba8230c4aa89
diff --git a/sys-libs/cracklib/cracklib-2.8.13.ebuild b/sys-libs/cracklib/cracklib-2.8.13.ebuild
new file mode 100644
index 0000000..1662a22
--- /dev/null
+++ b/sys-libs/cracklib/cracklib-2.8.13.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.8.13.ebuild,v 1.11 2009/03/17 10:13:35 armin76 Exp $
+
+inherit autotools eutils toolchain-funcs multilib
+
+MY_P=${P/_}
+DESCRIPTION="Password Checking Library"
+HOMEPAGE="http://sourceforge.net/projects/cracklib"
+SRC_URI="mirror://sourceforge/cracklib/${MY_P}.tar.gz"
+
+LICENSE="CRACKLIB"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE="nls python"
+
+DEPEND="python? ( dev-lang/python )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ # workaround #195017
+ if has unmerge-orphans ${FEATURES} && has_version "<${CATEGORY}/${PN}-2.8.10" ; then
+ eerror "Upgrade path is broken with FEATURES=unmerge-orphans"
+ eerror "Please run: FEATURES=-unmerge-orphans emerge cracklib"
+ die "Please run: FEATURES=-unmerge-orphans emerge cracklib"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-python-linkage.patch #246747
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ --with-default-dict='$(libdir)/cracklib_dict' \
+ $(use_enable nls) \
+ $(use_with python) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ rm -r "${D}"/usr/share/cracklib
+
+ # move shared libs to /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/ || die "could not move shared"
+ gen_usr_ldscript libcrack.so
+
+ insinto /usr/share/dict
+ doins dicts/cracklib-small || die "word dict"
+
+ dodoc AUTHORS ChangeLog NEWS README*
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == "/" ]] ; then
+ ebegin "Regenerating cracklib dictionary"
+ create-cracklib-dict /usr/share/dict/* > /dev/null
+ eend $?
+ fi
+}
diff --git a/sys-libs/cracklib/files/cracklib-2.8.13-python-linkage.patch b/sys-libs/cracklib/files/cracklib-2.8.13-python-linkage.patch
new file mode 100644
index 0000000..568d081
--- /dev/null
+++ b/sys-libs/cracklib/files/cracklib-2.8.13-python-linkage.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/246747
+
+--- cracklib/python/Makefile.in
++++ cracklib/python/Makefile.in
+@@ -57,7 +57,7 @@
+ am__installdirs = "$(DESTDIR)$(pyexecdir)" "$(DESTDIR)$(pythondir)"
+ pyexecLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(pyexec_LTLIBRARIES)
+-_cracklibmodule_la_LIBADD =
++_cracklibmodule_la_LIBADD = -lpython$(PYTHON_VERSION)
+ _cracklibmodule_la_SOURCES = _cracklibmodule.c
+ _cracklibmodule_la_OBJECTS = _cracklibmodule.lo
+ _cracklibmodule_la_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) \