aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2009-03-03 22:53:08 +0000
committerMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2009-03-03 22:53:08 +0000
commit78698325339dec159e72a3046e34b21e561618f0 (patch)
treef983cdec6ad7d410efdb190a278b4b9369ab7fb3 /sys-libs
parentadd pygobject-2.16.1 (diff)
downloadembedded-cross-78698325339dec159e72a3046e34b21e561618f0.tar.gz
embedded-cross-78698325339dec159e72a3046e34b21e561618f0.tar.bz2
embedded-cross-78698325339dec159e72a3046e34b21e561618f0.zip
add pam-1.0.4, patch for crosscompilation still works,
but still doesn't compile with USE="cracklib"
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/pam/Manifest4
-rw-r--r--sys-libs/pam/pam-1.0.3.ebuild2
-rw-r--r--sys-libs/pam/pam-1.0.4.ebuild183
3 files changed, 187 insertions, 2 deletions
diff --git a/sys-libs/pam/Manifest b/sys-libs/pam/Manifest
index df9461a..cb5bed4 100644
--- a/sys-libs/pam/Manifest
+++ b/sys-libs/pam/Manifest
@@ -6,5 +6,7 @@ AUX other.pamd 139 RMD160 d0f52fd0b830c86b0e933ebfaa8c2c1545337e43 SHA1 6d1f1a5f
AUX system-auth.pamd.epam 593 RMD160 262c88da0e6ac9ae09f0f1190de2f76396877807 SHA1 926c91cfa56c1480a7fe867ba902a94cf7e36ab7 SHA256 7896556f671ee88582babce4edd851fdc105a101bd8da48d2ef1dfd940b32eca
DIST Linux-PAM-1.0.2.tar.bz2 980345 RMD160 bcecf4f06330e11cc02bdafcbaab11435c4f922e SHA1 e7caf72a9c7afb23583f2e8c05c58da0f10c16e2 SHA256 42d06febf4717dd43eb557027d1b00a484c22589793438778ed69449a073a3b8
DIST Linux-PAM-1.0.3.tar.bz2 1009906 RMD160 4cb7bb6243a6dededdf183855807ede8d1da31e3 SHA1 ac82a41bbac940f2f777f85bbfb0c1e18dc8c393 SHA256 d6c03203bd383690fc1e756554ff1429b8d6a23c722761e21dbcb468572412f7
+DIST Linux-PAM-1.0.4.tar.bz2 1004979 RMD160 8eacf6344663c0ce2f42d374d82d717211ca10e5 SHA1 60146a363b653324d4477dce4a3e999834a2d713 SHA256 13136d438f5748d08dcb2227e44e53a3c611351b96e11891052e0c8c2557f3ca
EBUILD pam-1.0.2.ebuild 6016 RMD160 bacc20822fe8ac9a0b8b9bdabfbf86f9d9ca7abc SHA1 3be6c707bc38e316d4f23815ab4a1d32e8380931 SHA256 19e387675c070e5ca0739b64d4d13ba90eba7938bf2c47dfc7a9d34347061d6c
-EBUILD pam-1.0.3.ebuild 5757 RMD160 c6348662bb247af141854d9c26d90b482e58e02f SHA1 fe4f8f14a789afbd2b87c8a4412cecea10e08ae4 SHA256 2382e0f2ac68fb1f43d31f9d05857ccf4586db59c9cf29a3251906923a2cb158
+EBUILD pam-1.0.3.ebuild 5706 RMD160 6c1425e6f536454e73e7bcb2ec0b9316c3484447 SHA1 79d6fb1a66377e9bedc553271f0ea5660eb6e9e5 SHA256 65d1517b4d9a0a8d15145b93a26568dee0f1344b5df1a10045f15afe27ccd7b3
+EBUILD pam-1.0.4.ebuild 5706 RMD160 57c10343da6bc70e3b569135383d6129a27db630 SHA1 1e6d6d31444cfc73358c9786d276b7e75d410448 SHA256 b52ffba7fffc12396a87a6d34a1281292e39d7f921197a5f7aef21ee92780d09
diff --git a/sys-libs/pam/pam-1.0.3.ebuild b/sys-libs/pam/pam-1.0.3.ebuild
index 7613fed..4087388 100644
--- a/sys-libs/pam/pam-1.0.3.ebuild
+++ b/sys-libs/pam/pam-1.0.3.ebuild
@@ -109,7 +109,7 @@ src_unpack() {
# Remove NIS dependencies, see bug #235431
epatch "${FILESDIR}/${MY_PN}-1.0.2-noyp.patch"
- epatch "${FILESDIR}/${MY_PN}-1.0.2-cross-compile.patch"
+ epatch "${FILESDIR}/${MY_PN}-1.0.2-cross-compile.patch"
AT_M4DIR="m4" eautoreconf
diff --git a/sys-libs/pam/pam-1.0.4.ebuild b/sys-libs/pam/pam-1.0.4.ebuild
new file mode 100644
index 0000000..214d36c
--- /dev/null
+++ b/sys-libs/pam/pam-1.0.4.ebuild
@@ -0,0 +1,183 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-1.0.4.ebuild,v 1.1 2009/03/03 21:05:31 flameeyes Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit libtool multilib eutils autotools pam toolchain-funcs flag-o-matic
+
+MY_PN="Linux-PAM"
+MY_P="${MY_PN}-${PV}"
+
+HOMEPAGE="http://www.kernel.org/pub/linux/libs/pam/"
+DESCRIPTION="Linux-PAM (Pluggable Authentication Modules)"
+
+SRC_URI="mirror://kernel/linux/libs/pam/library/${MY_P}.tar.bz2"
+
+LICENSE="PAM"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="cracklib nls elibc_FreeBSD selinux vim-syntax audit test elibc_glibc"
+
+RDEPEND="nls? ( virtual/libintl )
+ sys-devel/flex
+ cracklib? ( >=sys-libs/cracklib-2.8.3 )
+ audit? ( sys-process/audit )
+ selinux? ( >=sys-libs/libselinux-1.28 )"
+DEPEND="${RDEPEND}
+ test? ( elibc_glibc? ( >=sys-libs/glibc-2.4 ) )
+ nls? ( sys-devel/gettext )"
+PDEPEND="sys-auth/pambase
+ vim-syntax? ( app-vim/pam-syntax )"
+
+S="${WORKDIR}/${MY_P}"
+
+PROVIDE="virtual/pam"
+
+check_old_modules() {
+ local retval="0"
+
+ if sed -e 's:#.*::' "${ROOT}"/etc/pam.d/* 2>/dev/null | fgrep -q pam_stack.so; then
+ eerror ""
+ eerror "Your current setup is using the pam_stack module."
+ eerror "This module is deprecated and no longer supported, and since version"
+ eerror "0.99 is no longer installed, nor provided by any other package."
+ eerror "The package will be built (to allow binary package builds), but will"
+ eerror "not be installed."
+ eerror "Please replace pam_stack usage with proper include directive usage,"
+ eerror "following the PAM Upgrade guide at the following URL"
+ eerror " http://www.gentoo.org/proj/en/base/pam/upgrade-0.99.xml"
+ eerror ""
+ ebeep 15
+
+ retval=1
+ fi
+
+ if sed -e 's:#.*::' "${ROOT}"/etc/pam.d/* 2>/dev/null | egrep -q 'pam_(pwdb|timestamp|console)'; then
+ eerror ""
+ eerror "Your current setup is using one or more of the following modules,"
+ eerror "that are not built or supported anymore:"
+ eerror "pam_pwdb, pam_timestamp, pam_console"
+ eerror "If you are in real need for these modules, please contact the maintainers"
+ eerror "of PAM through http://bugs.gentoo.org/ providing information about its"
+ eerror "use cases."
+ eerror "Please also make sure to read the PAM Upgrade guide at the following URL:"
+ eerror " http://www.gentoo.org/proj/en/base/pam/upgrade-0.99.xml"
+ eerror ""
+ ebeep 10
+
+ retval=1
+ fi
+
+ # Produce the warnings only during upgrade, for the following two
+ has_version '<sys-libs/pam-0.99' || return $retval
+
+ # This works only for those modules that are moved to sys-auth/$module, or the
+ # message will be wrong.
+ for module in pam_chroot pam_userdb pam_radius; do
+ if sed -e 's:#.*::' "${ROOT}"/etc/pam.d/* 2>/dev/null | fgrep -q ${module}.so; then
+ ewarn ""
+ ewarn "Your current setup is using the ${module} module."
+ ewarn "Since version 0.99, ${CATEGORY}/${PN} does not provide this module"
+ ewarn "anymore; if you want to continue using this module, you should install"
+ ewarn "sys-auth/${module}."
+ ewarn ""
+ ebeep 5
+ fi
+ done
+
+ return $retval
+}
+
+pkg_setup() {
+ check_old_modules
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ mkdir -p doc/txts
+ for readme in modules/pam_*/README; do
+ cp -f "${readme}" doc/txts/README.$(dirname "${readme}" | \
+ sed -e 's|^modules/||')
+ done
+
+ epatch "${FILESDIR}/${MY_PN}-0.99.7.0-disable-regenerate-man.patch"
+ epatch "${FILESDIR}/${MY_PN}-0.99.8.1-xtests.patch"
+
+ # Remove NIS dependencies, see bug #235431
+ epatch "${FILESDIR}/${MY_PN}-1.0.2-noyp.patch"
+ epatch "${FILESDIR}/${MY_PN}-1.0.2-cross-compile.patch"
+
+
+ AT_M4DIR="m4" eautoreconf
+
+ elibtoolize
+}
+
+src_compile() {
+ local myconf
+
+ if use hppa || use elibc_FreeBSD; then
+ myconf="${myconf} --disable-pie"
+ fi
+
+ # KEEP COMMENTED OUT! It seems like it fails to build with USE=debug!
+ # Do _not_ move this to $(use_enable) without checking if the
+ # configure.in has been fixed. As of 2009/03/03 it's still broken
+ # on upstream's CVS, and --disable-debug means --enable-debug too.
+ # if use debug; then
+ # myconf="${myconf} --enable-debug"
+ # fi
+
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html \
+ --enable-securedir=/$(get_libdir)/security \
+ --enable-isadir=/$(get_libdir)/security \
+ $(use_enable nls) \
+ $(use_enable selinux) \
+ $(use_enable cracklib) \
+ $(use_enable audit) \
+ --disable-db \
+ --disable-dependency-tracking \
+ --disable-prelude \
+ --disable-regenerate-man \
+ ${myconf} || die "econf failed"
+ emake sepermitlockdir="/var/run/sepermit" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install \
+ sepermitlockdir="/var/run/sepermit" || die "make install failed"
+
+ # Need to be suid
+ fperms u+s /sbin/unix_chkpwd
+
+ dodir /$(get_libdir)
+ mv "${D}/usr/$(get_libdir)/libpam.so"* "${D}/$(get_libdir)/"
+ mv "${D}/usr/$(get_libdir)/libpamc.so"* "${D}/$(get_libdir)/"
+ mv "${D}/usr/$(get_libdir)/libpam_misc.so"* "${D}/$(get_libdir)/"
+ gen_usr_ldscript libpam.so libpamc.so libpam_misc.so
+
+ dodoc CHANGELOG ChangeLog README AUTHORS Copyright
+ docinto modules ; dodoc doc/txts/README.*
+
+ # Remove the wrongly installed manpages
+ rm "${D}"/usr/share/man/man8/pam_userdb.8*
+ use cracklib || rm "${D}"/usr/share/man/man8/pam_cracklib.8*
+
+ # Get rid of the .la files. We certainly don't need them for PAM
+ # modules, and libpam is installed as a shared object only, so we
+ # don't ned them for static linking either.
+ find "${D}" -name '*.la' -delete
+}
+
+pkg_preinst() {
+ check_old_modules || die "deprecated PAM modules still used"
+
+ pam_epam_expand "${D}"/etc/pam.d/*
+}