aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-05-28 18:28:50 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-05-28 18:28:50 +0000
commit3ae38630a07af99ee5f345c064d1c9797ab77ff2 (patch)
treec5ecbdd9124b4c5bcf9c51383e18ba01e4a83d38 /x11-libs
parentcairo-1.8.6-r1 is stable now. (diff)
downloadembedded-cross-3ae38630a07af99ee5f345c064d1c9797ab77ff2.tar.gz
embedded-cross-3ae38630a07af99ee5f345c064d1c9797ab77ff2.tar.bz2
embedded-cross-3ae38630a07af99ee5f345c064d1c9797ab77ff2.zip
Remove cairo RDEPEND/DEPEND fix. Use --root-deps instead!
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/cairo/Manifest3
-rw-r--r--x11-libs/cairo/cairo-1.8.6.ebuild100
-rw-r--r--x11-libs/cairo/files/cairo-1.2.4-lcd-cleartype-like.diff275
3 files changed, 0 insertions, 378 deletions
diff --git a/x11-libs/cairo/Manifest b/x11-libs/cairo/Manifest
deleted file mode 100644
index d38d418..0000000
--- a/x11-libs/cairo/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-AUX cairo-1.2.4-lcd-cleartype-like.diff 7244 RMD160 e50d5bf17cbead688a8b808a78fe4104c09af52e SHA1 f63131fd75bb496db59e3ce6bc755bbfb70baacb SHA256 4926d20d2b6b5071a5bf9ee9a12a36fef69510ebebd717c1dab151fe650f173a
-DIST cairo-1.8.6.tar.gz 6616544 RMD160 2374236afabbe248a642bf1cac6a5996f64bed62 SHA1 d1e5479d4eeb7b1a3589672e3ef8f4899e7c5eba SHA256 93a347af0cecf258be8fb54265b16a0fb16317df4a32896141d2987c30773535
-EBUILD cairo-1.8.6.ebuild 2973 RMD160 c73ea8295ac555fb16857756e2cab09e78ddefee SHA1 4362e04f83951e2c9e03c145df0926acc1dadeb0 SHA256 7381520601c70ffa6ec0fd957c9f4013933932aaaeac9f8af697e6766d9e2ffa
diff --git a/x11-libs/cairo/cairo-1.8.6.ebuild b/x11-libs/cairo/cairo-1.8.6.ebuild
deleted file mode 100644
index f902459..0000000
--- a/x11-libs/cairo/cairo-1.8.6.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.8.6.ebuild,v 1.4 2009/01/05 13:26:13 remi Exp $
-
-inherit eutils flag-o-matic libtool
-
-DESCRIPTION="A vector graphics library with cross-device output support"
-HOMEPAGE="http://cairographics.org/"
-SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
-
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="cleartype debug directfb doc glitz opengl svg X xcb"
-
-# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
-RESTRICT="test"
-
-RDEPEND="media-libs/fontconfig
- >=media-libs/freetype-2.1.9
- sys-libs/zlib
- media-libs/libpng
- >=x11-libs/pixman-0.12.0
- directfb? ( >=dev-libs/DirectFB-0.9.24 )
- glitz? ( >=media-libs/glitz-0.5.1 )
- svg? ( dev-libs/libxml2 )
- X? ( >=x11-libs/libXrender-0.6
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXft )
- xcb? ( >=x11-libs/libxcb-0.92
- x11-libs/xcb-util )"
-# test? (
-# pdf test
-# x11-libs/pango
-# >=x11-libs/gtk+-2.0
-# >=app-text/poppler-bindings-0.9.2
-# ps test
-# virtual/ghostscript
-# svg test
-# >=x11-libs/gtk+-2.0
-# >=gnome-base/librsvg-2.15.0
-
-DEPEND=">=dev-util/pkgconfig-0.19
- doc? ( >=dev-util/gtk-doc-1.6
- ~app-text/docbook-xml-dtd-4.2 )
- X? ( x11-proto/renderproto )
- xcb? ( x11-proto/xcb-proto )"
-
-#pkg_setup() {
-# if ! built_with_use app-text/poppler-bindings gtk ; then
-# eerror 'poppler-bindings with gtk is required for the pdf backend'
-# die 'poppler-bindings built without gtk support'
-# fi
-#}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # ClearType-like patches applied by ArchLinux
- use cleartype && epatch "${FILESDIR}"/cairo-1.2.4-lcd-cleartype-like.diff
-
- # We need to run elibtoolize to ensure correct so versioning on FreeBSD
- elibtoolize
-}
-
-src_compile() {
- #gets rid of fbmmx.c inlining warnings
- append-flags -finline-limit=1200
-
- if use glitz && use opengl; then
- export glitz_LIBS=$(pkg-config --libs glitz-glx)
- fi
-
- econf $(use_enable X xlib) $(use_enable doc gtk-doc) \
- $(use_enable directfb) $(use_enable xcb) \
- $(use_enable svg) $(use_enable glitz) $(use_enable X xlib-xrender) \
- $(use_enable debug test-surfaces) --enable-pdf --enable-png \
- --enable-ft --enable-ps \
- || die "configure failed"
-
- emake || die "compile failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "Installation failed"
- dodoc AUTHORS ChangeLog NEWS README
-}
-
-pkg_postinst() {
- if use xcb; then
- ewarn "You have enabled the Cairo XCB backend which is used only by"
- ewarn "a select few apps. The Cairo XCB backend is presently"
- ewarn "un-maintained and needs a lot of work to get it caught up"
- ewarn "to the Xrender and Xlib backends, which are the backends used"
- ewarn "by most applications. See:"
- ewarn "http://lists.freedesktop.org/archives/xcb/2008-December/004139.html"
- fi
-}
diff --git a/x11-libs/cairo/files/cairo-1.2.4-lcd-cleartype-like.diff b/x11-libs/cairo/files/cairo-1.2.4-lcd-cleartype-like.diff
deleted file mode 100644
index 2f908b8..0000000
--- a/x11-libs/cairo/files/cairo-1.2.4-lcd-cleartype-like.diff
+++ /dev/null
@@ -1,275 +0,0 @@
-diff -rup libcairo-1.2.4.orig/src/cairo-ft-font.c libcairo-1.2.4/src/cairo-ft-font.c
---- libcairo-1.2.4.orig/src/cairo-ft-font.c 2006-08-22 21:40:02.802247352 +0800
-+++ libcairo-1.2.4/src/cairo-ft-font.c 2006-08-22 21:40:39.443677008 +0800
-@@ -53,6 +53,8 @@
- #include FT_SYNTHESIS_H
- #endif
-
-+#define FIR_FILTER 1
-+
- #define DOUBLE_TO_26_6(d) ((FT_F26Dot6)((d) * 64.0))
- #define DOUBLE_FROM_26_6(t) ((double)(t) / 64.0)
- #define DOUBLE_TO_16_16(d) ((FT_Fixed)((d) * 65536.0))
-@@ -492,6 +494,8 @@ _cairo_ft_unscaled_font_destroy (void *a
- }
- }
-
-+static const int fir_filter[5] = { 0x1C, 0x38, 0x55, 0x38, 0x1C };
-+
- static cairo_bool_t
- _has_unlocked_face (void *entry)
- {
-@@ -779,7 +783,220 @@ _get_bitmap_surface (FT_Bitmap *bi
- }
- format = CAIRO_FORMAT_A8;
- break;
-- case CAIRO_ANTIALIAS_SUBPIXEL: {
-+ case CAIRO_ANTIALIAS_SUBPIXEL:
-+#ifdef FIR_FILTER
-+ {
-+ unsigned char* line;
-+ unsigned char* bufBitmap;
-+ int pitch;
-+ unsigned char *data_rgba;
-+ unsigned int width_rgba, stride_rgba;
-+ int vmul = 1;
-+ int hmul = 1;
-+
-+ switch (font_options->subpixel_order) {
-+ case CAIRO_SUBPIXEL_ORDER_DEFAULT:
-+ case CAIRO_SUBPIXEL_ORDER_RGB:
-+ case CAIRO_SUBPIXEL_ORDER_BGR:
-+ default:
-+ width /= 3;
-+ hmul = 3;
-+ break;
-+ case CAIRO_SUBPIXEL_ORDER_VRGB:
-+ case CAIRO_SUBPIXEL_ORDER_VBGR:
-+ vmul = 3;
-+ height /= 3;
-+ break;
-+ }
-+ /*
-+ * Filter the glyph to soften the color fringes
-+ */
-+ width_rgba = width;
-+ stride = bitmap->pitch;
-+ stride_rgba = (width_rgba * 4 + 3) & ~3;
-+ data_rgba = calloc (1, stride_rgba * height);
-+
-+ /* perform in-place FIR filtering in either the horizontal or
-+ * vertical direction. We're going to modify the RGB graymap,
-+ * but that's ok, because we either own it, or its part of
-+ * the FreeType glyph slot, which will not be used anymore.
-+ */
-+ pitch = bitmap->pitch;
-+ line = (unsigned char*)bitmap->buffer;
-+ if ( pitch < 0 )
-+ line -= pitch*(height-1);
-+
-+ bufBitmap = line;
-+
-+ switch (font_options->subpixel_order) {
-+ case CAIRO_SUBPIXEL_ORDER_DEFAULT:
-+ case CAIRO_SUBPIXEL_ORDER_RGB:
-+ case CAIRO_SUBPIXEL_ORDER_BGR:
-+ {
-+ int h;
-+
-+ for ( h = height; h > 0; h--, line += pitch ) {
-+ int pix[6] = { 0, 0, 0, 0, 0, 0 };
-+ unsigned char* p = line;
-+ unsigned char* limit = line + width*3;
-+ int nn, val, val2;
-+
-+ val = p[0];
-+ for (nn = 0; nn < 3; nn++)
-+ pix[2 + nn] += val * fir_filter[nn];
-+
-+ val = p[1];
-+ for (nn = 0; nn < 4; nn++)
-+ pix[1 + nn] += val * fir_filter[nn];
-+
-+ p += 2;
-+
-+ for ( ; p < limit; p++ ) {
-+ val = p[0];
-+ for (nn = 0; nn < 5; nn++)
-+ pix[nn] += val * fir_filter[nn];
-+
-+ val2 = pix[0] / 256;
-+ val2 |= -(val2 >> 8);
-+ p[-2] = (unsigned char)val2;
-+
-+ for (nn = 0; nn < 5; nn++)
-+ pix[nn] = pix[nn + 1];
-+ }
-+ for (nn = 0; nn < 2; nn++ ) {
-+ val2 = pix[nn] / 256;
-+ val2 |= -(val2 >> 8);
-+ p[nn - 2] = (unsigned char)val2;
-+ }
-+ }
-+ }
-+ break;
-+ case CAIRO_SUBPIXEL_ORDER_VRGB:
-+ case CAIRO_SUBPIXEL_ORDER_VBGR:
-+ {
-+ int w;
-+
-+ for (w = 0; w < width; w++ ) {
-+ int pix[6] = { 0, 0, 0, 0, 0, 0 };
-+ unsigned char* p = bufBitmap + w;
-+ unsigned char* limit = bufBitmap + w + height*3*pitch;
-+ int nn, val, val2;
-+
-+ val = p[0];
-+ for (nn = 0; nn < 3; nn++)
-+ pix[2 + nn] += val*fir_filter[nn];
-+
-+ val = p[pitch];
-+ for (nn = 0; nn < 4; nn++ )
-+ pix[1 + nn] += val * fir_filter[nn];
-+
-+ p += 2*pitch;
-+ for ( ; p < limit; p += pitch ) {
-+ val = p[0];
-+ for (nn = 0; nn < 5; nn++ )
-+ pix[nn] += val * fir_filter[nn];
-+
-+ val2 = pix[0] / 256;
-+ val2 |= -(val2 >> 8);
-+ p[-2 * pitch] = (unsigned char)val2;
-+
-+ for (nn = 0; nn < 5; nn++)
-+ pix[nn] = pix[nn+1];
-+ }
-+
-+ for (nn = 0; nn < 2; nn++) {
-+ val2 = pix[nn] / 256;
-+ val2 |= -(val2 >> 8);
-+ p[(nn - 2) * pitch] = (unsigned char)val2;
-+ }
-+ }
-+ }
-+ break;
-+ default: /* shouldn't happen */
-+ break;
-+ }
-+
-+ /* now copy the resulting graymap into an ARGB32 image */
-+ {
-+ unsigned char* in_line = bufBitmap;
-+ unsigned char* out_line = data_rgba;
-+ int h = height;
-+
-+ switch (font_options->subpixel_order) {
-+ case CAIRO_SUBPIXEL_ORDER_DEFAULT:
-+ case CAIRO_SUBPIXEL_ORDER_RGB:
-+ for ( ; h > 0; h--, in_line += pitch, out_line += stride_rgba) {
-+ unsigned char* in = in_line;
-+ int* out = (int*)out_line;
-+ int w;
-+
-+ for (w = width; w > 0; w--, in += 3, out += 1) {
-+ int r = in[0];
-+ int g = in[1];
-+ int b = in[2];
-+
-+ out[0] = (g << 24) | (r << 16) | (g << 8) | b;
-+ }
-+ }
-+ break;
-+ case CAIRO_SUBPIXEL_ORDER_BGR:
-+ for ( ; h > 0; h--, in_line += pitch, out_line += stride_rgba) {
-+ unsigned char* in = in_line;
-+ int* out = (int*)out_line;
-+ int w;
-+
-+ for (w = width; w > 0; w--, in += 3, out += 1) {
-+ int r = in[2];
-+ int g = in[1];
-+ int b = in[0];
-+
-+ out[0] = (g << 24) | (r << 16) | (g << 8) | b;
-+ }
-+ }
-+ break;
-+ case CAIRO_SUBPIXEL_ORDER_VRGB:
-+ for ( ; h > 0; h--, in_line += pitch*3, out_line += stride_rgba) {
-+ unsigned char* in = in_line;
-+ int* out = (int*)out_line;
-+ int w;
-+
-+ for (w = width; w > 0; w--, in += 1, out += 1) {
-+ int r = in[0];
-+ int g = in[pitch];
-+ int b = in[pitch*2];
-+
-+ out[0] = (g << 24) | (r << 16) | (g << 8) | b;
-+ }
-+ }
-+ break;
-+ case CAIRO_SUBPIXEL_ORDER_VBGR:
-+ for ( ; h > 0; h--, in_line += pitch*3, out_line += stride_rgba) {
-+ unsigned char* in = in_line;
-+ int* out = (int*)out_line;
-+ int w;
-+
-+ for (w = width; w > 0; w--, in += 1, out += 1) {
-+ int r = in[2*pitch];
-+ int g = in[pitch];
-+ int b = in[0];
-+
-+ out[0] = (g << 24) | (r << 16) | (g << 8) | b;
-+ }
-+ }
-+ break;
-+ }
-+ }
-+
-+ if (own_buffer)
-+ free (bitmap->buffer);
-+ data = data_rgba;
-+ stride = stride_rgba;
-+ format = CAIRO_FORMAT_ARGB32;
-+ subpixel = TRUE;
-+ break;
-+ }
-+#else /* !FIR_FILTER */
-+ {
- int x, y;
- unsigned char *in_line, *out_line, *in;
- unsigned int *out;
-@@ -871,6 +1088,7 @@ _get_bitmap_surface (FT_Bitmap *bi
- subpixel = TRUE;
- break;
- }
-+#endif /* !FIR_FILTER */
- }
- break;
- case FT_PIXEL_MODE_GRAY2:
-@@ -986,12 +1204,22 @@ _render_glyph_outline (FT_Face
- matrix.xx *= 3;
- hmul = 3;
- subpixel = TRUE;
-+#ifdef FIR_FILTER
-+ cbox.xMin -= 64;
-+ cbox.xMax += 64;
-+ width += 2;
-+#endif
- break;
- case CAIRO_SUBPIXEL_ORDER_VRGB:
- case CAIRO_SUBPIXEL_ORDER_VBGR:
- matrix.yy *= 3;
- vmul = 3;
- subpixel = TRUE;
-+#ifdef FIR_FILTER
-+ cbox.yMin -= 64;
-+ cbox.yMax += 64;
-+ height += 2;
-+#endif
- break;
- }
- FT_Outline_Transform (outline, &matrix);
-Only in libcairo-1.2.4/src: cairo-ft-font.c.orig