summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2010-10-22 19:31:41 +0000
committerThomas Sachau <tommy@gentoo.org>2010-10-22 19:31:41 +0000
commitf9f46625e0e6aa8696c51d9055c9b0d7c699670e (patch)
tree015cfd20e252b92807cbb5ebbf6b613ec6aed904 /dev-python
parentAdd optional gles support to live ebuild of evas (diff)
downloadenlightenment-f9f46625e0e6aa8696c51d9055c9b0d7c699670e.tar.gz
enlightenment-f9f46625e0e6aa8696c51d9055c9b0d7c699670e.tar.bz2
enlightenment-f9f46625e0e6aa8696c51d9055c9b0d7c699670e.zip
Update python-e_dbus to use PYTHON_DEPEND and to support multiple python ABIs
(Portage version: 2.2_rc99-r1/svn/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-e_dbus/python-e_dbus-9999.ebuild33
1 files changed, 25 insertions, 8 deletions
diff --git a/dev-python/python-e_dbus/python-e_dbus-9999.ebuild b/dev-python/python-e_dbus/python-e_dbus-9999.ebuild
index c04cded..6b1efaa 100644
--- a/dev-python/python-e_dbus/python-e_dbus-9999.ebuild
+++ b/dev-python/python-e_dbus/python-e_dbus-9999.ebuild
@@ -1,21 +1,38 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
-NEED_PYTHON="2.4"
+EAPI=2
+
+E_PYTHON=1
+SUPPORT_PYTHON_ABIS="1"
+RESTRIC_PYTHON_ABIS="3.*"
ESVN_SUB_PROJECT="BINDINGS/python"
-inherit enlightenment distutils
+inherit enlightenment
DESCRIPTION="Python bindings for E_DBUS library"
LICENSE="LGPL-2.1"
IUSE=""
-RDEPEND=">=x11-libs/e_dbus-9999"
+RDEPEND=">=x11-libs/e_dbus-9999
+ dev-python/dbus-python"
DEPEND="${RDEPEND}
- dev-util/pkgconfig
- >=dev-python/setuptools-0.6_rc9"
+ dev-util/pkgconfig"
+
+src_prepare() {
+ enlightenment_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_execute_function -s enlightenment_src_configure
+}
+
+src_compile() {
+ python_execute_function -s enlightenment_src_compile
+}
-src_unpack() {
- enlightenment_src_unpack
+src_install() {
+ python_execute_function -s enlightenment_src_install
}