summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-07-25 19:45:42 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-07-25 19:45:42 -0400
commit66fee3ec3c7a8cea2332123c6a772d1bc0e35dda (patch)
treee29d230a2bbb29e9ecea607dc3a80b14adf99b92
parentconfigure.ac: update the version to 0.9.3. (diff)
downloadeselect-php-66fee3ec3c7a8cea2332123c6a772d1bc0e35dda.tar.gz
eselect-php-66fee3ec3c7a8cea2332123c6a772d1bc0e35dda.tar.bz2
eselect-php-66fee3ec3c7a8cea2332123c6a772d1bc0e35dda.zip
Rename OpenRC init script and config file.
The OpenRC init script is now installed by the Makefile, so to be useful it needs to be called "php-fpm". To that end, I've renamed both the init script and the config file to lack the word "example". Moreover, now that these files are code-like and not documentation-like, I've renamed the directory containing them from "doc" to "openrc".
-rw-r--r--.gitignore4
-rw-r--r--Makefile.am6
-rw-r--r--configure.ac2
-rw-r--r--openrc/php-fpm.conf (renamed from doc/php-fpm.example.conf)0
-rw-r--r--openrc/php-fpm.in.in (renamed from doc/php-fpm.example.init.in.in)0
5 files changed, 6 insertions, 6 deletions
diff --git a/.gitignore b/.gitignore
index 9561ed8..ab72e36 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,8 +6,8 @@ autom4te.cache/
config.log
config.status
configure
-doc/php-fpm.example.init
-doc/php-fpm.example.init.in
+openrc/php-fpm
+openrc/php-fpm.in
install-sh
missing
src/php.eselect
diff --git a/Makefile.am b/Makefile.am
index eb3b89b..2b3bf67 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,10 +1,10 @@
eselectdir = $(datadir)/eselect/modules
nodist_eselect_DATA = $(srcdir)/src/php.eselect
initdir = $(sysconfdir)/init.d
-nodist_init_DATA = $(srcdir)/doc/php-fpm.example.init
+nodist_init_DATA = $(srcdir)/openrc/php-fpm
# Without EXTRA_DIST, these files don't wind up in the tarball.
-EXTRA_DIST = $(srcdir)/src/70_mod_php.conf.in doc/*.*
+EXTRA_DIST = $(srcdir)/src/70_mod_php.conf.in openrc/*.*
if APACHE2
# Without these set, we won't try to install the conf file.
@@ -30,4 +30,4 @@ $(nodist_eselect_DATA) $(nodist_apacheconf_DATA) $(nodist_init_DATA): Makefile
$(srcdir)/src/php.eselect: $(srcdir)/src/php.eselect.in
$(srcdir)/src/70_mod_php.conf: $(srcdir)/src/70_mod_php.conf.in
-$(srcdir)/doc/php-fpm.example.init: $(srcdir)/doc/php-fpm.example.init.in
+$(srcdir)/openrc/php-fpm: $(srcdir)/openrc/php-fpm.in
diff --git a/configure.ac b/configure.ac
index c7702d5..5e6ccfc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,6 @@ AC_ARG_WITH(piddir, AC_HELP_STRING([--with-piddir=DIR],
AC_SUBST(piddir)
# List of output files.
-AC_CONFIG_FILES([Makefile src/php.eselect.in doc/php-fpm.example.init.in])
+AC_CONFIG_FILES([Makefile src/php.eselect.in openrc/php-fpm.in])
AC_OUTPUT
diff --git a/doc/php-fpm.example.conf b/openrc/php-fpm.conf
index b3efdbf..b3efdbf 100644
--- a/doc/php-fpm.example.conf
+++ b/openrc/php-fpm.conf
diff --git a/doc/php-fpm.example.init.in.in b/openrc/php-fpm.in.in
index 2eaa2c3..2eaa2c3 100644
--- a/doc/php-fpm.example.init.in.in
+++ b/openrc/php-fpm.in.in