summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-01-22 18:21:45 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-01-23 10:05:58 -0500
commitb341d98c011d3a829c2a5b40a6c5b83680d6d98e (patch)
tree0fbe09e6d2991c06a4a0afeeceed476ce539ebba
parentconfigure.ac: update to version 0.9.6. (diff)
downloadeselect-php-b341d98c011d3a829c2a5b40a6c5b83680d6d98e.tar.gz
eselect-php-b341d98c011d3a829c2a5b40a6c5b83680d6d98e.tar.bz2
eselect-php-b341d98c011d3a829c2a5b40a6c5b83680d6d98e.zip
Makefile.am: remove redundant $(srcdir)s.
The $(srcdir) in Makefile.am is implicit. Let's keep it that way. Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--Makefile.am32
1 files changed, 16 insertions, 16 deletions
diff --git a/Makefile.am b/Makefile.am
index e425c84..df6430a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,33 +1,33 @@
eselectdir = $(datadir)/eselect/modules
-nodist_eselect_DATA = $(srcdir)/src/php.eselect
+nodist_eselect_DATA = src/php.eselect
# Without EXTRA_DIST, these files don't wind up in the tarball.
-EXTRA_DIST = $(srcdir)/openrc \
- $(srcdir)/src/70_mod_php.conf.in \
- $(srcdir)/src/php-fpm-launcher.in \
- $(srcdir)/src/php-fpm.logrotate.in
+EXTRA_DIST = openrc \
+ src/70_mod_php.conf.in \
+ src/php-fpm-launcher.in \
+ src/php-fpm.logrotate.in
if APACHE2
# Without these set, we won't try to install the conf file.
apacheconfdir = $(sysconfdir)/apache2/modules.d
- nodist_apacheconf_DATA = $(srcdir)/src/70_mod_php.conf
+ nodist_apacheconf_DATA = src/70_mod_php.conf
endif
if FPM
# Same as the APACHE2 conditional.
initdir = $(sysconfdir)/init.d
- nodist_init_SCRIPTS = $(srcdir)/openrc/init.d/php-fpm
+ nodist_init_SCRIPTS = openrc/init.d/php-fpm
confdir = $(sysconfdir)/conf.d
- nodist_conf_DATA = $(srcdir)/openrc/conf.d/php-fpm
+ nodist_conf_DATA = openrc/conf.d/php-fpm
- nodist_libexec_SCRIPTS = $(srcdir)/src/php-fpm-launcher
+ nodist_libexec_SCRIPTS = src/php-fpm-launcher
logrotatedir = $(sysconfdir)/logrotate.d
- nodist_logrotate_DATA = $(srcdir)/src/php-fpm.logrotate
+ nodist_logrotate_DATA = src/php-fpm.logrotate
tmpfilesdir = $(prefix)/lib/tmpfiles.d
- dist_tmpfiles_DATA = $(srcdir)/src/php-fpm.conf
+ dist_tmpfiles_DATA = src/php-fpm.conf
endif
# The next few rules allow us to replace bindir, libdir, etc.
@@ -48,8 +48,8 @@ $(nodist_eselect_DATA) $(nodist_apacheconf_DATA) $(nodist_init_SCRIPTS) $(nodist
$(edit) $${srcdir}$@.in > $@.tmp
mv $@.tmp $@
-$(srcdir)/src/php.eselect: $(srcdir)/src/php.eselect.in
-$(srcdir)/src/php-fpm-launcher: $(srcdir)/src/php-fpm-launcher.in
-$(srcdir)/src/php-fpm.logrotate: $(srcdir)/src/php-fpm.logrotate.in
-$(srcdir)/src/70_mod_php.conf: $(srcdir)/src/70_mod_php.conf.in
-$(srcdir)/openrc/init.d/php-fpm: $(srcdir)/openrc/init.d/php-fpm.in
+src/php.eselect: src/php.eselect.in
+src/php-fpm-launcher: src/php-fpm-launcher.in
+src/php-fpm.logrotate: src/php-fpm.logrotate.in
+src/70_mod_php.conf: src/70_mod_php.conf.in
+openrc/init.d/php-fpm: openrc/init.d/php-fpm.in