summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c118e0e..f977807 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,6 +7,20 @@ AC_PROG_SED
AC_PATH_PROG(SORT,sort)
AC_PATH_PROG(UNIQ,uniq)
+
+# --enable-apache2 flag, disabled by default, that decides whether or
+# not we install the apache2 module configuration file.
+AC_ARG_ENABLE(
+ [apache2],
+ [ --enable-apache2 install the apache2 conf file [[default=no]]],
+ [case "${enableval}" in
+ yes) apache2=true ;;
+ no) apache2=false ;;
+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-apache2]) ;;
+ esac],[apache2=false])
+ AM_CONDITIONAL([APACHE2], [test x$apache2 = xtrue])
+
+
# List of output files.
AC_CONFIG_FILES([Makefile src/php.eselect.in])