aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2025-01-05 21:57:43 +0100
committerUlrich Müller <ulm@gentoo.org>2025-01-05 21:57:43 +0100
commit66a48765af817049f9aebd17bdd56688b4ecc5d7 (patch)
treed0c8018045ff30294eb6b4f16a738ae79fd4cd9f
parentUpdate version to 1.4.28 (diff)
downloadeselect-66a48765af817049f9aebd17bdd56688b4ecc5d7.tar.gz
eselect-66a48765af817049f9aebd17bdd56688b4ecc5d7.tar.bz2
eselect-66a48765af817049f9aebd17bdd56688b4ecc5d7.zip
Replace "root privileges" with "superuser privileges"
* libs/editor-variable.bash.in (write_env_value): * modules/env.eselect (do_update): * modules/kernel.eselect (test_for_root): * modules/locale.eselect (write_env_value): Replace "root privileges" with "superuser privileges". Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--ChangeLog8
-rw-r--r--libs/editor-variable.bash.in4
-rw-r--r--modules/env.eselect6
-rw-r--r--modules/kernel.eselect5
-rw-r--r--modules/locale.eselect4
-rw-r--r--modules/modules.eselect2
6 files changed, 19 insertions, 10 deletions
diff --git a/ChangeLog b/ChangeLog
index 1ae3225..f5f84ca 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,11 @@
+2025-01-05 Ulrich Müller <ulm@gentoo.org>
+
+ * libs/editor-variable.bash.in (write_env_value):
+ * modules/env.eselect (do_update):
+ * modules/kernel.eselect (test_for_root):
+ * modules/locale.eselect (write_env_value): Replace "root
+ privileges" with "superuser privileges".
+
2024-11-18 Ulrich Müller <ulm@gentoo.org>
* configure.ac: Update version to 1.4.28.
diff --git a/libs/editor-variable.bash.in b/libs/editor-variable.bash.in
index b7420b1..2fda5e2 100644
--- a/libs/editor-variable.bash.in
+++ b/libs/editor-variable.bash.in
@@ -1,5 +1,5 @@
# -*-eselect-*- vim: ft=eselect
-# Copyright (c) 2005-2020 Gentoo Authors
+# Copyright (c) 2005-2025 Gentoo Authors
#
# This file is part of the 'eselect' tools framework.
#
@@ -75,7 +75,7 @@ read_env_value() {
# write variable to config file
write_env_value() {
[[ -w ${EROOT}${EDITOR_ENVFILE%/*} ]] \
- || die -q "You need root privileges!"
+ || die -q "You need superuser privileges!"
store_config "${EROOT}${EDITOR_ENVFILE}" "${EDITOR_VAR}" "$1"
}
diff --git a/modules/env.eselect b/modules/env.eselect
index 21369d2..c30b526 100644
--- a/modules/env.eselect
+++ b/modules/env.eselect
@@ -1,5 +1,5 @@
# -*-eselect-*- vim: ft=eselect
-# Copyright 2005-2023 Gentoo Authors
+# Copyright 2005-2025 Gentoo Authors
# Distributed under the terms of the GNU GPL version 2 or later
inherit config multilib package-manager
@@ -265,9 +265,9 @@ do_update() {
# Test for sufficient permissions
if [[ -e ${ENVPROFILE} ]]; then
- [[ -w ${ENVPROFILE} ]] || die -q "You need to be root!"
+ [[ -w ${ENVPROFILE} ]] || die -q "You need superuser privileges!"
else
- touch "${ENVPROFILE}" || die -q "You need to be root!"
+ touch "${ENVPROFILE}" || die -q "You need superuser privileges!"
fi
# Use the package manager's env-update command if available,
diff --git a/modules/kernel.eselect b/modules/kernel.eselect
index e181886..f27b60b 100644
--- a/modules/kernel.eselect
+++ b/modules/kernel.eselect
@@ -1,5 +1,5 @@
# -*-eselect-*- vim: ft=eselect
-# Copyright 2005-2023 Gentoo Authors
+# Copyright 2005-2025 Gentoo Authors
# Distributed under the terms of the GNU GPL version 2 or later
DESCRIPTION="Manage the /usr/src/linux symlink"
@@ -191,6 +191,7 @@ do_update() {
test_for_root() {
if [[ ! -w ${EROOT}/usr/src ]]; then
- die -q "${EROOT}/usr/src not writeable by current user. Are you root?"
+ write_error_msg "${EROOT}/usr/src not writeable by current user."
+ die -q "You need superuser privileges!"
fi
}
diff --git a/modules/locale.eselect b/modules/locale.eselect
index f91c1c5..92c5fc4 100644
--- a/modules/locale.eselect
+++ b/modules/locale.eselect
@@ -1,5 +1,5 @@
# -*-eselect-*- vim: ft=eselect
-# Copyright 2005-2020 Gentoo Authors
+# Copyright 2005-2025 Gentoo Authors
# Distributed under the terms of the GNU GPL version 2 or later
inherit config
@@ -40,7 +40,7 @@ read_env_value() {
# write variable to config file
write_env_value() {
[[ -w ${EROOT}${LOCALE_ENVFILE%/*} ]] \
- || die -q "You need root privileges!"
+ || die -q "You need superuser privileges!"
store_config "${EROOT}${LOCALE_ENVFILE}" "LANG" "$1"
}
diff --git a/modules/modules.eselect b/modules/modules.eselect
index c3d9160..3c2d2a9 100644
--- a/modules/modules.eselect
+++ b/modules/modules.eselect
@@ -97,7 +97,7 @@ do_has() {
# describe_add() {
# echo "Install the given module file somewhere that eselect can find it."
# echo "By default, install to \$HOME/.eselect/modules/, unless running as "
-# echo "root. Then, install to ${ESELECT_DATA_PATH}/modules/."
+# echo "the superuser. Then, install to ${ESELECT_DATA_PATH}/modules/."
# }
# describe_add_parameters() {