aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-04-30 06:55:25 +0000
committerUlrich Müller <ulm@gentoo.org>2009-04-30 06:55:25 +0000
commitafbc140f908f28995ad80233a33d6262df0c73e8 (patch)
tree076210e686db483dadd8ad4466e784677be652b7
parentDon't call package-manager, caching is no longer necessary. (diff)
downloadeselect-afbc140f908f28995ad80233a33d6262df0c73e8.tar.gz
eselect-afbc140f908f28995ad80233a33d6262df0c73e8.tar.bz2
eselect-afbc140f908f28995ad80233a33d6262df0c73e8.zip
Remove mailer module since it's not functional, bug 220473.
svn path=/trunk/; revision=521
-rw-r--r--ChangeLog9
-rw-r--r--NEWS2
-rw-r--r--man/Makefile.am1
-rw-r--r--man/mailer.eselect.557
-rw-r--r--modules/Makefile.am1
-rw-r--r--modules/mailer.eselect132
6 files changed, 10 insertions, 192 deletions
diff --git a/ChangeLog b/ChangeLog
index c08ef33..2c43b3c 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,12 @@
+2009-04-30 Ulrich Mueller <ulm@gentoo.org>
+
+ * modules/mailer.eselect:
+ * man/mailer.eselect.5: The mailer module is no longer supported
+ by MTA packages and therefore not functional, see bug 220473.
+ Remove the module and its man page.
+ * modules/Makefile.am (safe_scripts):
+ * man/Makefile.am (man_MANS): Update Makefiles accordingly.
+
2009-04-28 Ulrich Mueller <ulm@gentoo.org>
* modules/mailer.eselect (do_list): Highlight selected target,
diff --git a/NEWS b/NEWS
index f2e88c7..1fa861b 100644
--- a/NEWS
+++ b/NEWS
@@ -6,7 +6,6 @@ trunk:
- Fixed bug #155814: Clear aliases and shell functions.
- Fixed bug #156866: Handle missing scripts in rc module.
- Fixed bug #180966: Make rc module work with OpenRC.
- - Fixed bug #220473: Highlight selected target in mailer module.
- Various improvements in opengl module.
New features:
@@ -15,6 +14,7 @@ trunk:
- Treat 'help' and 'version' options as if they were actions.
- Modules for the EDITOR, VISUAL, and PAGER environment variables.
- Module news-tng.eselect for reading Gentoo ('GLEP 42') news.
+ - Remove mailer module since it's not functional (bug #220473).
1.0.12:
Bug fixes:
diff --git a/man/Makefile.am b/man/Makefile.am
index d802ceb..64abee8 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -4,7 +4,6 @@ man_MANS = eselect.1 \
editor.eselect.5 \
env.eselect.5 \
kernel.eselect.5 \
- mailer.eselect.5 \
news-tng.eselect.5 \
pager.eselect.5 \
profile.eselect.5 \
diff --git a/man/mailer.eselect.5 b/man/mailer.eselect.5
deleted file mode 100644
index 27245ca..0000000
--- a/man/mailer.eselect.5
+++ /dev/null
@@ -1,57 +0,0 @@
-.\" Copyright 2005-2009 Gentoo Foundation
-.\" Distributed under the terms of the GNU General Public License v2
-.\" $Id$
-.\"
-.TH mailer.eselect 5 "April 2009" "Gentoo Linux" eselect
-.SH NAME
-mailer.eselect \- The mailer profile management module for Gentoo's eselect
-.SH SYNOPSIS
-.B eselect mailer
-.RB [ help | usage | version ]
-.br
-.B eselect mailer list
-.br
-.B eselect mailer set
-.I profile
-.br
-.B eselect mailer show
-.br
-.SH DESCRIPTION
-.B eselect
-is Gentoo's configuration and management tool. It features modules
-that care for the individual administrative tasks.
-.SH ACTION: LIST
-.B eselect mailer list
-.br
-Display an ordered list of the installed mailer profiles. Each line
-has a number, the profile's name and version number.
-
-# eselect mailer list
-.br
-Available mailer.conf profiles:
- [1] default
- [2] msmtp\-1.4.0
- [3] nbsmtp\-0.98
-.SH ACTION: SET
-.B eselect mailer set
-.I profile
-.br
-Set your system's currently active mailer to
-.IR profile .
-
-# eselect mailer set msmtp-1.4.0
-.SH ACTION: SHOW
-.B eselect mailer show
-.br
-Show your system's mailer profiles.
-
-# eselect mailer show
-.br
-Current mailer.conf profile:
- msmtp-1.4.0
-.SH AUTHOR
-Tom Martin <slarti@gentoo.org>
-.SH SEE ALSO
-.BR eselect (1)
-.SH REVISION
-$Id$
diff --git a/modules/Makefile.am b/modules/Makefile.am
index 9081058..b0427f8 100644
--- a/modules/Makefile.am
+++ b/modules/Makefile.am
@@ -6,7 +6,6 @@ safe_scripts = \
editor.eselect \
env.eselect \
kernel.eselect \
- mailer.eselect \
modules.eselect \
news-tng.eselect \
pager.eselect \
diff --git a/modules/mailer.eselect b/modules/mailer.eselect
deleted file mode 100644
index d460a45..0000000
--- a/modules/mailer.eselect
+++ /dev/null
@@ -1,132 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-DESCRIPTION="Manage the mailwrapper profiles in /etc/mail"
-MAINTAINER="slarti@gentoo.org"
-SVN_DATE='$Date$'
-VERSION=$(svn_date_to_version "${SVN_DATE}")
-
-# check we have /etc/mail
-check_dirs() {
- if [[ ! -d ${ROOT}/etc/mail ]] ; then
- die -q "/etc/mail does not exist, or is not a directory. Please fix."
- fi
-}
-
-# find a list of mailer.conf symlink targets
-find_targets() {
- check_dirs
- for f in ${ROOT}/etc/mail/*.mailer ; do
- [[ -e ${f} ]] || continue
- echo ${f##*/}
- done
-}
-
-# try to remove the mailer.conf symlink
-remove_symlink() {
- check_dirs
- rm "${ROOT}/etc/mail/mailer.conf"
-}
-
-# set the mailer.conf symlink
-set_symlink() {
- check_dirs
- target=${1}
- if is_number "${target}" ; then
- targets=( $(find_targets ) )
- target=${targets[$(( ${target} - 1 ))]%.mailer}
- fi
- if [[ -z ${target} ]] ; then
- die -q "Target \"${1}\" doesn't appear to be valid!"
- elif [[ -f "${ROOT}/etc/mail/${target}.mailer" ]] ; then
- pushd "${ROOT}/etc/mail" 1>/dev/null
- ln -s "${target}.mailer" "mailer.conf"
- popd 1>/dev/null
- else
- die -q "Target \"${1}\" doesn't appear to be valid!"
- fi
-}
-
-### show action ###
-
-describe_show() {
- echo "Show the current mailer.conf profile"
-}
-
-do_show() {
- check_dirs
- write_list_start "Current mailer.conf profile:"
- if [[ -L "${ROOT}/etc/mail/mailer.conf" ]] ; then
- profile="$(canonicalise ${ROOT}/etc/mail/mailer.conf )"
- write_kv_list_entry "${profile%.mailer}" ""
- elif [[ -e "${ROOT}/etc/mail/mailer.conf" ]] ; then
- write_kv_list_entry "(not a symlink)" ""
- else
- write_kv_list_entry "(unset)" ""
- fi
-}
-
-### list action ###
-
-describe_list() {
- echo "List available mailer.conf profiles"
-}
-
-do_list() {
- check_dirs
- targets=( $(find_targets ) )
- targets=( ${targets[@]%.mailer} )
- write_list_start "Available mailer.conf profiles:"
- if [[ -n ${targets[@]} ]] ; then
- local i
- for (( i = 0 ; i < ${#targets[@]} ; i = i + 1 )) ; do
- # any more elegant way to do this?
- local profile
- profile=$(basename \
- "$(canonicalise "${ROOT}/etc/mail/mailer.conf")")
- [[ ${targets[i]} = ${profile%.mailer} ]] \
- && targets[i]="${targets[i]} $(highlight '*')"
- done
- write_numbered_list "${targets[@]}"
- else
- write_kv_list_entry "(none found)" ""
- fi
-}
-
-### set action ###
-
-describe_set() {
- echo "Set a new mailer.conf profile"
-}
-
-describe_set_parameters() {
- echo "<target>"
-}
-
-describe_set_options() {
- echo "target : Target name or number (from 'list' action)"
-}
-
-do_set() {
- check_dirs
- if [[ -z ${1} ]] ; then
- die -q "You didn't tell me what to set the profile to"
-
- elif [[ -L "${ROOT}/etc/mail/mailer.conf" ]] ; then
- if ! remove_symlink ; then
- die -q "Couldn't remove existing mailer.conf"
- elif ! set_symlink "${1}" ; then
- die -q "Couldn't set a new profile"
- fi
-
- elif [[ -e "${ROOT}/etc/mail/mailer.conf" ]] ; then
- # we have something strange
- die -q "Sorry, ${ROOT}/etc/mail/mailer.conf confuses me"
-
- else
- set_symlink "${1}" || die -q "Couldn't set a new symlink"
- fi
-}
-
-# vim: set ft=eselect :