aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2016-10-09 16:17:50 +0200
committerAnthony G. Basile <blueness@gentoo.org>2017-01-01 18:19:58 -0500
commit18565392cfecb5be6f3261ae0f82827c9ecfa08b (patch)
tree0fc55a5d774e4fc1bd376bc84330ff6a42f5ab48 /Makefile.am
parentMerge pull request #139 from barbieri/eudev-old-kernels (diff)
downloadeudev-18565392cfecb5be6f3261ae0f82827c9ecfa08b.tar.gz
eudev-18565392cfecb5be6f3261ae0f82827c9ecfa08b.tar.bz2
eudev-18565392cfecb5be6f3261ae0f82827c9ecfa08b.zip
configure.ac: add option to disable building programs
In some cases (e.g. trimmed-down chroot or containers), libudev is the only thing needed, with udevd and assorted programs totally useless (e.g. because /dev is bind-mounted from the real one and managed out-side the chroot/container). Add an option to ./configure to enable/disable building the programs; this option defaults to "enable", so that it is backward compatible with existing build procedure, and because it by default makes sense to have udevd et al. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c6429df6..0d463798e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,9 +1,13 @@
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
SUBDIRS = \
- src \
+ src
+
+if ENABLE_PROGRAMS
+SUBDIRS += \
rules \
test
+endif
if ENABLE_MANPAGES
SUBDIRS += \