aboutsummaryrefslogtreecommitdiff
path: root/src
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2020-01-06 11:14:47 -0500
committerAnthony G. Basile <blueness@gentoo.org>2020-01-06 11:14:47 -0500
commit799591c57368bbe47667f5b696050247a766b117 (patch)
tree47cc28625b48c545ca37653dbb9a721dc3088dc2 /src
parentconfigure.ac: bump to version 3.2.9, version 243 (diff)
downloadeudev-799591c57368bbe47667f5b696050247a766b117.tar.gz
eudev-799591c57368bbe47667f5b696050247a766b117.tar.bz2
eudev-799591c57368bbe47667f5b696050247a766b117.zip
src/libudev/libudev-monitor.c: do not check if /dev is tmpfs
This check fails for buildroot systems where /dev is not mounted as a tmpfs filesystem. Dropping this check should be safe even on regular systems. This solves issue #172. Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'src')
-rw-r--r--src/libudev/libudev-monitor.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/libudev/libudev-monitor.c b/src/libudev/libudev-monitor.c
index 614149c62..060ba733f 100644
--- a/src/libudev/libudev-monitor.c
+++ b/src/libudev/libudev-monitor.c
@@ -186,7 +186,7 @@ struct udev_monitor *udev_monitor_new_from_netlink_fd(struct udev *udev, const c
* We do not set a netlink multicast group here, so the socket
* will not receive any messages.
*/
- if (access(UDEV_ROOT_RUN "/udev/control", F_OK) < 0 || !udev_has_devtmpfs(udev)) {
+ if (access(UDEV_ROOT_RUN "/udev/control", F_OK) < 0) {
log_debug("the udev service seems not to be active, disable the monitor");
group = UDEV_MONITOR_NONE;
} else