summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 00:32:55 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-02-29 00:37:23 +0300
commite1d897375270d1e81eca41fe7d1ea4be08772fa0 (patch)
tree5a8b9f44c008ac1cb6cccf3fb21abd45e0e8d5b8 /games-arcade
parentgames-arcade/metalslug3: update to EAPI7 (diff)
downloadgamerlay-e1d897375270d1e81eca41fe7d1ea4be08772fa0.tar.gz
gamerlay-e1d897375270d1e81eca41fe7d1ea4be08772fa0.tar.bz2
gamerlay-e1d897375270d1e81eca41fe7d1ea4be08772fa0.zip
games-arcade/supermeatboy: update to EAPI 7
Remove deprecated eclass, install into /opt/${PN} Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/supermeatboy/supermeatboy-2013.11.11-r1.ebuild (renamed from games-arcade/supermeatboy/supermeatboy-2013.11.11.ebuild)17
1 files changed, 8 insertions, 9 deletions
diff --git a/games-arcade/supermeatboy/supermeatboy-2013.11.11.ebuild b/games-arcade/supermeatboy/supermeatboy-2013.11.11-r1.ebuild
index 2614020..bb5fa90 100644
--- a/games-arcade/supermeatboy/supermeatboy-2013.11.11.ebuild
+++ b/games-arcade/supermeatboy/supermeatboy-2013.11.11-r1.ebuild
@@ -1,16 +1,15 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit desktop eutils versionator
+inherit desktop eutils
MY_PN=SuperMeatBoy
-MY_PV=$(version_format_string '${2}${3}${1}')
DESCRIPTION="A platformer where you play as an animated cube of meat"
HOMEPAGE="http://www.supermeatboy.com/"
-SRC_URI="${PN}-linux-${MY_PV}-bin"
+SRC_URI="${PN}-linux-$(ver_cut 2)$(ver_cut 3)$(ver_cut 1)-bin"
LICENSE="all-rights-reserved"
SLOT="0"
@@ -26,7 +25,6 @@ RDEPEND="
"
S="${WORKDIR}/data"
-GAMEDIR="/usr/share/${P}"
pkg_nofetch() {
einfo "Please download ${A}"
@@ -45,19 +43,20 @@ src_unpack() {
}
src_install() {
- insinto "${GAMEDIR}"
+ local dest="/opt/${PN}"
+ insinto ${dest}
doins -r resources Levels buttonmap.cfg \
gameaudio.dat gamedata.dat locdb.txt \
steam_appid.txt
- insinto "${GAMEDIR}/${ARCH}"
+ insinto "${dest}/${ARCH}"
doins "${ARCH}"/libsteam_api.so
doins "${ARCH}"/libmariadb.so.1
- exeinto "${GAMEDIR}/${ARCH}"
+ exeinto "${dest}/${ARCH}"
doexe "${ARCH}/${MY_PN}"
- make_wrapper "${PN}" "./${ARCH}/${MY_PN}" "${GAMEDIR}" "./${ARCH}"
+ make_wrapper "${PN}" "./${ARCH}/${MY_PN}" "${dest}" "./${ARCH}"
doicon "${PN}".png
make_desktop_entry "${PN}" "${MY_PN}" "${PN}"