summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2012-08-01 23:19:31 +0600
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2012-08-01 23:19:31 +0600
commit0ad4fbbb4468a2d4e609cef3faf42210c4164ac5 (patch)
tree945e0bec87747d967f0b81a84274c6c635b2fc1e /media-libs
parent[games-rpg/lonesurvivor] Change from DESTDIR to DISTDIR (diff)
downloadgamerlay-0ad4fbbb4468a2d4e609cef3faf42210c4164ac5.tar.gz
gamerlay-0ad4fbbb4468a2d4e609cef3faf42210c4164ac5.tar.bz2
gamerlay-0ad4fbbb4468a2d4e609cef3faf42210c4164ac5.zip
[media-libs/libsfml] Stable version for mars-game
(Portage version: 2.1.10.62/git/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsfml/Manifest4
-rw-r--r--media-libs/libsfml/libsfml-2.0_rc20120731.ebuild32
-rw-r--r--media-libs/libsfml/libsfml-9999.ebuild4
3 files changed, 36 insertions, 4 deletions
diff --git a/media-libs/libsfml/Manifest b/media-libs/libsfml/Manifest
index 79e7d94..288742c 100644
--- a/media-libs/libsfml/Manifest
+++ b/media-libs/libsfml/Manifest
@@ -1,2 +1,4 @@
-EBUILD libsfml-9999.ebuild 771 RMD160 76e3c16323dc267e78f8fd590da27bb1ec74f578 SHA1 0b03c4af2683e2e26765fded0c63cc0c9cd47ee9 SHA256 30471348761c4d1553fcc65275ff8217b17e368144f9131cdb645c1aa53d4a7a
+DIST SFML-2.0-rc20120731.zip 8766709 RMD160 25fb13c2987754d99d08ea11a3df6e97f0baf5f4 SHA1 9556e1df59854e2b92b29f6263a0e848d8c36cb1 SHA256 196ecde080e16dd4285949a768dc6c89faeb871654344ca2218c8e6a91c2c697
+EBUILD libsfml-2.0_rc20120731.ebuild 717 RMD160 9f761f6d3ebad8c04f19e58af73e455246e0a340 SHA1 e2b0504be728896627e8f48c51bebd79123a433b SHA256 1c1b4404d1c53bb0d3dc73684ae05748cc7f8facfcd6eb8b60381280f21b5fe4
+EBUILD libsfml-9999.ebuild 769 RMD160 ea9525db661ada6ddb96b6789cd1a68a7dcce7d6 SHA1 5ede913c1d4c340f9014ab8a6603f1f4ddd51729 SHA256 d03d808998e3389f7e12a052c3d6f9b07ecb1732e3570719957711ef6bb75dfa
MISC metadata.xml 700 RMD160 8aba321ecc1f0edde4b12049383a19d9cbb2c35f SHA1 11f9d85a9ea25c4b25e9ee8aaa002ae42f5ac734 SHA256 6d4fb245d294411ef4a81921c091b798d6855859dad605b3c5154ebde04180a4
diff --git a/media-libs/libsfml/libsfml-2.0_rc20120731.ebuild b/media-libs/libsfml/libsfml-2.0_rc20120731.ebuild
new file mode 100644
index 0000000..5815215
--- /dev/null
+++ b/media-libs/libsfml/libsfml-2.0_rc20120731.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit cmake-utils
+
+MY_PV="${PV/_/-}"
+DESCRIPTION="Simple and Fast Multimedia Library (SFML)"
+HOMEPAGE="http://www.sfml-dev.org/"
+SRC_URI="https://github.com/LaurentGomila/SFML/zipball/db1f1b8fa1006ea440b9cbe4a2d61b632109ebb2 -> SFML-${MY_PV}.zip"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="media-libs/freetype:2
+ media-libs/glew
+ >=media-libs/libpng-1.4
+ media-libs/libsndfile
+ media-libs/mesa
+ media-libs/openal
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/libX11
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/LaurentGomila-SFML-db1f1b8
diff --git a/media-libs/libsfml/libsfml-9999.ebuild b/media-libs/libsfml/libsfml-9999.ebuild
index bf6b71d..6e22276 100644
--- a/media-libs/libsfml/libsfml-9999.ebuild
+++ b/media-libs/libsfml/libsfml-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/media-libs/libsfml/libsfml-9999.ebuild,v 1.2 2011/09/09 07:52:53 frostwork Exp $
@@ -28,5 +28,3 @@ DEPEND="media-libs/freetype:2
x11-libs/libX11
x11-libs/libXrandr"
RDEPEND="${DEPEND}"
-
-