aboutsummaryrefslogtreecommitdiff
path: root/4.3.2
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2008-12-31 21:50:38 +0000
committerNed Ludd <solar@gentoo.org>2008-12-31 21:50:38 +0000
commit0c032b57faafb7999e09c5e2ac5b09851eaf1a1a (patch)
treefba0c2ceb4edc392884abcfa9f4f03fead2ef517 /4.3.2
parent- update the spec files (diff)
downloadgcc-patches-0c032b57faafb7999e09c5e2ac5b09851eaf1a1a.tar.gz
gcc-patches-0c032b57faafb7999e09c5e2ac5b09851eaf1a1a.tar.bz2
gcc-patches-0c032b57faafb7999e09c5e2ac5b09851eaf1a1a.zip
remove references to fortify and relro. relro should be default in our binutils for over a year now
Diffstat (limited to '4.3.2')
-rw-r--r--4.3.2/pie/20_all_gcc-4.4-gentoo-hardened-setup.patch31
1 files changed, 11 insertions, 20 deletions
diff --git a/4.3.2/pie/20_all_gcc-4.4-gentoo-hardened-setup.patch b/4.3.2/pie/20_all_gcc-4.4-gentoo-hardened-setup.patch
index 5a1abde..7c94a47 100644
--- a/4.3.2/pie/20_all_gcc-4.4-gentoo-hardened-setup.patch
+++ b/4.3.2/pie/20_all_gcc-4.4-gentoo-hardened-setup.patch
@@ -32,19 +32,19 @@
+#ifndef CC1_SSP_ALL_SPEC
+#define CC1_SSP_ALL_SPEC ""
+#endif
-+#ifndef CC1_FORTIFY_SPEC
-+#define CC1_FORTIFY_SPEC ""
-+#endif
+#ifndef CC1_STRICT_SPEC
+#define CC1_STRICT_SPEC ""
+#endif
-+#ifndef LINK_RELRO_SPEC
-+#define LINK_RELRO_SPEC ""
-+#endif
+#ifndef LINK_NOW_SPEC
+#define LINK_NOW_SPEC ""
+#endif
+
++
++
++
++
++
++
/* -u* was put back because both BSD and SysV seem to support it. */
/* %{static:} simply prevents an error message if the target machine
doesn't handle -static. */
@@ -53,7 +53,7 @@
#define LINK_COMMAND_SPEC "\
%{!fsyntax-only:%{!c:%{!M:%{!MM:%{!E:%{!S:\
- %(linker) %l " LINK_PIE_SPEC "%X %{o*} %{A} %{d} %{e*} %{m} %{N} %{n} %{r}\
-+ %(linker) %l %(link_pie) %(link_relro) %(link_now) %X %{o*} %{A} %{d} %{e*} %{m} %{N} %{n} %{r}\
++ %(linker) %l %(link_pie) %(link_now) %X %{o*} %{A} %{d} %{e*} %{m} %{N} %{n} %{r}\
%{s} %{t} %{u*} %{x} %{z} %{Z} %{!A:%{!nostdlib:%{!nostartfiles:%S}}}\
%{static:} %{L*} %(mfwrap) %(link_libgcc) %o\
%{fopenmp|ftree-parallelize-loops=*:%:include(libgomp.spec)%(link_gomp)} %(mflib)\
@@ -73,23 +73,14 @@
+static const char *cc1_ssp_spec = CC1_SSP_SPEC;
+static const char *cc1_ssp_all_spec = CC1_SSP_ALL_SPEC;
+static const char *cc1_pie_spec = CC1_PIE_SPEC;
-+static const char *cc1_fortify_spec = CC1_FORTIFY_SPEC;
+static const char *cc1_strict_spec = CC1_STRICT_SPEC;
-+static const char *link_relro_spec = LINK_RELRO_SPEC;
+static const char *link_now_spec = LINK_NOW_SPEC;
+static const char *link_pie_spec = LINK_PIE_SPEC;
++
++
/* Standard options to cpp, cc1, and as, to reduce duplication in specs.
There should be no need to override these in target dependent files,
-@@ -828,7 +860,7 @@
- %{H} %C %{D*&U*&A*} %{i*} %Z %i\
- %{fmudflap:-D_MUDFLAP -include mf-runtime.h}\
- %{fmudflapth:-D_MUDFLAP -D_MUDFLAPTH -include mf-runtime.h}\
-- %{E|M|MM:%W{o*}}";
-+ %{E|M|MM:%W{o*}} %(cc1_fortify)";
-
- /* This contains cpp options which are common with cc1_options and are passed
- only when preprocessing only to avoid duplication. We pass the cc1 spec
@@ -1643,6 +1675,14 @@
INIT_STATIC_SPEC ("startfile_pie_t_gen", &startfile_pie_t_gen_spec),
INIT_STATIC_SPEC ("startfile_pie_gen", &startfile_pie_gen_spec),
@@ -97,9 +88,9 @@
+ INIT_STATIC_SPEC ("cc1_ssp", &cc1_ssp_spec),
+ INIT_STATIC_SPEC ("cc1_ssp_all", &cc1_ssp_all_spec),
+ INIT_STATIC_SPEC ("cc1_pie", &cc1_pie_spec),
-+ INIT_STATIC_SPEC ("cc1_fortify", &cc1_fortify_spec),
++ /* INIT_STATIC_SPEC ("cc1_fortify", &cc1_fortify_spec), */
+ INIT_STATIC_SPEC ("cc1_strict", &cc1_strict_spec),
-+ INIT_STATIC_SPEC ("link_relro", &link_relro_spec),
++ /* INIT_STATIC_SPEC ("link_relro", &link_relro_spec), */
+ INIT_STATIC_SPEC ("link_now", &link_now_spec),
+ INIT_STATIC_SPEC ("link_pie", &link_pie_spec),
};