aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2013-07-01 05:55:05 +0000
committerRyan Hill <rhill@gentoo.org>2013-07-01 05:55:05 +0000
commit46cbd82e3196041d96c8a4f9c0ea17b91796b94a (patch)
tree53cedfa442297af0542394194dab0159dae14697 /4.8.1/gentoo/17_all_libitm-Werror.patch
parentInitial 4.8.1 patchset based of latest 4.8.0 patchset. (diff)
downloadgcc-patches-46cbd82e3196041d96c8a4f9c0ea17b91796b94a.tar.gz
gcc-patches-46cbd82e3196041d96c8a4f9c0ea17b91796b94a.tar.bz2
gcc-patches-46cbd82e3196041d96c8a4f9c0ea17b91796b94a.zip
Add --enable-werror for bug #475350.
Diffstat (limited to '4.8.1/gentoo/17_all_libitm-Werror.patch')
-rw-r--r--4.8.1/gentoo/17_all_libitm-Werror.patch70
1 files changed, 70 insertions, 0 deletions
diff --git a/4.8.1/gentoo/17_all_libitm-Werror.patch b/4.8.1/gentoo/17_all_libitm-Werror.patch
new file mode 100644
index 0000000..1bcf62e
--- /dev/null
+++ b/4.8.1/gentoo/17_all_libitm-Werror.patch
@@ -0,0 +1,70 @@
+Add --enable-werror.
+
+https://bugs.gentoo.org/475350
+
+
+2013-06-30 Ryan Hill <dirtyepic@gentoo.org>
+
+ * configure.ac: Add --enable-werror.
+ (XCFLAGS): Use it.
+ * configure: Regenerate.
+
+--- a/libitm/configure
++++ b/libitm/configure
+@@ -775,6 +775,7 @@ enable_maintainer_mode
+ enable_linux_futex
+ enable_tls
+ enable_symvers
++enable_werror
+ '
+ ac_precious_vars='build_alias
+ host_alias
+@@ -1423,6 +1424,7 @@ Optional Features:
+ --enable-tls Use thread-local storage [default=yes]
+ --enable-symvers=STYLE enables symbol versioning of the shared library
+ [default=yes]
++ --enable-werror turns on -Werror [default=yes]
+
+ Optional Packages:
+ --with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
+@@ -17491,9 +17493,18 @@ $as_echo "$as_me: not updating unwritable cache $cache_file" >&6;}
+ fi
+ rm -f confcache
+
+-# Add -Wall -Werror if we are using GCC.
++# Check whether --enable-werror was given.
++if test "${enable_werror+set}" = set; then :
++ enableval=$enable_werror;
++fi
++
++# Add -Wall if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
++ # Add -Werror if requested.
++ if test "x$enable_werror" != "xno"; then
++ XCFLAGS="$XCFLAGS -Werror"
++ fi
+ fi
+
+ XCFLAGS="$XCFLAGS $XPCFLAGS"
+--- a/libitm/configure.ac
++++ b/libitm/configure.ac
+@@ -252,9 +252,15 @@ GCC_CHECK_ELF_STYLE_WEAKREF
+ CFLAGS="$save_CFLAGS"
+ AC_CACHE_SAVE
+
+-# Add -Wall -Werror if we are using GCC.
++AC_ARG_ENABLE(werror, [AS_HELP_STRING([--enable-werror],
++ [turns on -Werror @<:@default=yes@:>@])])
++# Add -Wall if we are using GCC.
+ if test "x$GCC" = "xyes"; then
+- XCFLAGS="$XCFLAGS -Wall -Werror"
++ XCFLAGS="$XCFLAGS -Wall"
++ # Add -Werror if requested.
++ if test "x$enable_werror" != "xno"; then
++ XCFLAGS="$XCFLAGS -Werror"
++ fi
+ fi
+
+ XCFLAGS="$XCFLAGS $XPCFLAGS"