summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2021-06-10 11:21:23 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2021-06-10 11:21:23 -0400
commitdc3d3be665b51fc15065f6b7f1df3c92189ade85 (patch)
tree3c2a60c399ddd01877ab28b949bb8c8a865f8b05 /app-editors/pluma/pluma-1.24.2.ebuild
parentx11-misc/mozo: Bump to 1.24.1 (diff)
downloadgentoo-mate-dc3d3be665b51fc15065f6b7f1df3c92189ade85.tar.gz
gentoo-mate-dc3d3be665b51fc15065f6b7f1df3c92189ade85.tar.bz2
gentoo-mate-dc3d3be665b51fc15065f6b7f1df3c92189ade85.zip
app-editors/pluma: Bump to 1.24.2
Bug: https://bugs.gentoo.org/778857 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'app-editors/pluma/pluma-1.24.2.ebuild')
-rw-r--r--app-editors/pluma/pluma-1.24.2.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/app-editors/pluma/pluma-1.24.2.ebuild b/app-editors/pluma/pluma-1.24.2.ebuild
new file mode 100644
index 0000000..0614361
--- /dev/null
+++ b/app-editors/pluma/pluma-1.24.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit mate python-single-r1 virtualx
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Pluma text editor for the MATE desktop"
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="+introspection spell test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Tests require gvfs sftp fs mounted and schema's installed. Disable tests.
+# https://github.com/mate-desktop/mate-text-editor/issues/33
+RESTRICT="test"
+
+COMMON_DEPEND="dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libpeas-1.2.0[gtk]
+ >=dev-libs/libxml2-2.5:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/gtksourceview-3.0.0:3.0
+ x11-libs/libICE
+ x11-libs/libX11
+ >=x11-libs/libSM-1.0
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+ spell? (
+ >=app-text/enchant-1.6:=
+ >=app-text/iso-codes-0.35
+ )
+ !!app-editors/mate-text-editor
+"
+
+RDEPEND="${PYTHON_DEPS}
+ ${COMMON_DEPEND}
+ >=mate-base/mate-desktop-1.9[introspection?]
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ ~app-text/docbook-xml-dtd-4.1.2
+ app-text/rarian
+ >=app-text/scrollkeeper-dtd-1:1.0
+ app-text/yelp-tools
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/libtool-2.2.6:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable introspection) \
+ $(use_enable spell) \
+ $(use_enable test tests)
+}
+
+src_test() {
+ # FIXME: This should be handled at eclass level.
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}