aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2014-01-19 23:39:41 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2014-01-19 23:39:41 +0100
commit2fa30f99c9476940431563b8f2efced907d7e092 (patch)
treed8e5aca296c24224a0752687ff2134d4ce8791f8
parentadded systemd service file, systemd helper script; wrt bug 353492 (diff)
downloadgentoo-vdr-scripts-2fa30f99c9476940431563b8f2efced907d7e092.tar.gz
gentoo-vdr-scripts-2fa30f99c9476940431563b8f2efced907d7e092.tar.bz2
gentoo-vdr-scripts-2fa30f99c9476940431563b8f2efced907d7e092.zip
added Makefiles for systemd relevanted files; systemd handling in main Makefile added
-rw-r--r--ChangeLog8
-rw-r--r--Makefile9
-rw-r--r--README2
-rw-r--r--README.grub21
-rw-r--r--README.shutdown-jobs2
-rw-r--r--README.systemd3
-rw-r--r--README.vdrcaps2
-rw-r--r--TODO2
-rw-r--r--etc/systemd/system/vdr.service.d/00-gentoo-vdr-user.conf8
-rw-r--r--etc/systemd/system/vdr.service.d/Makefile16
-rw-r--r--usr/lib/systemd/system/Makefile16
-rw-r--r--var/vdr/tmp/Makefile16
-rw-r--r--var/vdr/tmp/systemd_env0
13 files changed, 80 insertions, 5 deletions
diff --git a/ChangeLog b/ChangeLog
index aa2edd7..a016398 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gentoo-vdr-scripts
# $Id$
+ 19 Jan 2014; Joerg Bornkessel <hd_brummy@gentoo.org> +README.systemd,
+ +etc/systemd/system/vdr.service.d/00-gentoo-vdr-user.conf,
+ +etc/systemd/system/vdr.service.d/Makefile, +usr/lib/systemd/system/Makefile,
+ +var/vdr/tmp/Makefile, +var/vdr/tmp/systemd_env, Makefile, README,
+ README.grub2, README.shutdown-jobs, README.vdrcaps, TODO:
+ added Makefiles for systemd relevanted files; systemd handling in main
+ Makefile added
+
19 Jan 2014; Joerg Bornkessel <hd_brummy@gentoo.org>
+usr/lib/systemd/system/vdr.service,
+usr/share/vdr/bin/vdr-systemd_helper.sh:
diff --git a/Makefile b/Makefile
index 25021b8..32b01c5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,9 +1,16 @@
-# $Id$
+# $Id: $
SHELL = /bin/bash
+# systemd support
+VDRSYSTEMD ?= 1
+
SUBDIRS = etc usr vdrplugin-rebuild
+ifeq ($(VDRSYSTEMD),1)
+SUBDIRS += etc/systemd/system/vdr.services.d usr/lib/systemd/system var/vdr/tmp
+endif
+
all:
VERSION := $(shell grep '^Version' README | awk '{ print $$2 }')
diff --git a/README b/README
index e6cfed4..515a89d 100644
--- a/README
+++ b/README
@@ -1,5 +1,5 @@
+# $Id: $
README for gentoo-vdr-scripts
-$Id$
Version 2.0.0
diff --git a/README.grub2 b/README.grub2
index fc5dce7..57e2713 100644
--- a/README.grub2
+++ b/README.grub2
@@ -1,3 +1,4 @@
+# $Id: $
# gentoo-vdr-scripts grub2 syntax
# example grub2 entry for reboot and default boot kernel
diff --git a/README.shutdown-jobs b/README.shutdown-jobs
index ef5e08c..d34f836 100644
--- a/README.shutdown-jobs
+++ b/README.shutdown-jobs
@@ -1,4 +1,4 @@
-$Id$
+# $Id: $
Short description of concept of shutdown-thread
This is implemented, at least from side of the scripts.
diff --git a/README.systemd b/README.systemd
new file mode 100644
index 0000000..a96ef2c
--- /dev/null
+++ b/README.systemd
@@ -0,0 +1,3 @@
+# $Id: $
+
+ToDo
diff --git a/README.vdrcaps b/README.vdrcaps
index 32e2e2e..4364678 100644
--- a/README.vdrcaps
+++ b/README.vdrcaps
@@ -1,4 +1,4 @@
-# $Id$
+# $Id: $
subset of all possible settings in /usr/share/vdr/capabilities.sh
CAP_SHUTDOWN_SVDRP - vdr has svdrp command DOWN to trigger a suto-hutdown after inactivity
diff --git a/TODO b/TODO
index b9d7608..f47dfe0 100644
--- a/TODO
+++ b/TODO
@@ -1,5 +1,5 @@
+# $Id: $
TODO file for gentoo-vdr-scripts
-$Id$
* improve syslog parsing code
diff --git a/etc/systemd/system/vdr.service.d/00-gentoo-vdr-user.conf b/etc/systemd/system/vdr.service.d/00-gentoo-vdr-user.conf
new file mode 100644
index 0000000..8f57598
--- /dev/null
+++ b/etc/systemd/system/vdr.service.d/00-gentoo-vdr-user.conf
@@ -0,0 +1,8 @@
+#
+# /etc/systemd/system/vdr.service.d/00-gentoo-vdr-user.conf
+#
+# use this file to override settings from vdr.service
+
+[Service]
+# uncomment this if you have to set START_VDR_AS_ROOT="yes" in /etc/conf.d/vdr
+#User=root
diff --git a/etc/systemd/system/vdr.service.d/Makefile b/etc/systemd/system/vdr.service.d/Makefile
new file mode 100644
index 0000000..9bb7610
--- /dev/null
+++ b/etc/systemd/system/vdr.service.d/Makefile
@@ -0,0 +1,16 @@
+# $Id: $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/etc/systemd/system/vdr.service.d
+SUBDIRS =
+BINS =
+CONFS = 00-gentoo-vdr-user.conf
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ @install -m 0644 -o root -g root $(CONFS) $(MYDIR)
+
+.PHONY: all install
diff --git a/usr/lib/systemd/system/Makefile b/usr/lib/systemd/system/Makefile
new file mode 100644
index 0000000..6185517
--- /dev/null
+++ b/usr/lib/systemd/system/Makefile
@@ -0,0 +1,16 @@
+# $ID: $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/usr/lib/systemd/system
+SUBDIRS =
+BINS =
+CONFS = vdr.service
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ @install -m 0644 -o root -g root $(CONDS) $(MYDIR)
+
+.PHONY: all install
diff --git a/var/vdr/tmp/Makefile b/var/vdr/tmp/Makefile
new file mode 100644
index 0000000..3009af8
--- /dev/null
+++ b/var/vdr/tmp/Makefile
@@ -0,0 +1,16 @@
+#$Id: $
+
+SHELL = /bin/bash
+
+MYDIR = $(DESTDIR)/var/vdr/tmp
+SUBDIRS =
+BINS =
+CONFS = systemd_env
+
+all:
+
+install:
+ @install -m 0755 -o root -g root -d $(MYDIR)
+ @install -m 0644 -o vdr -g vdr $(CONFS) $(MYDIR)
+
+.PHONY: all install
diff --git a/var/vdr/tmp/systemd_env b/var/vdr/tmp/systemd_env
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/var/vdr/tmp/systemd_env