aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index c3e83c5..b7b07c1 100644
--- a/meson.build
+++ b/meson.build
@@ -39,8 +39,10 @@ endif
subdir('bin')
subdir('pym')
-pytest = find_program('pytest')
-test('pytest', pytest, args : ['-v', meson.current_source_dir() / 'pym'])
+if get_option('tests')
+ pytest = find_program('pytest')
+ test('pytest', pytest, args : ['-v', meson.current_source_dir() / 'pym'])
+endif
if get_option('code-only')
subdir_done()