summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2007-05-12 10:13:17 +0000
committerFabian Groffen <grobian@gentoo.org>2007-05-12 10:13:17 +0000
commitf268d36bd1cacd0ec49af91df4705a0199820b94 (patch)
tree9627401948a71a474ac86a9e5845740da8077290 /gnustep-libs
downloadprefix-f268d36bd1cacd0ec49af91df4705a0199820b94.tar.gz
prefix-f268d36bd1cacd0ec49af91df4705a0199820b94.tar.bz2
prefix-f268d36bd1cacd0ec49af91df4705a0199820b94.zip
Add prefix-overlay. This should not be used by mortal souls, and is
here solely to allow me to contribute a little bit to the great GNUstep revival. svn path=/prefix-overlay/; revision=11
Diffstat (limited to 'gnustep-libs')
-rw-r--r--gnustep-libs/camaelon/Manifest5
-rw-r--r--gnustep-libs/camaelon/camaelon-2.0_pre20070504.ebuild31
-rw-r--r--gnustep-libs/camaelon/files/config-camaelon.sh5
3 files changed, 41 insertions, 0 deletions
diff --git a/gnustep-libs/camaelon/Manifest b/gnustep-libs/camaelon/Manifest
new file mode 100644
index 0000000..851792e
--- /dev/null
+++ b/gnustep-libs/camaelon/Manifest
@@ -0,0 +1,5 @@
+AUX config-camaelon.sh 362 RMD160 93062a340061723da0a0d34425afe3e584eac112 SHA1 b5f4b92e4bb8eb66f53e47bdd547073724657941 SHA256 3134fb9e2546e3c38f4f0a872556810519c1d3e2dcb798bd957522c54107e422
+DIST IndustrialTheme.tar.bz2 49338 RMD160 794adb1bd117e038a1211c33bb9740cd1ca9be9c SHA1 b61abb20b5cfdd56851c8f102d5f0779c7f29110 SHA256 29f9c2d0599a7ca84682e406eca2a546479c8cad386f19969ba437731e2b1379
+DIST MaxCurve-0.2.tar.bz2 48965 RMD160 29b910b8d1696633727f33bd1a8de11b21b56365 SHA1 5afaa87019821949b1df0ac1e21f79a645bbce8e SHA256 808b872ba00c02616b6d9754acb1533cd9139da88c22954506d236517d0b7202
+DIST camaelon-2.0_pre20070504.tar.bz2 106158 RMD160 ec6efdfe22ffd68af56da636f80e17ffba21b1bf SHA1 69cc8285a9596a9007835a3d468d4d931f181b43 SHA256 f1ddd9a51978e9b106cb4b90d9fe6a992f4b61bfeb3eeb49defff7981d1f848b
+EBUILD camaelon-2.0_pre20070504.ebuild 1009 RMD160 7674e43dcfcd21937b321200fa30c5576827f9fb SHA1 c503a3c659c18927a74fba08bb3880b22ad1c25e SHA256 fd5017c83729e843a75a53479d9e0c323678d365c649e24c783eba957cc064c0
diff --git a/gnustep-libs/camaelon/camaelon-2.0_pre20070504.ebuild b/gnustep-libs/camaelon/camaelon-2.0_pre20070504.ebuild
new file mode 100644
index 0000000..737003f
--- /dev/null
+++ b/gnustep-libs/camaelon/camaelon-2.0_pre20070504.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/camaelon/camaelon-2.0_pre20060324.ebuild,v 1.1 2006/03/26 10:49:57 grobian Exp $
+
+inherit gnustep-2
+
+S=${WORKDIR}/${PN/c/C}
+
+DESCRIPTION="Camaelon allows you to load theme bundles for GNUstep."
+
+HOMEPAGE="http://www.etoile-project.org/etoile/mediawiki/index.php?title=Camaelon"
+SRC_URI="http://overlays.gentoo.org/svn/proj/gnustep/downloads/${P}.tar.bz2
+ http://brante.dyndns.org/gnustep/download/MaxCurve-0.2.tar.bz2
+ mirror://sourceforge/mpdcon/IndustrialTheme.tar.bz2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+IUSE=""
+DEPEND="${GS_DEPEND}"
+RDEPEND="${GS_RDEPEND}"
+
+egnustep_install_domain "System"
+
+src_install() {
+ gnustep-2_src_install || die "install failed"
+
+ # install themes
+ mkdir -p "${D}$(egnustep_system_root)/Library/Themes"
+ cp -R ${WORKDIR}/*theme ${S}/*theme "${D}$(egnustep_system_root)/Library/Themes/"
+}
diff --git a/gnustep-libs/camaelon/files/config-camaelon.sh b/gnustep-libs/camaelon/files/config-camaelon.sh
new file mode 100644
index 0000000..5520d1a
--- /dev/null
+++ b/gnustep-libs/camaelon/files/config-camaelon.sh
@@ -0,0 +1,5 @@
+echo "Applying Camaelon default theme..."
+echo "defaults write NSGlobalDomain GSAppKitUserBundles \"(${GNUSTEP_SYSTEM_ROOT}/Library/Bundles/Camaelon.themeEngine)\""
+defaults write NSGlobalDomain GSAppKitUserBundles "(${GNUSTEP_SYSTEM_ROOT}/Library/Bundles/Camaelon.themeEngine)"
+echo "defaults write Camaelon Theme Nesedah"
+defaults write Camaelon Theme Nesedah