aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-05-10 02:54:08 +0200
committerJauhien Piatlicki <jauhien@gentoo.org>2014-05-10 03:08:47 +0200
commit4d99d6df938a26c702df542eaa6c56c91dd1c3da (patch)
treed315f1d75cf0a567ad049ef6ef39cec25156145f
parentgs-elpa: exclude cl-lib from dependencies as it is a package needed for compa... (diff)
downloadgs-elpa-4d99d6df938a26c702df542eaa6c56c91dd1c3da.tar.gz
gs-elpa-4d99d6df938a26c702df542eaa6c56c91dd1c3da.tar.bz2
gs-elpa-4d99d6df938a26c702df542eaa6c56c91dd1c3da.zip
gs-elpa splitted to a different repository
-rw-r--r--README.md60
-rw-r--r--docs/Makefile11
-rw-r--r--docs/gs-elpa.86
-rw-r--r--docs/gs-elpa.8.rst6
-rw-r--r--gs-elpa-overlays.xml6
-rw-r--r--gs_elpa/data/gs-elpa.eclass6
-rw-r--r--gs_elpa/elpa_db.py4
-rw-r--r--setup.py23
8 files changed, 27 insertions, 95 deletions
diff --git a/README.md b/README.md
index 0e26fb6..7a03840 100644
--- a/README.md
+++ b/README.md
@@ -1,60 +1,10 @@
-Objective
-=========
-
-There is a lot of 3rd party software providers that resemble overlays
-or repositories of Linux distributions in some way. For example: pypi,
-CRAN, CPAN, CTAN, octave-forge, ELPA. It's clear that all this
-software available through different mechanisms (such as package.el
-for Emacs or pkg command in Octave) will never have separately
-maintained ebuilds in Gentoo tree or even in overlays. Installing such
-a software with its own distribution system does not seem like a good
-idea, especially if one needs to install it system-wide.
-
-There is a number of solutions for this problem in Gentoo. But here
-another problem lies: there are special dedicated “g-helpers” for a
-number of 3rd party software providers. But, as Rafael Martins states
-“each one tries to solve the very same problems on its own unique and
-"innovative" way”. While it would be really nice to have a solid base
-framework with realization of all the basic algorithms necessary for
-ebuild and overlay generation, with uniform UI and with good
-integration with system package manager.
-
-Deliverables
-
-At the end of the project there should be a framework and number of
-backends for some of the 3rd party software providers. This framework
-should make writing of those g-helpers easier and regular.
-
-At the moment I see this framework as a number of classes in Python
-that can be inherited and expanded in backends with the specific
-logic. All the logic related to the interaction with user, portage and
-overlay tools should be implemented in the framework and normally
-should not be changed by backends. Integration with system may need
-patching of some existing tools (like layman).
-
-Framework should have: - basic logic for ebuild and overlay
-manipulation, dependencies resolving, patching and so on - cli, that
-allows users to generate separate ebuilds and even overlays with
-available backends - integration with other system tools (I mean
-layman, as I'm not really familiar with tools used by other package
-manglers. But supporting them would be a good idea as well).
-
-Backend should have everything specific for a given 3rd party software
-provider: concrete algorithms for ebuild-generation, eclasses,
-databases with information about available software and so on.
+This is [g-sorcery](https://github.com/jauhien/g-sorcery) backend for elisp packages.
+
Installation and using
======================
-You should emerge **app-portage/layman-9999**.
-
-Add `jauhien` overlay: **layman -a jauhien**.
-
-Emerge g-sorcery: **emerge -va g-sorcery**.
-
-Currently 3 backends are available: **gs-elpa**, **gs-pypi** and **gs-ctan**.
-
-Here is an example of using gs-elpa backend.
+Installation: in progress (use dev-portage/g-sorcery-9999, at the moment it has bundled backends).
There are two ways of using **gs-elpa**:
@@ -127,6 +77,4 @@ Repositories you can use are gnu-elpa, marmalade and melpa. You can use them
all in one overlay. Note, that if you call **generate-tree** command your overlay
will be wiped and overlay tree for a given repository will be generated. Be careful!
-See man pages of **gs-elpa**, **gs-pypi** and **gs-ctan** for further information.
-
-If you want to develop a new backend see [developer's instructions](https://github.com/jauhien/g-sorcery/blob/master/docs/developer_instructions.rst).
+See man page of **gs-elpa** for further information.
diff --git a/docs/Makefile b/docs/Makefile
index cba7bc8..0ad1489 100644
--- a/docs/Makefile
+++ b/docs/Makefile
@@ -1,16 +1,9 @@
-HTML_SOURCES=developer_instructions
-HTML_DOCS=$(HTML_SOURCES:=.html)
-
-MAN_SOURCES=g-sorcery g-sorcery.cfg gs-elpa gs-pypi gs-ctan
+MAN_SOURCES=gs-elpa
MANS=$(MAN_SOURCES:=.8)
-RST2HTML=rst2html.py
RST2MAN=rst2man.py
-all: ${MANS} ${HTML_DOCS}
+all: ${MANS}
%.8: %.8.rst
$(RST2MAN) $< $@
-
-%.html: %.rst
- $(RST2HTML) $< $@
diff --git a/docs/gs-elpa.8 b/docs/gs-elpa.8
index cd71794..e00d7de 100644
--- a/docs/gs-elpa.8
+++ b/docs/gs-elpa.8
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH GS-ELPA 8 "2013-08-04" "0.1" "g-sorcery"
+.TH GS-ELPA 8 "2014-05-10" "0.1" "g-sorcery"
.SH NAME
gs-elpa \- manage overlays for ELPA repositories
.
@@ -156,10 +156,10 @@ gnu\-elpa repository: \fBlayman \-a gnu\-elpa\fP.
.sp
\fBgs\-pypi\fP(8), \fBgs\-ctan\fP(8), \fBg\-sorcery.cfg\fP(8), \fBportage\fP(5), \fBemerge\fP(1), \fBlayman\fP(8)
.SH AUTHOR
-Written by Jauhien Piatlicki <piatlicki@gmail.com>. GSoC idea
+Written by Jauhien Piatlicki <jauhien@gentoo.org>. GSoC idea
and mentorship by Rafael Martins. Lots of help and improvements
by Brian Dolbec.
.SH COPYRIGHT
-Copyright (c) 2013 Jauhien Piatlicki, License: GPL-2
+Copyright (c) 2013-2014 Jauhien Piatlicki, License: GPL-2
.\" Generated by docutils manpage writer.
.
diff --git a/docs/gs-elpa.8.rst b/docs/gs-elpa.8.rst
index 008c30e..8dc20d0 100644
--- a/docs/gs-elpa.8.rst
+++ b/docs/gs-elpa.8.rst
@@ -6,11 +6,11 @@ gs-elpa
manage overlays for ELPA repositories
-------------------------------------
-:Author: Written by Jauhien Piatlicki <piatlicki@gmail.com>. GSoC idea
+:Author: Written by Jauhien Piatlicki <jauhien@gentoo.org>. GSoC idea
and mentorship by Rafael Martins. Lots of help and improvements
by Brian Dolbec.
-:Date: 2013-08-04
-:Copyright: Copyright (c) 2013 Jauhien Piatlicki, License: GPL-2
+:Date: 2014-05-10
+:Copyright: Copyright (c) 2013-2014 Jauhien Piatlicki, License: GPL-2
:Version: 0.1
:Manual section: 8
:Manual group: g-sorcery
diff --git a/gs-elpa-overlays.xml b/gs-elpa-overlays.xml
index b3dd883..357a79d 100644
--- a/gs-elpa-overlays.xml
+++ b/gs-elpa-overlays.xml
@@ -6,7 +6,7 @@
<description>packages for emacs</description>
<homepage>http://elpa.gnu.org/</homepage>
<owner>
- <email>piatlicki@gmail.com</email>
+ <email>jauhien@gentoo.org</email>
<name>Jauhien Piatlicki</name>
</owner>
<source type="g-sorcery">gs-elpa gnu-elpa</source>
@@ -16,7 +16,7 @@
<description>packages for emacs</description>
<homepage>http://marmalade-repo.org/</homepage>
<owner>
- <email>piatlicki@gmail.com</email>
+ <email>jauhien@gentoo.org</email>
<name>Jauhien Piatlicki</name>
</owner>
<source type="g-sorcery">gs-elpa marmalade</source>
@@ -26,7 +26,7 @@
<description>packages for emacs</description>
<homepage>http://melpa.milkbox.net</homepage>
<owner>
- <email>piatlicki@gmail.com</email>
+ <email>jauhien@gentoo.org</email>
<name>Jauhien Piatlicki</name>
</owner>
<source type="g-sorcery">gs-elpa melpa</source>
diff --git a/gs_elpa/data/gs-elpa.eclass b/gs_elpa/data/gs-elpa.eclass
index c4c85c6..d887c27 100644
--- a/gs_elpa/data/gs-elpa.eclass
+++ b/gs_elpa/data/gs-elpa.eclass
@@ -1,14 +1,14 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
# automatically generated by gs-elpa
# please do not edit this file
#
-# Original Author: Jauhien Piatlicki <piatlicki@gmail.com>
+# Original Author: Jauhien Piatlicki <jauhien@gentoo.org>
# Purpose: support installation of elisp packages for emacs
# from overlays generated by gs-elpa
#
-# Bugs to piatlicki@gmail.com
+# Bugs to jauhien@gentoo.org
#
# @ECLASS: gs-elpa.eclass
#
diff --git a/gs_elpa/elpa_db.py b/gs_elpa/elpa_db.py
index 8f8cd6d..e4a0232 100644
--- a/gs_elpa/elpa_db.py
+++ b/gs_elpa/elpa_db.py
@@ -7,7 +7,7 @@
ELPA package database
- :copyright: (c) 2013 by Jauhien Piatlicki
+ :copyright: (c) 2013-2014 by Jauhien Piatlicki
:license: GPL-2, see LICENSE for more details.
"""
@@ -109,7 +109,7 @@ class ElpaDBGenerator(DBGenerator):
#eclass entry
'eclasses' : ['g-sorcery', 'gs-elpa'],
#metadata entries
- 'maintainer' : [{'email' : 'piatlicki@gmail.com',
+ 'maintainer' : [{'email' : 'jauhien@gentoo.org',
'name' : 'Jauhien Piatlicki'}],
'longdescription' : description
}
diff --git a/setup.py b/setup.py
index 10f0461..4cc3c11 100644
--- a/setup.py
+++ b/setup.py
@@ -2,24 +2,15 @@
from distutils.core import setup
-setup(name = 'g-sorcery',
+setup(name = 'gs-elpa',
version = '0.1_alpha',
- description = 'g-sorcery framework for automated ebuild generators',
+ description = 'g-sorcery backend for elisp packages',
author = 'Jauhien Piatlicki',
- author_email = 'piatlicki@gmail.com',
- packages = ['g_sorcery', 'gs_db_tool', 'gs_elpa', 'gs_ctan', 'gs_pypi'],
- package_data = {'g_sorcery': ['data/*'],
- 'gs_pypi': ['data/*'],
- 'gs_elpa': ['data/*'],
- 'gs_ctan': ['data/*']},
- scripts = ['bin/g-sorcery', 'bin/gs-db-tool', 'bin/gs-elpa',
- 'bin/gs-ctan', 'bin/gs-pypi-generate-db', 'bin/gs-pypi'],
+ author_email = 'jauhien@gentoo.org',
+ packages = ['gs_elpa'],
+ package_data = {'gs_elpa': ['data/*']},
+ scripts = ['bin/gs-elpa'],
data_files = [('/etc/g-sorcery/', ['gs-elpa.json']),
- ('/etc/g-sorcery/', ['gs-ctan.json']),
- ('/etc/g-sorcery/', ['gs-pypi.json']),
- ('/etc/g-sorcery/', ['g-sorcery.cfg']),
- ('/etc/layman/overlays/', ['gs-elpa-overlays.xml']),
- ('/etc/layman/overlays/', ['gs-ctan-overlays.xml']),
- ('/etc/layman/overlays/', ['gs-pypi-overlays.xml'])],
+ ('/etc/layman/overlays/', ['gs-elpa-overlays.xml'])],
license = 'GPL',
)