aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg (Zorry) <zorry@gentoo.org>2010-05-26 23:58:06 +0200
committerMagnus Granberg (Zorry) <zorry@gentoo.org>2010-05-26 23:58:06 +0200
commitdad7b761feae86f47d071b439458fe7e67ffd0e1 (patch)
treecf3cce87f2b57a594de902b0b84858eda16eed4e
parentUpdated all to 0.4.3 (diff)
downloadhardened-gccpatchset-dad7b761feae86f47d071b439458fe7e67ffd0e1.tar.gz
hardened-gccpatchset-dad7b761feae86f47d071b439458fe7e67ffd0e1.tar.bz2
hardened-gccpatchset-dad7b761feae86f47d071b439458fe7e67ffd0e1.zip
Updated all piepatches to 0.4.4 and the specs to 0.2.0
-rw-r--r--gcc-4.4.3/piepatch/30_all_gcc44_esp.h.patch22
-rw-r--r--gcc-4.4.3/piepatch/README.Changelog5
-rw-r--r--gcc-4.4.3/piepatch/README.history2
-rw-r--r--gcc-4.4.3/specs/README.Changelog8
-rw-r--r--gcc-4.4.3/specs/README.history4
-rw-r--r--gcc-4.4.3/specs/hardenednopie.specs2
-rw-r--r--gcc-4.5.0/piepatch/30_all_gcc44_esp.h.patch22
-rw-r--r--gcc-4.5.0/piepatch/README.Changelog5
-rw-r--r--gcc-4.5.0/piepatch/README.history2
9 files changed, 46 insertions, 26 deletions
diff --git a/gcc-4.4.3/piepatch/30_all_gcc44_esp.h.patch b/gcc-4.4.3/piepatch/30_all_gcc44_esp.h.patch
index e5e9700..2b233ae 100644
--- a/gcc-4.4.3/piepatch/30_all_gcc44_esp.h.patch
+++ b/gcc-4.4.3/piepatch/30_all_gcc44_esp.h.patch
@@ -1,13 +1,13 @@
2010-05-26 Magnus Granberg <zorry@gentoo.org>
* gcc/esp.h New file to support --enable-esp
- Version 20100526.1
+ Version 20100526.2
--- gcc/esp.h 2010-04-09 16:14:00.000000000 +0200
+++ gcc/esp.h 2010-04-29 21:30:47.000000000 +0200
@@ -0,0 +1,145 @@
+/* License terms see GNU GENERAL PUBLIC LICENSE Version 3.
-+ * Version 20100526.1
++ * Version 20100526.2
+ * Magnus Granberg (Zorry) <zorry@gentoo.org> */
+#ifndef GCC_ESP_H
+#define GCC_ESP_H
@@ -19,8 +19,8 @@
+ This will add some unsupported upstream commands options as -nopie and -nonow.
+ -D__KERNEL__ is added so we don't have -fPIE, -pie and -fstack-protector-all when building kernels.
+ ESP_CC1_SPEC is added to CC1_SPEC.
-+ ESP_CC1_STRICT_SPEC is added so we don't disable the strict-overflow check.
-+ ESP_OPTIONS_PIE_CHECK_SPEC check for -pie, -p, -pg, -profile and -static.
++ ESP_CC1_STRICT_OVERFLOW_SPEC is added so we don't disable the strict-overflow check.
++ ESP_LINK_PIE_CHECK_SPEC check for -pie, -p, -pg, -profile and -static.
+ ENABLE_CRTBEGINTS add support for crtbeginTS.o, build -static with -fPIE or -fpie.
+*/
+#ifdef ENABLE_ESP
@@ -37,12 +37,12 @@
+ #else
+ #define ESP_CC1_PIE_SPEC ""
+ #endif
-+ #define ESP_CC1_STRICT_SPEC "%{!fstrict-overflow:%{!fno-strict-overflow: -fno-strict-overflow}}"
++ #define ESP_CC1_STRICT_OVERFLOW_SPEC "%{!fstrict-overflow:%{!fno-strict-overflow: -fno-strict-overflow}}"
+
+ /* ESP_LINK_SPEC is added to LINK_PIE_SPEC if esp is enable
+ -z now will be added if we don't have -vanilla spec. We do a -pie incompatible check
+ Don't remove the specs in the end */
-+ #define ESP_LINK_SPEC "%(esp_link_now) %(esp_options_pie_check) "
++ #define ESP_LINK_SPEC "%(esp_link_now) %(esp_link_pie_check) "
+ #define ESP_LINK_NOW_SPEC "%{!nonow:-z now}"
+
+ /* We use ESP_COMMAND_OPTIONS_SPEC to add pie command-line options. */
@@ -99,10 +99,10 @@
+ "-pie and (static)|pg|p|profile are incompatible when linking" */
+ /* With ENABLE_CRTBEGINTS we don't need to check for -static */
+ #ifdef ENABLE_CRTBEGINTS
-+ #define ESP_OPTIONS_PIE_CHECK_SPEC \
++ #define ESP_LINK_PIE_CHECK_SPEC \
+ "%{pie:%{pg|p|profile:%e-pie and -pg|p|profile are incompatible when linking}}"
+ #else
-+ #define ESP_OPTIONS_PIE_CHECK_SPEC \
++ #define ESP_LINK_PIE_CHECK_SPEC \
+ "%{pie:%{static|pg|p|profile:%e-pie and -static|pg|p|profile are incompatible when linking}}"
+ #endif
+
@@ -115,7 +115,7 @@
+
+ #else
+ #define ESP_OPTIONS_PIE_SPEC ""
-+ #define ESP_OPTIONS_PIE_CHECK_SPEC ""
++ #define ESP_LINK_PIE_CHECK_SPEC ""
+ #define ESP_LINK_PIE_SPEC ""
+ #define LINK_PIE_SPEC "%{pie:-pie} %(esp_link)"
+ #endif
@@ -125,15 +125,15 @@
+ { "esp_cc1", ESP_CC1_SPEC }, \
+ { "esp_cc1_pie", ESP_CC1_PIE_SPEC }, \
+ { "esp_cc1_ssp", ESP_CC1_SSP_SPEC }, \
-+ { "esp_cc1_strict", ESP_CC1_STRICT_SPEC }, \
++ { "esp_cc1_strict_overflow", ESP_CC1_STRICT_OVERFLOW_SPEC }, \
+ { "esp_link", ESP_LINK_SPEC }, \
+ { "esp_link_now", ESP_LINK_NOW_SPEC }, \
+ { "esp_link_pie", ESP_LINK_PIE_SPEC }, \
++ { "esp_link_pie_check", ESP_LINK_PIE_CHECK_SPEC }, \
+ { "esp_command_options", ESP_COMMAND_OPTIONS_SPEC }, \
+ { "esp_cpp_options", ESP_CPP_OPTIONS_SPEC }, \
+ { "esp_options", ESP_OPTIONS_SPEC }, \
+ { "esp_options_pie", ESP_OPTIONS_PIE_SPEC }, \
-+ { "esp_options_pie_check", ESP_OPTIONS_PIE_CHECK_SPEC }, \
+ { "esp_options_ssp", ESP_OPTIONS_SSP_SPEC }
+
+ static const char *esp_command_options_spec = ESP_COMMAND_OPTIONS_SPEC;
diff --git a/gcc-4.4.3/piepatch/README.Changelog b/gcc-4.4.3/piepatch/README.Changelog
index 5554c8f..33a5f11 100644
--- a/gcc-4.4.3/piepatch/README.Changelog
+++ b/gcc-4.4.3/piepatch/README.Changelog
@@ -1,3 +1,8 @@
+0.4.4 Magnus Granberg <zorry@gentoo.org>
+
+ * gcc/esp.h Renamed ESP_CC1_STRICT_SPEC to ESP_CC1_STRICT_OVERFLOW_SPEC
+ Renamed ESP_OPTIONS_PIE_CHECK_SPEC to ESP_LINK_PIE_CHECK_SPEC
+
0.4.3 Magnus Granberg <zorry@gentoo.org>
#299061 b.g.o
diff --git a/gcc-4.4.3/piepatch/README.history b/gcc-4.4.3/piepatch/README.history
index f41b241..7b6c0dc 100644
--- a/gcc-4.4.3/piepatch/README.history
+++ b/gcc-4.4.3/piepatch/README.history
@@ -1,3 +1,5 @@
+0.4.4 26-05-2010
+ U 30_all_gcc44_esp.h.patch
0.4.3 26-05-2010
U 20_all_gcc44_gcc.c.patch
U 30_all_gcc44_esp.h.patch
diff --git a/gcc-4.4.3/specs/README.Changelog b/gcc-4.4.3/specs/README.Changelog
index 995152e..e104b5a 100644
--- a/gcc-4.4.3/specs/README.Changelog
+++ b/gcc-4.4.3/specs/README.Changelog
@@ -1,10 +1,14 @@
-0.1.9 Magnus granberg <zorry@gentoo.org>
+0.2.0 Magnus Granberg <zorry@gentoo.org>
+
+ * hardenednopie.spec Renamed esp_options_pie_check
+ to espf_link_pie_check
+
+0.1.9 Magnus Granberg <zorry@gentoo.org>
* hardenednopiessp.spec New file disable pie and ssp
0.1.8 Magnus Granberg <zorry@gentoo.org>
- * vanilla.specs change espf_cc1_strict_overflow to espf_cc1_strict
* README.Gentoo.patches Updated links.
0.1.7 Magnus Granberg <zorry@ume.nu>
diff --git a/gcc-4.4.3/specs/README.history b/gcc-4.4.3/specs/README.history
index 301757c..1d147b2 100644
--- a/gcc-4.4.3/specs/README.history
+++ b/gcc-4.4.3/specs/README.history
@@ -1,5 +1,7 @@
+0.2.0 05-26-2010
+ U hardenednopie.specs
0.1.9 04-19-2010
- hardenednopiessp.specs
+ + hardenednopiessp.specs
0.1.8 04-10-2010
vanilla.specs
diff --git a/gcc-4.4.3/specs/hardenednopie.specs b/gcc-4.4.3/specs/hardenednopie.specs
index 7260d4d..ccc4d76 100644
--- a/gcc-4.4.3/specs/hardenednopie.specs
+++ b/gcc-4.4.3/specs/hardenednopie.specs
@@ -4,7 +4,7 @@
*esp_options_pie:
-*esp_options_pie_check:
+*esp_link_pie_check:
*esp_link_pie:
diff --git a/gcc-4.5.0/piepatch/30_all_gcc44_esp.h.patch b/gcc-4.5.0/piepatch/30_all_gcc44_esp.h.patch
index e5e9700..2b233ae 100644
--- a/gcc-4.5.0/piepatch/30_all_gcc44_esp.h.patch
+++ b/gcc-4.5.0/piepatch/30_all_gcc44_esp.h.patch
@@ -1,13 +1,13 @@
2010-05-26 Magnus Granberg <zorry@gentoo.org>
* gcc/esp.h New file to support --enable-esp
- Version 20100526.1
+ Version 20100526.2
--- gcc/esp.h 2010-04-09 16:14:00.000000000 +0200
+++ gcc/esp.h 2010-04-29 21:30:47.000000000 +0200
@@ -0,0 +1,145 @@
+/* License terms see GNU GENERAL PUBLIC LICENSE Version 3.
-+ * Version 20100526.1
++ * Version 20100526.2
+ * Magnus Granberg (Zorry) <zorry@gentoo.org> */
+#ifndef GCC_ESP_H
+#define GCC_ESP_H
@@ -19,8 +19,8 @@
+ This will add some unsupported upstream commands options as -nopie and -nonow.
+ -D__KERNEL__ is added so we don't have -fPIE, -pie and -fstack-protector-all when building kernels.
+ ESP_CC1_SPEC is added to CC1_SPEC.
-+ ESP_CC1_STRICT_SPEC is added so we don't disable the strict-overflow check.
-+ ESP_OPTIONS_PIE_CHECK_SPEC check for -pie, -p, -pg, -profile and -static.
++ ESP_CC1_STRICT_OVERFLOW_SPEC is added so we don't disable the strict-overflow check.
++ ESP_LINK_PIE_CHECK_SPEC check for -pie, -p, -pg, -profile and -static.
+ ENABLE_CRTBEGINTS add support for crtbeginTS.o, build -static with -fPIE or -fpie.
+*/
+#ifdef ENABLE_ESP
@@ -37,12 +37,12 @@
+ #else
+ #define ESP_CC1_PIE_SPEC ""
+ #endif
-+ #define ESP_CC1_STRICT_SPEC "%{!fstrict-overflow:%{!fno-strict-overflow: -fno-strict-overflow}}"
++ #define ESP_CC1_STRICT_OVERFLOW_SPEC "%{!fstrict-overflow:%{!fno-strict-overflow: -fno-strict-overflow}}"
+
+ /* ESP_LINK_SPEC is added to LINK_PIE_SPEC if esp is enable
+ -z now will be added if we don't have -vanilla spec. We do a -pie incompatible check
+ Don't remove the specs in the end */
-+ #define ESP_LINK_SPEC "%(esp_link_now) %(esp_options_pie_check) "
++ #define ESP_LINK_SPEC "%(esp_link_now) %(esp_link_pie_check) "
+ #define ESP_LINK_NOW_SPEC "%{!nonow:-z now}"
+
+ /* We use ESP_COMMAND_OPTIONS_SPEC to add pie command-line options. */
@@ -99,10 +99,10 @@
+ "-pie and (static)|pg|p|profile are incompatible when linking" */
+ /* With ENABLE_CRTBEGINTS we don't need to check for -static */
+ #ifdef ENABLE_CRTBEGINTS
-+ #define ESP_OPTIONS_PIE_CHECK_SPEC \
++ #define ESP_LINK_PIE_CHECK_SPEC \
+ "%{pie:%{pg|p|profile:%e-pie and -pg|p|profile are incompatible when linking}}"
+ #else
-+ #define ESP_OPTIONS_PIE_CHECK_SPEC \
++ #define ESP_LINK_PIE_CHECK_SPEC \
+ "%{pie:%{static|pg|p|profile:%e-pie and -static|pg|p|profile are incompatible when linking}}"
+ #endif
+
@@ -115,7 +115,7 @@
+
+ #else
+ #define ESP_OPTIONS_PIE_SPEC ""
-+ #define ESP_OPTIONS_PIE_CHECK_SPEC ""
++ #define ESP_LINK_PIE_CHECK_SPEC ""
+ #define ESP_LINK_PIE_SPEC ""
+ #define LINK_PIE_SPEC "%{pie:-pie} %(esp_link)"
+ #endif
@@ -125,15 +125,15 @@
+ { "esp_cc1", ESP_CC1_SPEC }, \
+ { "esp_cc1_pie", ESP_CC1_PIE_SPEC }, \
+ { "esp_cc1_ssp", ESP_CC1_SSP_SPEC }, \
-+ { "esp_cc1_strict", ESP_CC1_STRICT_SPEC }, \
++ { "esp_cc1_strict_overflow", ESP_CC1_STRICT_OVERFLOW_SPEC }, \
+ { "esp_link", ESP_LINK_SPEC }, \
+ { "esp_link_now", ESP_LINK_NOW_SPEC }, \
+ { "esp_link_pie", ESP_LINK_PIE_SPEC }, \
++ { "esp_link_pie_check", ESP_LINK_PIE_CHECK_SPEC }, \
+ { "esp_command_options", ESP_COMMAND_OPTIONS_SPEC }, \
+ { "esp_cpp_options", ESP_CPP_OPTIONS_SPEC }, \
+ { "esp_options", ESP_OPTIONS_SPEC }, \
+ { "esp_options_pie", ESP_OPTIONS_PIE_SPEC }, \
-+ { "esp_options_pie_check", ESP_OPTIONS_PIE_CHECK_SPEC }, \
+ { "esp_options_ssp", ESP_OPTIONS_SSP_SPEC }
+
+ static const char *esp_command_options_spec = ESP_COMMAND_OPTIONS_SPEC;
diff --git a/gcc-4.5.0/piepatch/README.Changelog b/gcc-4.5.0/piepatch/README.Changelog
index 302ed6b..936b997 100644
--- a/gcc-4.5.0/piepatch/README.Changelog
+++ b/gcc-4.5.0/piepatch/README.Changelog
@@ -1,3 +1,8 @@
+0.4.4 Magnus Granberg <zorry@gentoo.org>
+
+ * gcc/esp.h Renamed ESP_CC1_STRICT_SPEC to ESP_CC1_STRICT_OVERFLOW_SPEC
+ Renamed ESP_OPTIONS_PIE_CHECK_SPEC to ESP_LINK_PIE_CHECK_SPEC
+
0.4.3 Magnus Granberg <zorry@gentoo.org>
#299061 b.g.o
diff --git a/gcc-4.5.0/piepatch/README.history b/gcc-4.5.0/piepatch/README.history
index 319245b..c13f0db 100644
--- a/gcc-4.5.0/piepatch/README.history
+++ b/gcc-4.5.0/piepatch/README.history
@@ -1,3 +1,5 @@
+0.4.4 26-05-2010
+ U 30_all_gcc44_esp.h.patch
0.4.3 26-05-2010
U 20_all_gcc44_gcc.c.patch
U 30_all_gcc44_esp.h.patch