aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Göttsche <cgzones@googlemail.com>2024-02-22 17:41:28 +0100
committerKenton Groombridge <concord@gentoo.org>2024-03-01 12:05:41 -0500
commitd4a01ab0b955623422eade1f35368a2ee3983db9 (patch)
tree3bbf696623d32c8c261649fd69eedfe981a608db
parentRules.modular: use temporary file to not ignore error (diff)
downloadhardened-refpolicy-d4a01ab0b955623422eade1f35368a2ee3983db9.tar.gz
hardened-refpolicy-d4a01ab0b955623422eade1f35368a2ee3983db9.tar.bz2
hardened-refpolicy-d4a01ab0b955623422eade1f35368a2ee3983db9.zip
Makefile: use sepolgen-ifgen-attr-helper from test toolchain
When building with a non default toolchain by setting the environment variable TEST_TOOLCHAIN also use the sepolgen-ifgen helper binary sepolgen-ifgen-attr-helper from this toolchain. Signed-off-by: Christian Göttsche <cgzones@googlemail.com> Signed-off-by: Kenton Groombridge <concord@gentoo.org>
-rw-r--r--Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 3f1d3060..82df2045 100644
--- a/Makefile
+++ b/Makefile
@@ -62,7 +62,11 @@ SEMOD_PKG ?= $(tc_usrbindir)/semodule_package
SEMOD_LNK ?= $(tc_usrbindir)/semodule_link
SEMOD_EXP ?= $(tc_usrbindir)/semodule_expand
LOADPOLICY ?= $(tc_usrsbindir)/load_policy
+ifdef TEST_TOOLCHAIN
+SEPOLGEN_IFGEN ?= $(tc_usrbindir)/sepolgen-ifgen --attr-helper $(TEST_TOOLCHAIN)$(BINDIR)/sepolgen-ifgen-attr-helper
+else
SEPOLGEN_IFGEN ?= $(tc_usrbindir)/sepolgen-ifgen
+endif
SETFILES ?= $(tc_sbindir)/setfiles
SEFCONTEXT_COMPILE ?= $(tc_usrsbindir)/sefcontext_compile
XMLLINT ?= $(BINDIR)/xmllint