aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@flameeyes.eu>2012-12-02 09:43:28 -0800
committerDiego Elio Pettenò <flameeyes@flameeyes.eu>2012-12-02 09:45:57 -0800
commit3f1e4efa40c3189e6f631ced6245f2e6bf73a1b3 (patch)
treeec5f38bcef2d944c3715ce2ead6f1e0b9ae1a7e7 /Makefile
parentFix URL of GitHu repository. (diff)
downloadhwids-3f1e4efa40c3189e6f631ced6245f2e6bf73a1b3.tar.gz
hwids-3f1e4efa40c3189e6f631ced6245f2e6bf73a1b3.tar.bz2
hwids-3f1e4efa40c3189e6f631ced6245f2e6bf73a1b3.zip
Add udev's hwdb support straight into hwids.hwids-20121202.3
Download the ACPI table (which is not autogenerated) as well as the hwdb updater script from systemd's git, and add a Makefile rule to re-generate the hwdb files.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 95b304e..7e47c03 100644
--- a/Makefile
+++ b/Makefile
@@ -13,10 +13,15 @@ fetch:
$(Q)$(HTTPCAT) http://pci-ids.ucw.cz/v2.2/pci.ids.bz2 | bzcat > pci.ids
$(Q)$(HTTPCAT) http://www.linux-usb.org/usb.ids.bz2 | bzcat > usb.ids
$(Q)$(HTTPCAT) http://standards.ieee.org/develop/regauth/oui/oui.txt > oui.txt
+ $(Q)$(HTTPCAT) http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/20-acpi-vendor.hwdb > udev/20-acpi-vendor.hwdb
+ $(Q)$(HTTPCAT) http://cgit.freedesktop.org/systemd/systemd/plain/hwdb/ids-update.pl > udev-hwdb-update.pl
$(Q)$(STATUS)
-PV ?= $(shell ( awk '$$2 == "Date:" { print $$3; nextfile }' pci.ids usb.ids; git log --format=format:%ci -1 -- oui.txt | cut -d ' ' -f1; ) | sort | tail -n 1 | tr -d -)
+PV ?= $(shell ( awk '$$2 == "Date:" { print $$3; nextfile }' pci.ids usb.ids; git log --format=format:%ci -1 -- oui.txt hwdb/20-acpi-vendor.hwdb udev-hwdb-update.pl | cut -d ' ' -f1; ) | sort | tail -n 1 | tr -d -)
P = hwids-$(PV)
tag:
git tag $(P)
+
+udev-hwdb:
+ perl ./udev-hwdb-update.pl && mv *.hwdb udev/