aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml17
1 files changed, 17 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..33e28ca
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,17 @@
+[project]
+name = 'java-config'
+dynamic = ['version']
+description = 'Java environment configuration query tool'
+readme = 'README'
+requires-python = '>=3.9'
+license = {file = "COPYING"}
+authors = [
+ {name = 'Gentoo Java Project', email = 'java@gentoo.org'},
+]
+
+[build-system]
+build-backend = 'mesonpy'
+requires = ['meson-python']
+
+[tool.meson-python.args]
+setup = ['-Dsystem-wide=false']