aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2021-06-30 11:34:37 +0200
committerFlorian Schmaus <flow@gentoo.org>2021-06-30 11:35:25 +0200
commit3f9f507e0155576242d1959919da2b4f6e12b0ab (patch)
tree877dd6857abda745b8dbe88853814387f8f67002
parentdev-java/pircbot: treeclean (diff)
downloadjava-3f9f507e0155576242d1959919da2b4f6e12b0ab.tar.gz
java-3f9f507e0155576242d1959919da2b4f6e12b0ab.tar.bz2
java-3f9f507e0155576242d1959919da2b4f6e12b0ab.zip
dev-java/joal: treeclean
Reason: failed sourcing ebuild: java-pkg-2: EAPI 2 not supported, (java-pkg-2.eclass, line 17: called die) Bug: https://bugs.gentoo.org/759889 Signed-off-by: Florian Schmaus <flow@gentoo.org>
-rw-r--r--dev-java/joal/Manifest1
-rw-r--r--dev-java/joal/files/joal-1.1.2-build.xml.patch68
-rw-r--r--dev-java/joal/joal-1.1.2.ebuild57
-rw-r--r--dev-java/joal/metadata.xml15
4 files changed, 0 insertions, 141 deletions
diff --git a/dev-java/joal/Manifest b/dev-java/joal/Manifest
deleted file mode 100644
index 7ff075d5..00000000
--- a/dev-java/joal/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST joal-1.1.2-src.zip 3140255 SHA256 9290cdd8a7312cbb6a0da0c9edea0e042525dfcfd8d68e05706283d5f55ec8cb
diff --git a/dev-java/joal/files/joal-1.1.2-build.xml.patch b/dev-java/joal/files/joal-1.1.2-build.xml.patch
deleted file mode 100644
index b80160fc..00000000
--- a/dev-java/joal/files/joal-1.1.2-build.xml.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-diff -Naur joal.old/make/build.xml joal/make/build.xml
---- joal.old/make/build.xml 2006-12-20 18:43:10.000000000 +1300
-+++ joal/make/build.xml 2007-03-10 23:31:58.000000000 +1300
-@@ -113,9 +113,12 @@
- <!-- sibling of the JOAL workspace. -->
- <property name="gluegen.make.dir" value="../../gluegen/make" />
- <property name="gluegen.build.xml" value="${gluegen.make.dir}/build.xml" />
-+
- <property name="gluegen.jar" value="../../gluegen/build/gluegen.jar" />
- <property name="gluegen-rt.jar" value="../../gluegen/build/gluegen-rt.jar" />
--
-+ <echo message="gluegen.jar=${gluegen.jar}" />
-+ <echo message="gluegen-rt.jar=${gluegen-rt.jar}" />
-+
- <!-- Create the classpath that includes GlueGen and
- - ANTLR. This requires the user-defined "antlr.jar"
- - property. -->
-@@ -124,6 +127,22 @@
- <pathelement location="${antlr.jar}" />
- </path>
-
-+
-+
-+ <!-- This property will stop gluegen from being built.
-+ - It is meant for situations where gluegen is already
-+ - availiable on the system.
-+ -->
-+ <condition property="gluegen.prebuilt">
-+ <and>
-+ <available file="${gluegen.jar}" />
-+ <available file="${gluegen-rt.jar}" />
-+ </and>
-+ </condition>
-+
-+ <echo message="gluegen.prebuilt=${gluegen.prebuilt}" />
-+
-+
- <!-- Names of directories relative to the project root.
- Some of these are used in FileMappers later for dependence information
- and need exact string matching, which is why they use file.separator
-@@ -342,10 +361,16 @@
- <!--
- - Build GlueGen
- -->
-- <target name="build.gluegen" depends="init">
-+
-+ <!--
-+ Gentoo patch makes this check whether gluegen is already avaliable
-+ -->
-+ <target name="build.gluegen" depends="init" unless="gluegen.prebuilt">
- <!-- Run the GlueGen build to ensure that the GlueGen ANT task
- - has been built. -->
-- <ant antfile="${gluegen.build.xml}" dir="${gluegen.make.dir}" target="all" inheritAll="false" />
-+ <ant antfile="${gluegen.build.xml}" dir="${gluegen.make.dir}" target="all" inheritAll="false">
-+ <property name="antlr.jar" value="${antlr.jar}" />
-+ </ant>
- </target>
-
- <!-- ================================================================== -->
-@@ -577,7 +602,7 @@
- </target>
-
- <!-- Build zip archives for developers, both source and binaries -->
-- <target name="zip" depends="setup-version-string">
-+ <target name="zip" depends="setup-version-string" >
- <!-- Clean up and create temporary directory -->
- <delete dir="../build/tmp" failonerror="false" />
- <delete>
diff --git a/dev-java/joal/joal-1.1.2.ebuild b/dev-java/joal/joal-1.1.2.ebuild
deleted file mode 100644
index 4d578922..00000000
--- a/dev-java/joal/joal-1.1.2.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-
-WANT_ANT_TASKS="ant-antlr"
-JAVA_PKG_IUSE="doc test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Java binding for OpenAL API"
-HOMEPAGE="https://joal.dev.java.net/"
-SRC_URI="http://download.java.net/media/joal/builds/archive/${PV}/${P}-src.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-CDEPEND="media-libs/openal:0
- dev-java/gluegen:0"
-DEPEND=">=virtual/jdk-1.4
- dev-java/antlr:0
- app-arch/unzip
- ${CDEPEND}"
-RDEPEND=">=virtual/jre-1.4
- ${CDEPEND}"
-
-S="${WORKDIR}/${PN}"
-
-java_prepare() {
- epatch "${FILESDIR}/${PF}-build.xml.patch"
-
- mkdir make/lib/linux-amd64
-}
-
-src_compile() {
- cd make/ || die "Unable to enter make directory"
- local antflags="-Dantlr.jar=$(java-pkg_getjars --build-only antlr)"
- local gcp="$(java-config --tools)"
- local gluegen="-Dgluegen.jar=$(java-pkg_getjar gluegen gluegen.jar)"
- local gluegen_rt="-Dgluegen-rt.jar=$(java-pkg_getjar gluegen 'gluegen-rt.jar')"
-
- eant -Djoal.lib.dir=/usr "${antflags}" \
- -Dgentoo.classpath="${gcp}" "${gluegen}" "${gluegen_rt}" \
- declare jar c.build.joal $(use_doc javadoc)
-}
-
-src_install() {
- #Another jar is also created, that contains
- #the generated shared library. We shouldn't need it.
- java-pkg_dojar build/${PN}.jar
- use_doc && java-pkg_dojavadoc javadoc_public
- java-pkg_doso build/obj/*.so
-}
-
diff --git a/dev-java/joal/metadata.xml b/dev-java/joal/metadata.xml
deleted file mode 100644
index 11faac1c..00000000
--- a/dev-java/joal/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
-<email>java@gentoo.org</email>
-<name>Java</name>
-</maintainer>
-<longdescription lang="en">
-The JOAL Project hosts a reference implementation of the Java bindings for
-OpenAL API, and is designed to provide hardware-supported 3D spatialized audio
-for games written in Java. It is part of a suite of open-source technologies
-initiated by the Game Technology Group at Sun Microsystems, with intention of
-making the development of high performance games in Java a reality.
-</longdescription>
-</pkgmetadata>