aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-06-11 18:03:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-06-11 21:33:08 +0200
commit1ff1ac134374c03b4f4399f1510cd1f3c10eb14c (patch)
tree5aa953100248bfd35cd6fe614e4b19b49077891d /app-cdr
parentkde-apps/umbrello: 24.05.1 version bump (diff)
downloadkde-1ff1ac134374c03b4f4399f1510cd1f3c10eb14c.tar.gz
kde-1ff1ac134374c03b4f4399f1510cd1f3c10eb14c.tar.bz2
kde-1ff1ac134374c03b4f4399f1510cd1f3c10eb14c.zip
app-cdr/dolphin-plugins-mountiso: 24.05.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.05.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
new file mode 100644
index 0000000000..0f110cea59
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -0,0 +1 @@
+DIST dolphin-plugins-24.05.1.tar.xz 306024 BLAKE2B 3b5c999c6eb2657e1d0e831f6f23942aa14515459a263217e62b1a04ccafe480cd7723d855ccecf3aba197f17ca172234d6f182681970a5a216bdb72a7357871 SHA512 0b26cf5e09b837f451d6e902f0aa6ce231327dd3eda480b4bff6987f6f0ea8688d9ff097681cef855e1a47b599c3092e183905193f15b0b905345362be1e1fdb
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.05.1.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.05.1.ebuild
new file mode 100644
index 0000000000..1c8dd99f2d
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.05.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=6.3.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # qtconcurrent only required by git
+ ecm_punt_qt_module Concurrent
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}