aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-19 17:21:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-19 17:50:12 +0100
commit55ae2e33eb96949e44dea762a5e87225ceb4c742 (patch)
tree8b3c119ff29ebe3328cd14d99dccba2c8c1dc3c6 /app-cdr
parentkde-apps/umbrello: 24.02.1 version bump (diff)
downloadkde-55ae2e33eb96949e44dea762a5e87225ceb4c742.tar.gz
kde-55ae2e33eb96949e44dea762a5e87225ceb4c742.tar.bz2
kde-55ae2e33eb96949e44dea762a5e87225ceb4c742.zip
app-cdr/dolphin-plugins-mountiso: 24.02.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.02.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
new file mode 100644
index 0000000000..e833a561a5
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -0,0 +1 @@
+DIST dolphin-plugins-24.02.1.tar.xz 296296 BLAKE2B 804ec7e27752b642e1f9c212be7d721dab502b8b162e7a0ee00406f3a8754ce43767b9cb01e5ac5c94d94cf42e171e9e4b90bda01e4db6f6ddf6cb841ede21d5 SHA512 de69bf30ac3c8a6e15542c084b89882fdb9af31db0ffa7160c77bc7f1ad26d8011953b194de41938370ac4babf73ee3e167850d9bb0cd506f93817de937a4688
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.02.1.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.02.1.ebuild
new file mode 100644
index 0000000000..11419012f8
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.02.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=6.0.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}