aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-25 19:43:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-26 12:38:59 +0200
commit61affc713e683524bf3f6d18ad88120b3cdf3b88 (patch)
treeffb713be5d7cc9b8a4215f9a7b044114c5799d71 /app-cdr
parentkde-apps/umbrello: 23.03.80 version bump (diff)
downloadkde-61affc713e683524bf3f6d18ad88120b3cdf3b88.tar.gz
kde-61affc713e683524bf3f6d18ad88120b3cdf3b88.tar.bz2
kde-61affc713e683524bf3f6d18ad88120b3cdf3b88.zip
app-cdr/dolphin-plugins-mountiso: 23.03.80 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.03.80.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
new file mode 100644
index 0000000000..c5ba9f05b5
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -0,0 +1 @@
+DIST dolphin-plugins-23.03.80.tar.xz 272432 BLAKE2B fbe3aa9f8e0730ea2119dd1b6b3676dc841b3bd60ffe0a108154da893e923e5c31ecd47bec17f5ff16cc25291b8a74ce85d3022eb75d3f89e76c09954fbfe8ff SHA512 1c56f8b0533e1fed4c36fc0a05ae8f25b94ea4b2a939af2407dc1f095f6f963db1e7355eda6f7a4cda643aefa01a5bb3f0d3950f581e38fe960eacba9983521b
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.03.80.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.03.80.ebuild
new file mode 100644
index 0000000000..f4ba6d3d3e
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-23.03.80.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="false"
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=5.104.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/dolphin-${PVCUT}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+ # delete non-${PN} translations
+ find po -type f -name "*po" -and -not -name "*${MY_PLUGIN_NAME}plugin" -delete || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ rm "${D}"/usr/share/metainfo/org.kde.dolphin-plugins.metainfo.xml || die
+}