aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-04-21 22:22:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-04-21 22:52:40 +0200
commite7328e382435cb0e594337447963551a1620fb6e (patch)
tree184fea666f100cc91ace8e307fa3183f6dd64aef /app-office/merkuro
parentnet-p2p/ktorrent: Add 24.05 stable branch (diff)
downloadkde-e7328e382435cb0e594337447963551a1620fb6e.tar.gz
kde-e7328e382435cb0e594337447963551a1620fb6e.tar.bz2
kde-e7328e382435cb0e594337447963551a1620fb6e.zip
app-office/merkuro: Add 24.05 stable branch
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-office/merkuro')
-rw-r--r--app-office/merkuro/merkuro-24.05.49.9999.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-office/merkuro/merkuro-24.05.49.9999.ebuild b/app-office/merkuro/merkuro-24.05.49.9999.ebuild
new file mode 100644
index 0000000000..e4b1a338f3
--- /dev/null
+++ b/app-office/merkuro/merkuro-24.05.49.9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_CATEGORY="pim"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.0.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Calendar application using Akonadi"
+HOMEPAGE="https://apps.kde.org/merkuro.calendar/"
+
+LICENSE="|| ( GPL-2 GPL-3 ) CC0-1.0"
+SLOT="6"
+KEYWORDS=""
+IUSE=""
+
+# All of the tests involve interacting with akonadi right now (as of 22.04)
+RESTRICT="test"
+
+# TODO: Needs messagecomposer
+DEPEND="
+ app-crypt/gpgme:=[cxx]
+ dev-libs/kirigami-addons:6
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=dev-qt/qtsvg-${QTMIN}:6
+ >=kde-apps/akonadi-${PVCUT}:6
+ >=kde-apps/akonadi-contacts-${PVCUT}:6
+ >=kde-apps/akonadi-mime-${PVCUT}:6
+ >=kde-apps/kcalutils-${PVCUT}:6
+ >=kde-apps/kidentitymanagement-${PVCUT}:6
+ >=kde-apps/kmailtransport-${PVCUT}:6
+ >=kde-apps/kmbox-${PVCUT}:6
+ >=kde-apps/kmime-${PVCUT}:6
+ >=kde-apps/mailcommon-${PVCUT}:6
+ >=kde-apps/mimetreeparser-${PVCUT}:6
+ >=kde-frameworks/kcalendarcore-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcontacts-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-frameworks/kitemmodels-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+"
+# TODO: is qt5compat still needed? 578c2acf4da3e7b26206a9834a79928630f76ecf
+# qtlocation is needed at runtime only or fails to start
+RDEPEND="${DEPEND}
+ >=dev-qt/qt5compat-${QTMIN}:6[qml]
+ >=dev-qt/qtlocation-${QTMIN}:6
+ >=dev-qt/qtwebengine-${QTMIN}:6
+ >=kde-apps/kdepim-runtime-${PVCUT}:6
+ >=kde-frameworks/qqc2-desktop-style-${KFMIN}:6
+"