aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-07 22:31:33 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-10 18:10:45 +0100
commit254ce4b4c7baffca68076554ac4a200f31e9c2ab (patch)
tree8b28b540531a6f0deef66212480e0441c31904bb /games-kids
parentgames-kids/gcompris: Add test dependencies, fix BDEPEND (diff)
downloadkde-254ce4b4c7baffca68076554ac4a200f31e9c2ab.tar.gz
kde-254ce4b4c7baffca68076554ac4a200f31e9c2ab.tar.bz2
kde-254ce4b4c7baffca68076554ac4a200f31e9c2ab.zip
games-kids/gcompris: 0.97_beta version bump
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gcompris/Manifest1
-rw-r--r--games-kids/gcompris/gcompris-0.97_beta.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/games-kids/gcompris/Manifest b/games-kids/gcompris/Manifest
new file mode 100644
index 0000000000..c424202d72
--- /dev/null
+++ b/games-kids/gcompris/Manifest
@@ -0,0 +1 @@
+DIST gcompris-qt-0.97-beta.tar.xz 75872260 BLAKE2B 239fba5b84935f09231eaf6b20ff9c581e16d3f0023900630b426d7fcfca1c63d3599bc9913d26950ac6a062339cb2e975d083e264b80eb7e5b37d69588e5d75 SHA512 d5c5848d6cf847a6d325dfead516ca7fb229e19b5fe0139fdf6c72f3b8d59254b28621821a66bcca02aade1efa9776957326a499f050128da0d185eb11bafed2
diff --git a/games-kids/gcompris/gcompris-0.97_beta.ebuild b/games-kids/gcompris/gcompris-0.97_beta.ebuild
new file mode 100644
index 0000000000..2910e466fd
--- /dev/null
+++ b/games-kids/gcompris/gcompris-0.97_beta.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="optional"
+ECM_TEST="true"
+QT5MIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Full featured educational application for children from 2 to 10"
+HOMEPAGE="https://gcompris.net/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="https://gcompris.net/download/qt/src/beta/${PN}-qt-${PV/_/-}.tar.xz"
+ KEYWORDS=""
+ S="${WORKDIR}/${PN}-qt-${PV/_beta/}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="kiosk"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-${QT5MIN}:5
+ test? (
+ dev-util/cppcheck
+ sys-devel/clang
+ )
+"
+RDEPEND="
+ >=dev-qt/qtdeclarative-${QT5MIN}:5
+ >=dev-qt/qtgui-${QT5MIN}:5
+ >=dev-qt/qtnetwork-${QT5MIN}:5
+ >=dev-qt/qtsensors-${QT5MIN}:5
+ >=dev-qt/qtsvg-${QT5MIN}:5
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtmultimedia-${QT5MIN}:5
+ >=dev-qt/qtxml-${QT5MIN}:5
+ >=dev-qt/qtxmlpatterns-${QT5MIN}:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DQML_BOX2D_MODULE=disabled
+ -DWITH_KIOSK_MODE=$(usex kiosk)
+ )
+ ecm_src_configure
+}