aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-06 15:51:02 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-06 15:58:43 +0100
commit72b5a2ace3aa7f864a5b49341e49fe074df116fa (patch)
treef2f7378d41793844a76ad09f1cb7d3942e445971 /kde-frameworks/syntax-highlighting
parentkde-frameworks/sonnet: 5.88.0 version bump (diff)
downloadkde-72b5a2ace3aa7f864a5b49341e49fe074df116fa.tar.gz
kde-72b5a2ace3aa7f864a5b49341e49fe074df116fa.tar.bz2
kde-72b5a2ace3aa7f864a5b49341e49fe074df116fa.zip
kde-frameworks/syntax-highlighting: 5.88.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest1
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.88.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
new file mode 100644
index 0000000000..e3b990642a
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -0,0 +1 @@
+DIST syntax-highlighting-5.88.0.tar.xz 2372812 BLAKE2B 260622a6ae7faf007e103d06570761d08c23eb6df11fe1d4241e4773b703ac87452f96bb9794e89df53e3c654761cafe2c4502342937fb3880a4bd2f5c2d1186 SHA512 1e1a294b382c7697bc89a27a32911770b4a4fce222e5bb2520cdd42a2792521df9592bd71b87918ed967b225d95cb95832e5325e721dc68cf3fa9b2d8edb396f
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.88.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.88.0.ebuild
new file mode 100644
index 0000000000..094222310b
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.88.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="nls"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}