aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-03-10 17:44:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-03-10 17:50:25 +0100
commitf0f10a29b5f3221ffa6fccf567a21dbf12fc37d3 (patch)
treedd90bbaed4941dd01a1c20c2663400af1a3c7b35 /kde-frameworks/syntax-highlighting
parentkde-frameworks/sonnet: 5.92.0 version bump (diff)
downloadkde-f0f10a29b5f3221ffa6fccf567a21dbf12fc37d3.tar.gz
kde-f0f10a29b5f3221ffa6fccf567a21dbf12fc37d3.tar.bz2
kde-f0f10a29b5f3221ffa6fccf567a21dbf12fc37d3.zip
kde-frameworks/syntax-highlighting: 5.92.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest1
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.92.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
new file mode 100644
index 0000000000..683bbeaed1
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -0,0 +1 @@
+DIST syntax-highlighting-5.92.0.tar.xz 2394744 BLAKE2B b445efecf6c5be17efac2c8247a901f3be1ce576fdb1100fe5da22aceb67ee1161c798de222f08ed611c82a35cba34b6167fd2ad3b150d91a9c46ab8fb299cc1 SHA512 bec8064f041fa6b57e57eb33eeed457ccf4e329f9b9b2ae494e000c26e54d4e966d1368b9772a638e7c8318192e701dfa06f5b3b508e13f32a8ff130582e5d96
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.92.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.92.0.ebuild
new file mode 100644
index 0000000000..437ce41a33
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.92.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="nls"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}