aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-21 22:28:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-22 10:45:25 +0100
commite03199917089b15cfbbf72e8aae8fbd26bb7677f (patch)
tree00f0a0ffdff293db0692bf93c53df687032cdd24 /kde-plasma/kinfocenter
parentkde-plasma/kglobalacceld: 6.0.0 version bump (diff)
downloadkde-e03199917089b15cfbbf72e8aae8fbd26bb7677f.tar.gz
kde-e03199917089b15cfbbf72e8aae8fbd26bb7677f.tar.bz2
kde-e03199917089b15cfbbf72e8aae8fbd26bb7677f.zip
kde-plasma/kinfocenter: 6.0.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-6.0.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index c5bffaee3e..1e2191c150 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -1 +1,2 @@
DIST glogo-small.png 24583 BLAKE2B 0af2ceae708e56f217120e5d8b880fb71401e3761ab26c4af5e74c0622368aa4e34b05160fae15fbfbbc832077810ab5c1e424826632748299fd22997cbe665c SHA512 648be463ec3812a2edcdab54d7a230bf2bd7e6895f4ffe72321d8fca28a5e1e0980f6e3b9a32f369c8369943ceb802a65a94b9dad820dcf2c81d4581d814cb48
+DIST kinfocenter-6.0.0.tar.xz 829520 BLAKE2B 3758ce3fdac017ce03125a81f7023280d582f658189545500209e966d0587c5a2b30b32c62ae39f06c40fe72a68ffd2e1a89b9ac67401408ffafd4461fc69de5 SHA512 1be480609679f4b83690c8de4861088e8a1ad897da8086f2fcf458fe70b4f8c3ef350a1978e48b2b9fe4d3414b3f6d21d8c11df404c1c5b054a11fed756746f0
diff --git a/kde-plasma/kinfocenter/kinfocenter-6.0.0.ebuild b/kde-plasma/kinfocenter/kinfocenter-6.0.0.ebuild
new file mode 100644
index 0000000000..b4104eeaa0
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-6.0.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KFMIN=6.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.2
+inherit ecm plasma.kde.org optfeature
+
+DESCRIPTION="Utility providing information about the computer hardware"
+HOMEPAGE="https://userbase.kde.org/KInfoCenter"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="gles2-only usb"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gles2-only=,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kauth-${KFMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+ gles2-only? ( media-libs/mesa[gles2] )
+ usb? ( virtual/libusb:1 )
+"
+RDEPEND="${DEPEND}
+ dev-qt/qdbus:*
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-plasma/kde-cli-tools-${PVCUT}:*
+ >=kde-plasma/systemsettings-${PVCUT}:6
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package usb USB1)
+ -DCMAKE_DISABLE_FIND_PACKAGE_SeleniumWebDriverATSPI=ON # missing
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+
+ # TODO: Make this fully obsolete by /etc/os-release
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "NFS information module" net-fs/nfs-utils
+ optfeature "Samba status information module" net-fs/samba
+ optfeature "Vulkan graphics API information module" dev-util/vulkan-tools
+ optfeature "advanced CPU information module" sys-apps/util-linux
+ fi
+ optfeature "Wayland information module" app-misc/wayland-utils
+ optfeature "Firmware security module" "app-text/aha sys-apps/fwupd"
+ optfeature "OpenGL information module" x11-apps/mesa-progs
+ optfeature "PCI devices information module" sys-apps/pciutils
+ optfeature "X Server information module" x11-apps/xdpyinfo
+ ecm_pkg_postinst
+}